Skype refuses to connect [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

ReemZ
Old Dear Hen
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Skype refuses to connect [Solved]

Post by ReemZ » Tue Jan 24, 2012 22:34

After losing my homedir, I did a fresh install of the latest daily of SL x86_64 KDE (of 22 Jan) and after a bit of configging everything's back in working order...except for Skype. I've already removed (--configfiles) and reinstalled it, but still the result's the same: it won't login, it just keeps trying, and even sending a sigterm (kill, kill -15, killall) won't put it down, I have to send a sigkill (kill -9) for that. Launching Skype from a terminal gives me no output at all.
Only difference with the previous install is that I am now still using the default NetworkManager and until now it's been behaving a lot better than it used to, I've not (yet) replaced it with WICD. Could this have anything to do with it?

Edit 1: reported as Bug 3003

Edit 2: there's a long thread of possible solutions and workarounds by now, however they all seem to address the problem from a wrong angle. For those that don't want to fight through a nine-page thread or skip to what is currently the last post, the bottom line is: the problem is NOT PulseAudio.
Simply install a set of packages from Portage (they'll hit Entropy soon though):

Code: Select all

emerge --sync
emerge -av =app-emulation/emul-linux-x86-baselibs-20120127 app-emulation/emul-linux-x86-qtlibs app-emulation/emul-linux-x86-gtklibs
Edit 3: the abovementioned packages are in Entropy now, in the daily repository.
I'm sure they'll hit weekly soon ;)
Last edited by ReemZ on Sat Feb 11, 2012 3:54, edited 4 times in total.
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!

User avatar
sabayonino
Sagely Hen
Posts: 3279
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Skype refuses to connect

Post by sabayonino » Wed Jan 25, 2012 0:18

Does firewall running on your system ? [UFW]

check :

Code: Select all

# rc-update show | grep ufw
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

ReemZ
Old Dear Hen
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: Skype refuses to connect

Post by ReemZ » Wed Jan 25, 2012 1:04

Yeah it does (runlevel default, shouldn't this be boot?), just looking into it now.
Default incoming policy is Deny, default outgoing policy is Allow (makes sense).
No rules defined yet and when trying to add one I can't find Skype in the drop-down list though...
Little nudge please?
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!

ReemZ
Old Dear Hen
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: Skype refuses to connect

Post by ReemZ » Wed Jan 25, 2012 2:01

Disabled the firewall to test, both by unticking Firewall Status: Enabled and by /etc/init.d/ufw stop
Skype still doesn't connect though.
Here's a screenie of the options screen before attempting to connect.
However, there's no difference with the options in Skype on my desky and that does connect.
Any ideas?
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8116
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Skype refuses to connect

Post by Fitzcarraldo » Wed Jan 25, 2012 3:10

You wrote that you removed and reinstalled Skype, but try deleting just the file ~/Skype/your_Skype_username/config.xml and then launch Skype.

ReemZ
Old Dear Hen
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: Skype refuses to connect

Post by ReemZ » Wed Jan 25, 2012 3:56

Fitzcarraldo wrote:You wrote that you removed and reinstalled Skype, but try deleting just the file ~/Skype/your_Skype_username/config.xml and then launch Skype.

Code: Select all

[email protected] ~ $ ls -lR .Skype/
.Skype/:
total 12
drwxr-xr-x 2 reemz reemz 4096 Jan 24 18:30 shared_dynco
drwxr-xr-x 2 reemz reemz 4096 Jan 24 18:30 shared_httpfe
-rw-r--r-- 1 reemz reemz    0 Jan 24 18:30 shared.lck
-rw-r--r-- 1 reemz reemz 1192 Jan 24 21:43 shared.xml

.Skype/shared_dynco:
total 172
-rw-r--r-- 1 reemz reemz 102400 Jan 25 01:50 dc.db
-rw-r--r-- 1 reemz reemz  66176 Jan 25 01:50 dc.db-journal
-rw-r--r-- 1 reemz reemz      0 Jan 24 18:30 dc.lock

.Skype/shared_httpfe:
total 52
-rw-r--r-- 1 reemz reemz 36864 Jan 24 18:30 queue.db
-rw-r--r-- 1 reemz reemz 12824 Jan 24 18:30 queue.db-journal
-rw-r--r-- 1 reemz reemz     0 Jan 24 18:30 queue.lock
[email protected] ~ $
:(
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!

ezioze
Simple Hen
Posts: 47
Joined: Mon May 10, 2010 10:05

Re: Skype refuses to connect

Post by ezioze » Wed Jan 25, 2012 14:28

Same problem here. After last update Skype refuses to connect.
if i login as root all works well, so is not a fw problems.
i just tried chmod 777 -R on home/.Skype but no result.

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8116
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Skype refuses to connect

Post by Fitzcarraldo » Thu Jan 26, 2012 2:18

If Skype works when you log-in as root user, then it must be a permissions issue. I'm not on a Linux PC at the moment, but you need to find in which directory Skype is installed and then check its permissions and, if necessary, change them. For example, if the directory is /usr/local/share/skype then you would need to change the permissions using the following command as root user:

Code: Select all

# chmod 755 /usr/local/share/skype
Also, if several of you are experiencing the same problem then I recommend you file a bug report (see link Bugs at the top of this page).

ReemZ
Old Dear Hen
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: Skype refuses to connect

Post by ReemZ » Thu Jan 26, 2012 2:49

Code: Select all

[email protected] ~ $ which skype
/usr/bin/skype
[email protected] ~ $ ls -l /usr/bin | grep -i skype
-rwxr-xr-x 1 root root         230 Oct 26 08:34 skype
[email protected] ~ $
Seems permissions are in order, or am I looking at the wrong thing here?
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8116
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Skype refuses to connect

Post by Fitzcarraldo » Thu Jan 26, 2012 2:51

If I recall correctly, despite the "bin", /usr/bin/skype is a Bash script, not a binary. Keep looking for the rest of the Skype stuff in a directory.

Post Reply