My machine doesnt boot [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

My machine doesnt boot [Solved]

Postby gocool » Tue Dec 20, 2011 17:14

I updated my machine yesterday
(equo update && equo upgrade --ask)
and did a reboot and nothing comes up...
(and yes I did an equo conf update)
i mean not even the GRUB menu...just a cursor blinking. Please guide me what to do.
(GRUB loading stage 2 blinks for a moment and then the cursor starts to blink on a blank screen)

My config:
Sabayon 6.0
I have KDE, GNOME, LXDE environments
Acer laptop
160 GB HDD
2 GB RAM
Last edited by gocool on Wed May 23, 2012 17:58, edited 1 time in total.
gocool
Growing Hen
 
Posts: 139
Joined: Wed Aug 06, 2008 13:37

Re: My machine doesnt boot

Postby Fitzcarraldo » Fri Dec 23, 2011 12:06

What is your GPU? Boot the LiveDVD and chroot into your HDD installation (see HOWTO: chroot from a LiveCD), then use the command line to try and fix your installation.

To fix any incorrect libraries or dependencies:

Code: Select all
equo libtest
equo deptest
equo conf update

If that does not solve your problem then I suggest you try setting the kernel to the latest version you downloaded when upgrading: see Using Kernel Switcher.

If that does not solve your problem then check that you have the correct OpenGL libraries selected:

Code: Select all
eselect opengl list
eselect opengl set x

where x is:

"ati" (without the quotes) if you are using the closed-source FGLRX video driver.

"nvidia" (without the quotes) if you are using a closed-source NVIDIA video driver.

"xorg-x11" (without the quotes) if you are using an open-source video driver.

You can check what video driver you are using by looking in /etx/X11/xorg.conf:

Code: Select all
cat /etc/X11/xorg.conf | grep -i Driver

Driver "fglrx" is the closed-source FGLRX driver.

Driver "ati" is the open-source Radeon driver.

Driver "nv" is an open-source NVIDIA driver.

Driver "nouveau" is an open-source NVIDIA driver.

Driver "nvidia" is the closed-source NVIDIA driver.

EDIT: If /etc/X11/xorg.conf does not exist then look in /var/log/Xorg.0.log instead.

Also check that the following command has all the options set to "classic":

Code: Select all
eselect mesa list

If they are not, set each one to "classic". for example, to set 64bit r600 to "classic" use:

Code: Select all
eselect mesa set 64bit r600 classic

You can check what modules are loaded by using the command:

Code: Select all
lsmod | more

If you are using the closed-source nvidia video driver or the open-source nv driver but the Nouveau open-source module is being loaded, blacklist the Nouveau driver to stop it loading: see Re: Quit shipping nouveau with the kernel!.

If you are using the closed-source FGLRX driver but the open-source radeon kernel module is being loaded, stop the open-source kernel radeon module from loading by removing "radeon" from the file /etc/conf.d/modules if it is included in there.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: My machine doesnt boot [Solved]

Postby gocool » Wed May 23, 2012 18:01

Thank you Fitzcarraldo. This really helped.
gocool
Growing Hen
 
Posts: 139
Joined: Wed Aug 06, 2008 13:37


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 3 guests