can't get to login screen [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

can't get to login screen [Solved]

Postby succuba » Sun Aug 07, 2011 9:16

After installing the latest updates I can't get to the login screen.

I have a nvidia card and followed the advice given in the other thread but still can't get there.

I changed the driver to vesa in the xorg.conf file file but this did not work, any suggestions?

Thanks for your time
Last edited by succuba on Mon Aug 08, 2011 15:07, edited 1 time in total.
succuba
Young Hen
 
Posts: 24
Joined: Thu Jan 20, 2011 21:41

Re: can't get to login screen

Postby gosport_gaz » Sun Aug 07, 2011 9:44

I think that I have the same problem, but I don't think that its to do with the Nvidia driver. If I try to start any display manager I get:
Process 6972: arguments to dbus_connection_ref() were incorrect, assertion "connection !=NULL" failed in file /var/tmp/portage/sub-apps/dbus -1.4.12/work/bus-1.4.12/dbus/dbus-connections.c line 2626.
d-bus not built with -rdynamic so unable to print a backtrace.
.
I updated using the update manager running under Gnome, but I also have KDE on the system so the updates were both Gnome3 and KDE 4.7. I'm using an NVIDA 5200 board with a 173 driver.
Anyone got any ideas, or do I need to go back to square one.
gosport_gaz
Young Hen
 
Posts: 31
Joined: Sat Jul 10, 2010 11:08

Re: can't get to login screen

Postby succuba » Sun Aug 07, 2011 9:57

I don't get any error massages gaz I just get a flashing blinker in the top left hand corner
succuba
Young Hen
 
Posts: 24
Joined: Thu Jan 20, 2011 21:41

Re: can't get to login screen

Postby gosport_gaz » Sun Aug 07, 2011 10:28

If you press <alt F2> you should get a terminal up. log on as usual; then type su and enter you're password again - this should allow you to start the display manager - type GDM (or KDM if you're using KDE).
That's when I get the message.
If you get the same then there's another thread below this on the forum that might help, sorry but I didn't get the URL.
Gaz
gosport_gaz
Young Hen
 
Posts: 31
Joined: Sat Jul 10, 2010 11:08

Re: can't get to login screen

Postby succuba » Sun Aug 07, 2011 10:32

Got it... thanks

Mine starts - process 8119: but everything else is the same
succuba
Young Hen
 
Posts: 24
Joined: Thu Jan 20, 2011 21:41

Re: can't get to login screen

Postby succuba » Mon Aug 08, 2011 10:23

I have tried most of the things in both the related thread but to no avail, I wonder if someone would talk me through this issue to get me up and running again.

Thanks for your time
succuba
Young Hen
 
Posts: 24
Joined: Thu Jan 20, 2011 21:41

Re: can't get to login screen

Postby popsUlfr » Mon Aug 08, 2011 11:11

succuba wrote:I have tried most of the things in both the related thread but to no avail, I wonder if someone would talk me through this issue to get me up and running again.

Thanks for your time


Ok, let's try a fresh approach :P

Make sure again you have correct kernel+nvidia-drivers combination:
Code: Select all
equo update --force
equo upgrade
equo deptest

I assume you use the linux-sabayon kernel
Code: Select all
equo search linux-sabayon

check the versions that are installed (e.g.: linux-sabayon-3.0 etc...)
then
Code: Select all
equo search nvidia-drivers

each installed kernel needs its own nvidia package!
If not the case, install the missing one.
Code: Select all
eselect opengl list

the output needs to have nvidia selected, if not the case correct it with:
Code: Select all
eselect opengl set nvidia


Add the nvidia module to your /etc/conf.d/modules file to make sure it always gets loaded:
Code: Select all
modules="nvidia"


Remove your current xorg.conf file:
Code: Select all
rm /etc/X11/xorg.conf

Make sure 'x-setup' is on the boot or default runlevel by running (used for automatic x configuration):
Code: Select all
rc-status --all

otherwise just add it
Code: Select all
rc-update add x-setup boot


Make sure you have
Code: Select all
DISPLAYMANAGER="gdm"

set in your '/etc/conf.d/xdm' file (or kdm if you're using kde)
also make sure 'xdm' is on the boot or default runlevel with 'rc-status --all' otherwise add it:
Code: Select all
rc-update add xdm boot


Now reboot.

If it isn't working you may post your '/var/log/Xorg.0.log' and perhaps your generated '/etc/X11/xorg.conf' or just try these aswell:
Use nvidia's tool to generate a xorg.conf file by first removing your current xorg.conf
Code: Select all
rm /etc/X11/xorg.conf

then
Code: Select all
nvidia-xconfig

remove 'x-setup' from your boot runlevel
Code: Select all
rc-update del x-setup boot


Reboot or just try to restart your x server
Code: Select all
/etc/init.d/xdm restart


Other option (#1):
remove your xorg.conf
Code: Select all
rm /etc/X11/xorg.conf

remove 'x-setup' from your boot runlevel
Code: Select all
rc-update del x-setup boot

Add a file called '30-nvidia.conf' into
Code: Select all
/etc/X11/xorg.conf.d/

with these contents
Code: Select all
Section "Device"
   Identifier "Nvidia Card"
   Driver "nvidia"
EndSection


Reboot and see if it helps.

Other option(#2): Let's just try to start vanilla X.
You'll need to install a few packages for that:
Code: Select all
equo install twm
equo install xterm

remove 'xdm' from your boot runlevel
Code: Select all
rc-update del xdm boot

Reboot if you want otherwise make sure the xdm service isn't running
Code: Select all
/etc/init.d/xdm stop
/etc/init.d/xdm zap

Log in as normal user.
Move or delete any '.xinitrc' you might have in your personal directory
Code: Select all
cd
rm .xinitrc

Code: Select all
cd
mv .xinitrc .xinitrc.backup

then try to start x as normal user
Code: Select all
startx

you should see a minimal x desktop with clock and terminal. Retry these steps (if it didn't work out) by using nvidia-xconfig to generate a xorg.conf file. If it works then there's some issue with gnome's or kde's display manager. If it still doesn't work we may have to dissect Xorg logs and other logs.
popsUlfr
Young Hen
 
Posts: 34
Joined: Sun Aug 07, 2011 16:41

Re: can't get to login screen

Postby succuba » Mon Aug 08, 2011 11:29

Thanks for the help pops... hang in there I am going through your post now.
succuba
Young Hen
 
Posts: 24
Joined: Thu Jan 20, 2011 21:41

Re: can't get to login screen

Postby succuba » Mon Aug 08, 2011 12:18

OK, not much joy trying those things.

Firstly I can only get to the shell by pressing F2 after the "set map to UK" message on the screen. I can then enter using the verbose method but this does not pick up my LAN drivers and I cannot download anything.

Secondly :

Code: Select all
equo search linux-sabayon


check the versions that are installed (e.g.: linux-sabayon-3.0 etc...)
sys-kernel/linux-sabayon-2.6.39-r10 -- is installed
sys-kernel/linux-sabayon-3.0-r4 -- is not installed

Thirdly:

Add the nvidia module to your /etc/conf.d/modules file to make sure it always gets loaded:

Code: Select all
modules="nvidia"


How do I do this?

I tried everything else that's how it has taken so long but I still cannot get to the login screen only the flashing curser in the top left hand corner.

Would it be OK just to re install sabayon with a new downloaded DVD? or is that not the way.


Sorry for being such a NOOB
succuba
Young Hen
 
Posts: 24
Joined: Thu Jan 20, 2011 21:41

Re: can't get to login screen

Postby popsUlfr » Mon Aug 08, 2011 12:20

succuba wrote:Thanks for the help pops... hang in there I am going through your post now.


Ah, yes one thing I missed if you generate a xorg.conf file with the nvidia tool after you created that 30-nvidia.conf file you should remove or move the 30-nvidia.conf out of the xorg.conf.d folder before trying to start the x server :)
popsUlfr
Young Hen
 
Posts: 34
Joined: Sun Aug 07, 2011 16:41

Next

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest