segmentation fault

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

amitvn
Simple Hen
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

segmentation fault

Post by amitvn » Sat Aug 06, 2011 22:40

Code: Select all

[email protected] ~ $ mail-notification 
Segmentation fault
any solution for this?
Love Sabayon <3

amitvn
Simple Hen
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: segmentation fault

Post by amitvn » Sun Aug 07, 2011 6:52

one more segmentation fault

Code: Select all

[email protected] ~ $ soundconverter 
SoundConverter 1.5.4
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
  using Gstreamer version: 0.10.35
  using gio
  using 2 thread(s)

(soundconverter:9667): libglade-WARNING **: could not convert string to type `GValueArray' for property `authors'

(soundconverter:9667): libglade-WARNING **: could not convert string to type `GValueArray' for property `documenters'
/usr/bin/soundconverter:2859: GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
  glade = gtk.glade.XML(GLADE)
Segmentation fault
Love Sabayon <3

micia
Sagely Hen
Posts: 2718
Joined: Wed Nov 26, 2008 16:41
Contact:

Re: segmentation fault

Post by micia » Mon Aug 08, 2011 11:44

A segmentation fault is not enough to spot the problem, a segmentation fault is a signal (SIGSEGV) that is sent to a process when the process' memory is corrupted.
It is a very noticeable sign of an error in the program's code.
Even if it is possible to handle this signal, it is not a good idea since the application cannot rely on the good state of its memory.

A segmentation fault of a program is, in the general case, not related to a segmentation fault of another program.
You should search for some other clues to find out what is wrong (and it is also possible that what is wrong is the code of the application itself), for example, did this always happened? Did you update some package and then this issue showed up? Is this issue reproducible?

amitvn
Simple Hen
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: segmentation fault

Post by amitvn » Mon Aug 08, 2011 13:56

this was not the problem when i was using limbo and gnome 3 testing
but when gnome 3 moved to official repo and i updated system this problem started..
i am using mail notification in gnome 3 from start of testing..it ws working fine and suddenly was not starting so i checked and found this error
Love Sabayon <3

amitvn
Simple Hen
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: segmentation fault

Post by amitvn » Mon Aug 08, 2011 14:25

and this was also strange that nautilus freezing several times..

Code: Select all

[email protected] ~ $ nautilus
Timeout was reached
so was unable to browse files also and only one way to try at next boot
Love Sabayon <3

popsUlfr
Young Hen
Posts: 34
Joined: Sun Aug 07, 2011 16:41

Re: segmentation fault

Post by popsUlfr » Tue Aug 09, 2011 16:31

amitvn wrote:and this was also strange that nautilus freezing several times..

Code: Select all

[email protected] ~ $ nautilus
Timeout was reached
so was unable to browse files also and only one way to try at next boot
What do

Code: Select all

equo deptest

Code: Select all

equo libtest
say?

Did you at any point install another major gcc version and switch profile with

Code: Select all

gcc-config -l
?
I'm just saying this because switching gcc profile without fixing libraries makes almost everything segfault like crazy.
Other than that reinstalling pygobject and pygtk might be an idea(?).

Code: Select all

equo install pygobject pygtk
using python's updater to find broken packages maybe ?

Code: Select all

python-updater -p
(the -p will prevent any potentially broken packages to be emerged)
But are mail-notification or nautilus using python?

amitvn
Simple Hen
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: segmentation fault

Post by amitvn » Tue Aug 09, 2011 19:14

i already did libtest and deptest doesn't work that way..
updatin python components also neither helped..
https://wiki.archlinux.org/index.php/GN ... _to_launch
looking at above url seems like some issue with gnome itself but never came accross while was in testing repo. :(
Love Sabayon <3

micia
Sagely Hen
Posts: 2718
Joined: Wed Nov 26, 2008 16:41
Contact:

Re: segmentation fault

Post by micia » Tue Aug 09, 2011 19:16

I am not facing them either.

I see that mail-notification depends on some packages that belong to the old Gnome, have you tried to remove it and see if, without the old Gnome packages, it works fine?

On my system, if I want to install mail-notification, I get:

Code: Select all

equo install mail-notification --ask
>>  @@ These are the chosen packages:
>>    # (1/1) [sabayonlinux.org] mail-client/mail-notification-5.4-r4
>>     Versions: Not installed / NoTag / NoRev ===> 5.4-r4 / NoTag / 2
>> 	Action:		 Install
>>  @@ Packages involved: 1
     Would you like to continue with dependencies calculation ? [Yes/No] y
>>  @@ Calculating dependencies ...
>>  @@ These are the packages that would be installed:
>>  ## [N] [sabayonlinux.org] gnome-base/libgnomecanvas-2.30.3|0
>>  ## [N] [sabayonlinux.org] gnome-base/gnome-mime-data-2.18.0|3
>>  ## [N] [sabayonlinux.org] gnome-base/gnome-vfs-2.24.4-r1|1
>>  ## [N] [sabayonlinux.org] gnome-base/libgnome-2.32.1|0
>>  ## [N] [sabayonlinux.org] gnome-base/libbonoboui-2.24.4-r1|1
>>  ## [N] [sabayonlinux.org] gnome-base/libgnomeui-2.24.5|1
>>  ## [N] [sabayonlinux.org] mail-client/mail-notification-5.4-r4|2
>>  @@ Packages needing to be installed/updated/downgraded: 7
>>  @@ Packages needing to be removed: 0
>>  @@ Packages needing to be installed: 7
>>  @@ Packages needing to be reinstalled: 0
>>  @@ Packages needing to be updated: 0
>>  @@ Packages needing to be downgraded: 0
>>  @@ Download size: 5.6MB
>>  @@ Used disk space: 49.9MB
>>  @@ You need at least: 61.2MB of free space
     Would you like to execute the queue ? [Yes/No] 

amitvn
Simple Hen
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: segmentation fault

Post by amitvn » Tue Aug 09, 2011 19:26

seems like llibrary gnome-base/libgnomecanvas causing both problems as when i try to remove it it tells to remove many older libs and also mail-notification and soundconverter which are exactly apps giving errors
Love Sabayon <3

popsUlfr
Young Hen
Posts: 34
Joined: Sun Aug 07, 2011 16:41

Re: segmentation fault

Post by popsUlfr » Tue Aug 09, 2011 20:43

amitvn wrote:seems like llibrary gnome-base/libgnomecanvas causing both problems as when i try to remove it it tells to remove many older libs and also mail-notification and soundconverter which are exactly apps giving errors
May

Code: Select all

equo --empty <appsthatsegfault>
help perhaps?

It will pull in and reinstall all dependencies aswell.

Post Reply