Keyboard layout doesn't apply to the login screen [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
djoco
Baby Hen
Posts: 2
Joined: Sun May 15, 2011 21:48

Keyboard layout doesn't apply to the login screen [Solved]

Post by djoco » Tue May 17, 2011 21:24

Today, I installed SabayonLinux x86 KDE in my "old" computer (it is only 6 years old) and I selected the language and keyboard layout (es_ES and qwerty-es) using the instalation wizard instead of the boot screen because I used unetbootin.
Now the keyboard works fine everywhere except at the login screen. There the keyboard writes using the US keymap. At the terminals, the keymap is OK.

How can I change my X login keyboard layout to ES?
Last edited by djoco on Thu May 19, 2011 6:45, edited 1 time in total.

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8116
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Keyboard layout doesn't apply to the login screen

Post by Fitzcarraldo » Tue May 17, 2011 21:56

All the below must be done as root user.

1. Make sure /etc/conf.d/keymaps has keymap="es" (this is for the console).

2. Add the following to /etc/X11/xorg.conf and reboot:

Code: Select all

Section "InputClass"
    Identifier             "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option                 "XkbLayout" "es"
EndSection
If the above two steps alone do not fix it, carry on with the following steps:

3. Edit the file /etc/env.d/02locale and make it:

Code: Select all

LANG="es_ES.UTF-8"
LC_MESSAGES="es_ES.UTF-8"
LANGUAGE="es_ES.UTF-8"
GDM_LANG="es_ES.UTF-8"
LC_CTYPE="es_ES.UTF-8"
LC_NUMERIC="es_ES.UTF-8"
LC_TIME="es_ES.UTF-8"
LC_COLLATE="es_ES.UTF-8"
LC_MONETARY="es_ES.UTF-8"
LC_PAPER="es_ES.UTF-8"
LC_NAME="es_ES.UTF-8"
LC_ADDRESS="es_ES.UTF-8"
LC_TELEPHONE="es_ES.UTF-8"
LC_MEASUREMENT="es_ES.UTF-8"
LC_IDENTIFICATION="es_ES.UTF-8"
SYSFONT="latarcyrheb-sun16"
then update the environment:

Code: Select all

env-update && source /etc/profile
4. Edit the file /etc/locale.gen and make it the following (you can just comment out the other locales rather than deleting them if you want):

Code: Select all

es_ES ISO-8859-1
es_ES.UTF-8 UTF-8
5. Enter the command:

Code: Select all

locale-gen
6. If you're using KDE, make sure you have selected Spanish language and Spanish keyboard layout via, respectively, Kickoff > System Settings > Locale | Languages | Preferred Languages and Kickoff > System Settings > Input Devices > Keyboard | Layouts | Add Layout.

Thev00d00
Generally Awesome (tm)
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom
Contact:

Re: Keyboard layout doesn't apply to the login screen

Post by Thev00d00 » Tue May 17, 2011 22:12

check your bootline too, mine has keymap=gb :wink:
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me

djoco
Baby Hen
Posts: 2
Joined: Sun May 15, 2011 21:48

Re: Keyboard layout doesn't apply to the login screen

Post by djoco » Thu May 19, 2011 6:45

The first solution worked for me.
Fitzcarraldo wrote:All the below must be done as root user.

1. Make sure /etc/conf.d/keymaps has keymap="es" (this is for the console).

2. Add the following to /etc/X11/xorg.conf and reboot:

Code: Select all

Section "InputClass"
    Identifier             "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option                 "XkbLayout" "es"
EndSection
# echo '
Section "InputClass"
Identifier "Keyboard Defaults"
MatchIsKeyboard "yes"
Option "XkbLayout" "es"
EndSection' >> /etc/X11/xorg.conf
# reboot

Thank you!

Post Reply