how to downgrade a package? [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
dragonauta
Simple Hen
Posts: 52
Joined: Thu Mar 11, 2010 11:13

how to downgrade a package? [Solved]

Post by dragonauta » Wed Feb 09, 2011 14:23

I updated ATI driver (xf86-video-ati) from 6.13 to 6.14
Now I got a black screen in every console, graphic and text. (I selected vesa driver as a workaround)

I want to know if it's possible to downgrade that package.
I don't see any option using equo.
Should I use emerge?
thanks

Fitzcarraldo
Sagely Hen
Posts: 8218
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: how to downgrade a package?

Post by Fitzcarraldo » Wed Feb 09, 2011 16:27

Have you installed the latest version of the X.Org Server from the Entropy Repository? Try that first. For example, when one compiles a new version of xorg-server, one has to recompile all the X.Org drivers such as xf86-video-ati (even if the version has not changed). So maybe that would do it (although if xf86-video-vesa works then probably not, but it's worth a shot). If it doesn't solve your problem then downgrade via Portage:

Code: Select all

$ su
Password:
# emerge --sync
# layman -a sabayon # Don't worry if it says the overlay is already added.
# layman -S
# emerge -1v =xf86-video-ati-<version number you want to install>
# equo rescue spmsync
The last line is to tell Entropy what you did via Portage.

You can mask the package in Entropy to stop Entropy trying to install the Entropy package when you next do an equo update && equo upgrade.

dragonauta
Simple Hen
Posts: 52
Joined: Thu Mar 11, 2010 11:13

Re: how to downgrade a package?

Post by dragonauta » Wed Feb 09, 2011 18:40

I have my SL fully updated.
xorg-server-1.9.3-r1
xorg-x11-7.4-r1

I try reinstalling X. Changed to radeon driver, reboot, but same effects. Black screen.
Then I access through ssh and looked into /var/log.
I found that X server crashes with seg fault. Here's the last part of Xorg.0.log

Code: Select all

[    24.438] (II) RADEON(0): Largest offscreen area available: 1536 x 6749
[    24.451] (II) RADEON(0): RADEONRestoreMemMapRegisters() : 
[    24.451] (II) RADEON(0):   MC_FB_LOCATION   : 0x00df00d0 0x003f0000
[    24.451] (II) RADEON(0):   MC_AGP_LOCATION  : 0x003f0000
[    24.461] (==) RADEON(0): Backing store disabled
[    24.461] (WW) RADEON(0): Direct rendering disabled
[    24.461] (EE) RADEON(0): Acceleration initialization failed
[    24.461] (II) RADEON(0): Acceleration disabled
[    24.461] (**) RADEON(0): DPMS enabled
[    24.461] (==) RADEON(0): Silken mouse enabled
[    24.462] (II) RADEON(0): Will use 32 kb for hardware cursor 0 at offset 0x00873000
[    24.462] (II) RADEON(0): Will use 32 kb for hardware cursor 1 at offset 0x00879000
[    24.462] (II) RADEON(0): Largest offscreen area available: 1536 x 6741
[    24.462] (II) RADEON(0): Textured video requires CP on R5xx/R6xx/R7xx/IGP
[    24.490] 
Backtrace:
[    24.490] 0: /usr/bin/X (xorg_backtrace+0x28) [0x4a16d8]
[    24.490] 1: /usr/bin/X (0x400000+0x63809) [0x463809]
[    24.490] 2: /lib/libpthread.so.0 (0x7f9691f6c000+0xf120) [0x7f9691f7b120]
[    24.490] 3: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7f968f08e000+0xe16cd) [0x7f968f16f6cd]
[    24.490] 4: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7f968f08e000+0xe2d0f) [0x7f968f170d0f]
[    24.490] 5: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7f968f08e000+0x8f932) [0x7f968f11d932]
[    24.490] 6: /usr/bin/X (xf86SetDesiredModes+0x1f3) [0x489ee3]
[    24.490] 7: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7f968f08e000+0x4af99) [0x7f968f0d8f99]
[    24.490] 8: /usr/bin/X (AddScreen+0x1cb) [0x42a3ab]
[    24.490] 9: /usr/bin/X (InitOutput+0x2d5) [0x4720e5]
[    24.490] 10: /usr/bin/X (0x400000+0x245ad) [0x4245ad]
[    24.490] 11: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7f969115ebbd]
[    24.490] 12: /usr/bin/X (0x400000+0x242f9) [0x4242f9]
[    24.490] Segmentation fault at address 0x1b0
[    24.490] 
Fatal server error:
[    24.490] Caught signal 11 (Segmentation fault). Server aborting
[    24.490] 
[    24.490] 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
I'll try to downgrade radeon driver
Thanks Fitzcarraldo

smb96
Simple Hen
Posts: 70
Joined: Mon Nov 23, 2009 11:44

Re: how to downgrade a package?

Post by smb96 » Thu Feb 10, 2011 10:07

Which Kernel do you use? You should try .37, if you are using a different one.

dragonauta
Simple Hen
Posts: 52
Joined: Thu Mar 11, 2010 11:13

Re: how to downgrade a package?

Post by dragonauta » Thu Feb 10, 2011 14:05

Thanks smb96.
I'm rolling SL since 5.1 version.

I have .37 kernel and fully updated packages.
Last upgrade installed xf86-video-ati-6.14.0 and it fails.

I follow Fitzcarraldo's steps and I was able to downgrade 6.14 to 6.12.6.
Now my X works perfectly.

joost
Sagely Hen
Posts: 2805
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: how to downgrade a package? [Solved]

Post by joost » Fri Feb 11, 2011 10:56

regarding the OS ati driver.
Did you load the radeon kernel module and also did you remove the ati-drivers (fglrx) from your system?

Edit /etc/conf.d/modules and add modules=”radeon” at the end of the file

The driver has been in Limbo a few days and nobody reported any problems with it (nor have I).
What graphics chipset does your system use anyway?

Also have a look here:
http://joostruis.wordpress.com/2011/01/ ... -catalyst/
My blog | Mastodon | Please support Sabayon: Become a Patron

lxnay
Land Owner
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy
Contact:

Re: how to downgrade a package? [Solved]

Post by lxnay » Fri Feb 11, 2011 11:53

I don't see any log. How do you expect us to fix it :D
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+

dragonauta
Simple Hen
Posts: 52
Joined: Thu Mar 11, 2010 11:13

Re: how to downgrade a package? [Solved]

Post by dragonauta » Fri Feb 11, 2011 12:45

Thanks both joost and lxnay.
Try again upgrading to 6.14

I don't have fglrx in my system.
Checked double time for modules and radeon is already included into modules line.
I have a RV730 chip.

# lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV730 PRO [Radeon HD 4650]

I'm opening a bug report. I saved old logs and then deleted them so when booting I'll have 'clean' logs just with the seg fault.
I will include Xorg.0.log, kdm.log and messages

Post Reply