Can't Update Entropy

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Post Reply
adam-red
Baby Hen
Posts: 7
Joined: Wed Aug 04, 2010 21:56

Can't Update Entropy

Post by adam-red » Wed Aug 04, 2010 22:20

I've just installed 5.3 x64 Gnome and Sabayon seems nice but it won't let me apply any of the updates. Apparently I should use the command:

Code: Select all

equo install entropy equo --nodeps && equo upgrade
But when I do I get the following error:

Code: Select all

>> 
>> Entropy/Equo version mismatch: it could make your system explode!
>> (0.99.46.9 [equo] & 0.99.49.6 [entropy])
>> 
>> Hi. My name is Bug Reporter. I am sorry to inform you that Equo crashed. Well, you know, shit happens.
>> But there's something you could do to help Equo to be a better application.
>> -- EVEN IF I DON'T WANT YOU TO SUBMIT THE SAME REPORT MULTIPLE TIMES --
>> Now I am showing you what happened. Don't panic, I'm here to help you.
Traceback (most recent call last):
  File "/usr/bin/equo", line 950, in <module>
    main_rc = main()
  File "/usr/bin/equo", line 933, in main
    rc = cmd_cb(main_cmd, options)
  File "/usr/bin/equo", line 390, in _do_text_ui
    return text_ui.package([main_cmd] + options)
  File "/usr/lib/entropy/client/text_ui.py", line 193, in package
    recursive = e_req_recursive)
  File "/usr/lib/entropy/client/text_ui.py", line 1275, in install_packages
    print_info(darkred(" ##")+flags+repoinfo+enlightenatom(pkgatom)+"|"+red(str(pkgrev))+oldinfo)
  File "/usr/lib/entropy/client/text_tools.py", line 296, in enlightenatom
    operator = entropy.tools.get_operator(clean_atom)
AttributeError: 'module' object has no attribute 'get_operator'

Frame enlightenatom in /usr/lib/entropy/client/text_tools.py at line 296 
	                atom = u'sys-apps/entropy-0.99.49.6'
	            only_cpv = u'sys-apps/entropy-0.99.49.6'
	         entropy_rev = ''
	         entropy_tag = ''
	          clean_atom = u'sys-apps/entropy-0.99.49.6'
 
>> Of course you are on the Internet...
Erm... Can I send the error, along with some information
about your hardware to my creators so they can fix me? (Your IP will be logged) [Yes/No]
Any ideas?

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Can't Update Entropy

Post by wolfden » Thu Aug 05, 2010 0:24

hmmmm, first time I seen that, wonder how you did that....

You can always reinstall entropy, equo, sulfur through the overlay.

layman -d sabayon
layman -a sabayon
emerge --sync
emerge entropy equo sulfur
equo update
equo upgrade

adam-red
Baby Hen
Posts: 7
Joined: Wed Aug 04, 2010 21:56

Re: Can't Update Entropy

Post by adam-red » Thu Aug 05, 2010 12:32

Ta mate, that and a reboot sorted the problem.

jcgg
Young Hen
Posts: 28
Joined: Mon Dec 28, 2009 2:37

Re: Can't Update Entropy

Post by jcgg » Fri Aug 06, 2010 15:09

I have the same problem. I cannot even use the GUI for system settings, I have to use Konsole kdesu systemsettings.

Post Reply