Anoying "biip" sound when turning on and off pc [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Post Reply
altairz
Simple Hen
Posts: 59
Joined: Mon Oct 26, 2009 18:02

Anoying "biip" sound when turning on and off pc [Solved]

Post by altairz » Wed May 12, 2010 17:06

When I turn off my computer, this sound comes. Also when I come to the login menu when I start up.

Before I have opened the blacklist.conf and added "blacklist pcspkr" in a own line. This have worked before with sabayon 5.0. But it didn't seem to work with 5.2.

Here is the sound I'm talking about:
http://www.youtube.com/watch?v=dhExp1WRwYA

How can I remove this sound?
Last edited by altairz on Mon May 17, 2010 15:25, edited 2 times in total.

dexter
Baby Hen
Posts: 12
Joined: Sun Dec 21, 2008 17:58
Location: Cosenza, Italy

Re: Anoying "biip" sound when turning on and off pc

Post by dexter » Fri May 14, 2010 10:09

Just tick the speaker off :mrgreen: :mrgreen: :mrgreen:
Dex

altairz
Simple Hen
Posts: 59
Joined: Mon Oct 26, 2009 18:02

Re: Anoying "biip" sound when turning on and off pc

Post by altairz » Fri May 14, 2010 17:18

dexter wrote:Just tick the speaker off :mrgreen: :mrgreen: :mrgreen:


Yeah, and what if I want to listen to music or something? :P

Stupot
Sagely Hen
Posts: 1629
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Anoying "biip" sound when turning on and off pc

Post by Stupot » Fri May 14, 2010 20:57

The 'biip" sound you are hearing is coming from your motherboard and not through your speakers, correct?

That can be disabled via motherboard settings or physically unplugging the right wire to your motherboard...

If this sound beeps before the kernel is even loaded or before grub is loaded, then you will need to change it via the motherboard settings as no linux settings have taken effect yet.

altairz
Simple Hen
Posts: 59
Joined: Mon Oct 26, 2009 18:02

Re: Anoying "biip" sound when turning on and off pc

Post by altairz » Fri May 14, 2010 21:20

Stupot wrote:The 'biip" sound you are hearing is coming from your motherboard and not through your speakers, correct?

That can be disabled via motherboard settings or physically unplugging the right wire to your motherboard...

If this sound beeps before the kernel is even loaded or before grub is loaded, then you will need to change it via the motherboard settings as no linux settings have taken effect yet.


Not realy sure where it comes from, but I think they come from the speakers. Cause when I turn of the sound on the speakers, the sound disappear. Can it still be from the motherboard then? if so, how do I change the motherboard settings?

Someone sugested that I might could turn off the sound in the preferences in the login manager. But he didn't know how to do it in sabayon. Could he be right about this?

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8091
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Anoying "biip" sound when turning on and off pc

Post by Fitzcarraldo » Fri May 14, 2010 23:08

How precisely are you blacklisting the pcspkr module, because the old way of doing it was in /etc/modules.d/ but the current way of doing it is in /etc/modprobe.d/?

Code: Select all

# echo "blacklist pcspkr" >>/etc/modprobe.d/blacklist.conf
# update-modules

and then look in /etc/modprobe.conf to see if the module is blacklisted and, if it is, reboot and use:

Code: Select all

lsmod

to check that the module is not loaded this time.

altairz
Simple Hen
Posts: 59
Joined: Mon Oct 26, 2009 18:02

Re: Anoying "biip" sound when turning on and off pc

Post by altairz » Fri May 14, 2010 23:51

Fitzcarraldo wrote:How precisely are you blacklisting the pcspkr module, because the old way of doing it was in /etc/modules.d/ but the current way of doing it is in /etc/modprobe.d/?

Code: Select all

# echo "blacklist pcspkr" >>/etc/modprobe.d/blacklist.conf
# update-modules

and then look in /etc/modprobe.conf to see if the module is blacklisted and, if it is, reboot and use:

Code: Select all

lsmod

to check that the module is not loaded this time.


I did the two first commands, and then used gedit to look in "/etc/modprobe.conf", but the file was empty.

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Anoying "biip" sound when turning on and off pc

Post by wolfden » Sat May 15, 2010 5:40

did you do it as root?

errors reported running them?

altairz
Simple Hen
Posts: 59
Joined: Mon Oct 26, 2009 18:02

Re: Anoying "biip" sound when turning on and off pc

Post by altairz » Sat May 15, 2010 10:37

wolfden wrote:did you do it as root?

errors reported running them?


Yes, I did everything as root. And no errors was reported.
But I tried to do it again, and when I then typed in "update-modules", I got this message:

"* Warning: /etc/modprobe.conf has not been automatically generated
* Use "update-modules force" to force (re)generation"

Then I typed in "update-modules force", and got this message:

"* Warning: /etc/modprobe.conf has not been automatically generated
* --force specified, (re)generating file anyway
* Updating modules.conf...
* Updating modules.dep..."

Any other ideas on how to move this sound?
It was so easy with the 5.0 version, why have it been so hard now?

altairz
Simple Hen
Posts: 59
Joined: Mon Oct 26, 2009 18:02

Re: Anoying "biip" sound when turning on and off pc

Post by altairz » Mon May 17, 2010 15:24

Finnaly found the solution! :D So here is what I did:

# echo "blacklist snd_pcsp" >>/etc/modprobe.d/blacklist.conf
# update-modules

First I tried to blacklist "pcspkr", but it dosn't work for the new kernels. Is seems that from kernel 2.6.27, the "pcspkr" have changed the name to "snd_pcsp".

So if you run those two commands as root, the sound should be removed, as long as you have kernel 2.6.27 or newer. If you have an older kernel, you probably have to change "snd_pcsp" to "pcspkr".
And you have to restart, in order for the changes to take effect.

Post Reply