entropy update issues [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

entropy update issues [Solved]

Postby bloodyscript » Wed Apr 28, 2010 21:59

hi i recently purchased a new computer and have been trying to install sabayon for some time now. the first attempt was 5.1 gnome 64 edition it installed but i could not update or use entropy or emerge. so since it was a new installation rather than trying to figure out why the problem was happening i decided to re download of 5.2 gnome 64 edition. with no luck was i able to even install the operating system due to some error i dont remember. so i assumed it was the disc i burned i then re downloaded and re burned the disc. again the error happened so i re downloaded but this time 5.2 kde 64 edition, this time it finally installed and everything is working except again entropy needs to be updated. now i went to http://wiki.sabayon.org/index.php?title=Entropy followed the instructions. heres what happened

the end tail of layman --sync sabayon
Code: Select all
 rename x11-themes/sabayon-artwork-core/{sabayon-artwork-core-5.2_beta1.ebuild => sabayon-artwork-core-5.2.ebuild} (100%)
 rename x11-themes/sabayon-artwork-extra/{sabayon-artwork-extra-5.2_beta1.ebuild => sabayon-artwork-extra-5.2.ebuild} (100%)
 rename x11-themes/sabayon-artwork-gnome/{sabayon-artwork-gnome-5.2_beta1.ebuild => sabayon-artwork-gnome-5.2.ebuild} (100%)
 create mode 100644 x11-themes/sabayon-artwork-kde/sabayon-artwork-kde-5.2.ebuild
 delete mode 100644 x11-themes/sabayon-artwork-kde/sabayon-artwork-kde-5.2_beta1.ebuild
 rename x11-themes/sabayon-artwork-ooo/{sabayon-artwork-ooo-5.2_beta1.ebuild => sabayon-artwork-ooo-5.2.ebuild} (100%)
*
* Success:
* ------
*
* Successfully synchronized overlay "sabayon".


emerge entropy and sulfur
Code: Select all
junmangand apefu # emerge entropy sulfur

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "sys-apps/entropy" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/entropy-0.99.41.2 (masked by: corruption)
- sys-apps/entropy-0.99.41.1 (masked by: corruption)
- sys-apps/entropy-0.99.41 (masked by: corruption)
- sys-apps/entropy-0.99.40.4 (masked by: corruption)
- sys-apps/entropy-0.99.40.3 (masked by: corruption)
- sys-apps/entropy-0.99.40.2 (masked by: corruption)
- sys-apps/entropy-0.99.40.1 (masked by: corruption)
- sys-apps/entropy-0.99.40 (masked by: corruption)
- sys-apps/entropy-0.99.39 (masked by: corruption)
- sys-apps/entropy-0.99.38.7 (masked by: corruption)
- sys-apps/entropy-0.99.38.6 (masked by: corruption)
- sys-apps/entropy-0.99.38.5 (masked by: corruption)
- sys-apps/entropy-0.99.38.4 (masked by: corruption)
- sys-apps/entropy-0.99.38.3 (masked by: corruption)
- sys-apps/entropy-0.99.38.2 (masked by: corruption)
- sys-apps/entropy-0.99.38.1 (masked by: corruption)
- sys-apps/entropy-0.99.38 (masked by: corruption)
- sys-apps/entropy-0.99.37.2 (masked by: corruption)
- sys-apps/entropy-0.99.37.1 (masked by: corruption)
- sys-apps/entropy-0.99.37 (masked by: corruption)
- sys-apps/entropy-0.99.36.3 (masked by: corruption)
- sys-apps/entropy-0.99.36.2 (masked by: corruption)
- sys-apps/entropy-0.99.36.1 (masked by: corruption)
- sys-apps/entropy-0.99.36 (masked by: corruption)
- sys-apps/entropy-0.99.35.9 (masked by: corruption)
- sys-apps/entropy-0.99.35.8-r1 (masked by: corruption)
- sys-apps/entropy-0.99.35.8 (masked by: corruption)


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


equo update
Code: Select all
junmangand apefu # equo update
>>      [sabayon.org:1026] Successfully connected to host
>>      [sabayon.org:1026] Successfully disconnected from host
>>  @@ Repositories synchronization ...
>>   #  (1/1) Sabayon Linux Official Repository
>>   # Database URL: http://pkg.sabayon.org/standard/sabayonlinux.org/database/amd64/5                                                                         
>>   # Database local path: /var/lib/entropy/client/database/amd64/sabayonlinux.org/standard/amd64/5                                                           
>>   # Database EAPI: 3
>>      [sabayon.org:1026] Successfully connected to host
>>      [sabayon.org:1026] Successfully disconnected from host
>>      Attention: database is already up to date.
>>  !!! Entropy: a new release is available. Mind to install it before any other package.                                                                       
>>  @@  Notice board: sabayonlinux.org
>>     [0] [Fri, 12 Feb 2010 11:34:08 +0000] Title: Entropy update required (please read!)                                                                     
>>     [1] [Fri, 12 Feb 2010 11:37:07 +0000] Title: Wireless issues after KDE 4.4 update                                     
 


end tail of equo install entropy sulfur
Code: Select all
>>    ## Package checksum matches: media-libs:jpeg-8a~0.tbz2
>>    ## Package signature verification error for: GPG, cannot verify file /var/lib/entropy/packages/amd64/5/media-libs:jpeg-8a~0.tbz2, exit status 2
>>    ## Package signature: GPG does not match the recorded one
>>    ## Checksum does not match. Download attempt #5
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it
>>    ## ( mirror #1 ) Successfully downloaded from: na.mirror.garr.it at 0.0b/second
>>    ## Package checksum matches: media-libs:jpeg-8a~0.tbz2
>>    ## Package signature verification error for: GPG, cannot verify file /var/lib/entropy/packages/amd64/5/media-libs:jpeg-8a~0.tbz2, exit status 2
>>    ## Package signature: GPG does not match the recorded one
>>    ## Checksum does not match. Download attempt #6
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it
>>    ## ( mirror #1 ) Successfully downloaded from: na.mirror.garr.it at 0.0b/second
>>    ## Cannot fetch package or checksum does not match.
>>    ## Try to download latest repositories.
>>    ## An error occured. Action aborted.
>>  @@ Download incomplete.
>>  @@ Configuration files scan complete.


now im not sure whats happening the masked files are they masked because they can cause corruption or are they masked becuase they are corrupted?

whats causeing the checksum not to match the dependency download or why wouldnt it be able to fetch the file?
and thank you for the furture help and information
Last edited by bloodyscript on Fri Apr 30, 2010 13:54, edited 1 time in total.
bloodyscript
Simple Hen
 
Posts: 43
Joined: Tue Nov 11, 2008 22:23

Re: entropy update issues

Postby wolfden » Wed Apr 28, 2010 22:37

you don't need to emerge the package manager as it already is there, it looks like you didn't emerge --sync first

try equo update --force && equo install entropy equo sulfur && equo update
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: entropy update issues

Postby bloodyscript » Thu Apr 29, 2010 2:50

it still gave me the same error when downloading but found a new error: Error during GPG verification of: packages.db.meta
>> !!! It could mean a potential security risk: cannot verify file /var/lib/entropy/client/database/amd64/sabayonlinux.org/standard/amd64/5/packages.db.meta, exit status 2


begining of equo update --force && equo install entropy equo sulfur && equo update
Code: Select all
junmangand apefu # equo update --force && equo install entropy equo sulfur && equo update
[sabayon.org:1026] Successfully connected to host
>>      [sabayon.org:1026] Successfully disconnected from host
>>  @@ Repositories synchronization ...
>>   #  (1/1) Sabayon Linux Official Repository
>>   # Database URL: http://pkg.sabayon.org/standard/sabayonlinux.org/database/amd64/5                                                                         
>>   # Database local path: /var/lib/entropy/client/database/amd64/sabayonlinux.org/standard/amd64/5                                                           
>>   # Database EAPI: 3
>>      [sabayon.org:1026] Successfully connected to host
>>      [sabayon.org:1026] Successfully disconnected from host
>>      Downloading repository database ...
>>      Downloading checksum packages.db.dumplight.bz2.md5 ...
>>      packages.db.meta: available, w00t!.
>>        << unpacked meta file: ca.cert
>>        << unpacked meta file: make.conf
>>        << unpacked meta file: make.profile
>>        << unpacked meta file: package.keywords
>>        << unpacked meta file: package.mask
>>        << unpacked meta file: package.unmask
>>        << unpacked meta file: package.use
>>        << unpacked meta file: packages.db.conflicting_tagged
>>        << unpacked meta file: packages.db.critical
>>        << unpacked meta file: packages.db.keywords
>>        << unpacked meta file: packages.db.lic_whitelist
>>        << unpacked meta file: packages.db.mask
>>        << unpacked meta file: packages.db.post_update.sh
>>        << unpacked meta file: packages.db.post_upgrade.sh
>>        << unpacked meta file: packages.db.restricted
>>        << unpacked meta file: packages.db.revision
>>        << unpacked meta file: packages.db.system_mask
>>        << unpacked meta file: server.cert
>>        << unpacked meta file: signature.asc
>>      Downloading GPG signature of repository metafile packages.db.meta.asc ..>>      packages.db.meta.asc: available, w00t!.
>>      notice.rss: available, w00t!.
>>      Repository revision: 1715
>>      Downloaded database status: OK
>>      GPG key already installed for: sabayonlinux.org
>>      Make sure to verify the imported key and set an appropriate trust level:
>>      $ gpg --homedir '/etc/entropy/client-gpg-keys' --edit-key 'F96DEF6B01C5BDAEB1BADB8CB116DA6F114D935D'                                                   
>>      !!! Error during GPG verification of: packages.db.meta
>>      !!! It could mean a potential security risk: cannot verify file /var/lib/entropy/client/database/amd64/sabayonlinux.org/standard/amd64/5/packages.db.meta, exit status 2
>>      !!! Error during GPG verification of: packages.db.dumplight.bz2
>>      !!! It could mean a potential security risk: cannot verify file /var/lib/entropy/client/database/amd64/sabayonlinux.org/standard/amd64/5/packages.db.dumplight.bz2, exit status 2


tail end of equo update --force && equo install entropy equo sulfur && equo update
Code: Select all
>>    ## Package checksum matches: x11-libs:libXt-1.0.8~0.tbz2
>>    ## Package signature verification error for: GPG, cannot verify file /var/lib/entropy/packages/amd64/5/x11-libs:libXt-1.0.8~0.tbz2, exit status 2
>>    ## Package signature: GPG does not match the recorded one
>>    ## Checksum does not match. Download attempt #5
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it
>>    ## ( mirror #1 ) Successfully downloaded from: na.mirror.garr.it at 0.0b/second
>>    ## Package checksum matches: x11-libs:libXt-1.0.8~0.tbz2
>>    ## Package signature verification error for: GPG, cannot verify file /var/lib/entropy/packages/amd64/5/x11-libs:libXt-1.0.8~0.tbz2, exit status 2
>>    ## Package signature: GPG does not match the recorded one
>>    ## Checksum does not match. Download attempt #6
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it
>>    ## ( mirror #1 ) Successfully downloaded from: na.mirror.garr.it at 0.0b/second
>>    ## Cannot fetch package or checksum does not match.
>>    ## Try to download latest repositories.
>>    ## An error occured. Action aborted.
>>  @@ Download incomplete.
>>  @@ Configuration files scan complete.



is there something wrong with the installtion?
bloodyscript
Simple Hen
 
Posts: 43
Joined: Tue Nov 11, 2008 22:23

Re: entropy update issues

Postby bloodyscript » Thu Apr 29, 2010 12:32

ok i forgot to post results from emerge -- sync

end tail of emerge --sync
Code: Select all
Number of files: 137932
Number of files transferred: 180
Total file size: 186749388 bytes
Total transferred file size: 1054809 bytes
Literal data: 1054809 bytes
Matched data: 0 bytes
File list size: 3078694
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 43514
Total bytes received: 3509985

sent 43514 bytes  received 3509985 bytes  81689.63 bytes/sec
total size is 186749388  speedup is 52.55

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


it seems to be some issue regarding the GPG signature verification
">> ## Package signature: GPG does not match the recorded one
>> ## Checksum does not match. Download attempt #1"


ok my bad i didnt properly search my error and finaly found a fix to the problem it ended up my time and date were set to 2002 causeing the issue. since it was a new install i didnt even think about checking the date to see if it was set correctly.
bloodyscript
Simple Hen
 
Posts: 43
Joined: Tue Nov 11, 2008 22:23

Re: entropy update issues

Postby Stupot » Thu Apr 29, 2010 16:12

I see you found that you had the same issue I had. I'll put a link here in case someone searches for this problem and finds your thread.


viewtopic.php?f=76&t=20279&p=115665#p115665

P.S. Mark it as solved.
Stupot
Sagely Hen
 
Posts: 1517
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron