Page 1 of 1

nvidia-settings --> x server display configuration

Posted: Sat Apr 24, 2010 9:02
by pavav
Hi, my question is:
I installed drivers for nvidia (x11-drivers/nvidia-drivers-173.14.25#2.6.33-sabayon) and nvidia-settings (media-video/nvidia-settings-190.53). When I open nvidia-settings, in the "X Server Display Configuration" tab I get the following message:

Code: Select all

Unable to load X Server Display Configuration page:

Failed to query NoScanout for screen 0.
and I don't know why?

Re: nvidia-settings --> x server display configuration

Posted: Tue Apr 27, 2010 21:09
by albfneto
what is your video board?

had you upgraded all the distro or installed a new kernel?

reboot, login session, then prior to try open nvidia-settings, try this command:

Code: Select all

sudo eselect opengl set nvidia

Re: nvidia-settings --> x server display configuration

Posted: Thu Apr 29, 2010 22:31
by pavav
Hi, my video is Quadro NVS 55/280 PCI (NV34), I have all updates installed and opengl is set to *[1]nvidia, but "X Server Display Configuration" is still unavailable..
I think (but I'm not sure) it happened after I upgraded the nvidia-settings package to version 190.

Re: nvidia-settings --> x server display configuration

Posted: Mon May 24, 2010 19:25
by pavav
still have this problem..

Re: nvidia-settings --> x server display configuration

Posted: Mon May 24, 2010 22:13
by genfool
I am no expert and do not have that card. I did a search and seems it uses the 96.xx drivers
http://www.nvidia.com/object/linux_disp ... 43.16.html
I may be wrong in my search, just what I came up with, would not hurt to try them and see if they work.
The link I post is for reference only, do not use it to download the driver.
In a root terminal, "equo search nvidia" and equo install the 96.xx drivers for your kernel.

First
eselect kernel list and then uname -r make sure they match
eselect opengl list and set nvidia ( I know you already did but humor me)
nano /etc/X11/xorg.conf make sure that every instance to drivers says nvidia and not nv
then equo install the 96.xx drivers listed
This should work, let us know how it goes. If you still have issues they can be fixed.

Re: nvidia-settings --> x server display configuration

Posted: Mon May 24, 2010 23:31
by pavav
Hi and thanks for response. Last driver that can be used with this card is 173.14.x.x, you can see it here: http://www.nvidia.com/object/IO_32667.html
In fact, everything was normal until some time ago. I'm not sure but I think the problem occurs after updating the package nvidia-settings to version 190.53 (from 185.18.31)