So far so good... except "No Sound" [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

So far so good... except "No Sound" [Solved]

Postby xdemo » Sat Apr 03, 2010 13:31

I have took the time to learn a little about sabayon and finally decided to install it today. My existing vista (not that i'm bothered) and ubuntu partitions are still intact and everything went well! So far all i have needed to do is blacklist module "rt2800sta" in order to connect via wireless.

So pretty much, everything works out of the box, except for my sound. I'll mention it works fine in my current Ubuntu Karmic install to convince you guys that my speakers are not broken :lol:

Heres a little information:
Code: Select all
[email protected] ~ $ uname -a
Linux sabayon 2.6.33-sabayon #1 SMP Tue Mar 2 20:46:59 UTC 2010 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ AuthenticAMD GNU/Linux
[email protected] ~ $ cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe024000 irq 27
[email protected] ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
[email protected] ~ $ cat /proc/asound/card0/codec#0 | grep -i codec
Codec: Realtek ALC888
[email protected] ~ $

I have tried to test sound in vlc/dragonplayer, flash player, and no KDE startup sounds etc.
I've also had a look at alsamixer and tried muting channels etc, but i am unable to hear anything.

How can i go about fixing this? This is also the first time i have encountered a sound problem with my current computer.
Thanks in advance.

Ok this is kind of confusing. If i plug in headphones (hphone jack on front of my computer), i get sound. So i plug my speakers into the front jack and sound "sort of" works. However everything is reallllllly quiet (alsamixer/channels all on full blast etc).
Is there anyway to get my main audiojack in the back of my computer to play sound (which is the 'hda nvidia' one)? I also remember in the last release of Sabayon (4.x?) i downloaded the liveCd and had audio/song play during live mode which worked perfect with my speakers.. I'm still baffled. Been searchin a fix all day >.>
Last edited by xdemo on Mon Apr 05, 2010 7:32, edited 1 time in total.
Sabayon 5.2 x86_64 w/ fluxbox
Baby Hen
Posts: 13
Joined: Sat Apr 03, 2010 13:22

Re: So far so good... except "No Sound"

Postby noyabas50 » Sat Apr 03, 2010 22:36

As I a recent convert to Sabayon, I ran into this issue just last week.

After some posts in the webchat and reading through the wiki, you will find this
issue documented at great length.

See, for example, ... _Questions

I am able to get my sound card working after following these instructions.

Hopefully, you will too - soon :D

Baby Hen
Posts: 1
Joined: Thu Apr 01, 2010 21:48

Re: So far so good... except "No Sound"

Postby xdemo » Mon Apr 05, 2010 7:32

Ah thanks. Its working perfectly now. Alsaconf fixed it up nicely! :D
Sabayon 5.2 x86_64 w/ fluxbox
Baby Hen
Posts: 13
Joined: Sat Apr 03, 2010 13:22

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 3 guests