xset -dpms no worky...

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

xset -dpms no worky...

Postby ReemZ » Thu Mar 18, 2010 20:20

No idea where to post this really so I'll drop it here.

My monitor goes to standby mode after ten minutes of not "using" the puter, I used to prevent this from happening by entering 'xset -dpms' in a Run Command dialog (Alt-F2) in SL4 (KDE3.5) and the only little annoyance I had then was not being able to find out how to make this permanent so I wouldn't have to do this after each login.
Now, in SL5 (KDE4), this simply doesn't work.

Bug? Feature? PEBKAC? :scratch:
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: xset -dpms no worky...

Postby Fitzcarraldo » Thu Mar 18, 2010 22:01

Try the command in a Konsole window, and then check if it is actually disabled:

Code: Select all
$ xset q | grep DPMS
DPMS (Energy Star):
  DPMS is Enabled
$ xset -dpms
$ xset q | grep DPMS
DPMS (Energy Star):
  DPMS is Disabled
$ xset +dpms
$ xset q | grep DPMS
DPMS (Energy Star):
  DPMS is Enabled
$ xset -dpms
$ xset q | grep DPMS
DPMS (Energy Star):
  DPMS is Disabled
$


There are a number of ways to execute the xset -dpms command automatically at startup. I do it manually by double-clicking on a pretty icon on my Desktop (a Desktop Config File that simply runs the command xset -dpms), as I only occasionally want to stop my external monitor going into energy-saving mode. However the following method to do it automatically at startup -- which I haven't tried myself -- should work:

Create the file /etc/X11/xinit/xinitrc.d/98-xset containing the xset command:

Code: Select all
#!/bin/sh
xset -dpms

and make it executable:

Code: Select all
chmod +x /etc/X11/xinit/xinitrc.d/98-xset

Once you have logged in, you can open a Konsole window and check if it has worked by using the aforementioned xset q | grep DPMS command.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: xset -dpms no worky...

Postby ReemZ » Thu Mar 18, 2010 22:30

Fitzcarraldo wrote:Try the command in a Konsole window, and then check if it is actually disabled:

Code: Select all
$ xset q | grep DPMS
DPMS (Energy Star):
  DPMS is Enabled
$ xset -dpms
$ xset q | grep DPMS
DPMS (Energy Star):
  DPMS is Disabled
$ xset +dpms
$ xset q | grep DPMS
DPMS (Energy Star):
  DPMS is Enabled
$ xset -dpms
$ xset q | grep DPMS
DPMS (Energy Star):
  DPMS is Disabled
$

Thanks, I'd already found this (man xset, yay!) and tried this, output is the same for me so it should work...
Tried in a console (Yakuake to be precise, could try in Konsole but I doubt this would make any difference) both as user and as root, all with the same result: 'xset -q' showing correct settings but a monitor refusing to take notice of it...

Fitzcarraldo wrote:There are a number of ways to execute the xset -dpms command automatically at startup. I do it manually by double-clicking on a pretty icon on my Desktop (a Desktop Config File that simply runs the command xset -dpms), as I only occasionally want to stop my external monitor going into energy-saving mode. However the following method to do it automatically at startup -- which I haven't tried myself -- should work:

Create the file /etc/X11/xinit/xinitrc.d/98-xset containing the xset command:

Code: Select all
#!/bin/sh
xset -dpms

and make it executable:

Code: Select all
chmod +x /etc/X11/xinit/xinitrc.d/98-xset

Once you have logged in, you can open a Konsole window and check if it has worked by using the aforementioned xset q | grep DPMS command.

Thanks, I'll try this, but as manually giving this command doesn't seem to work I won't know if the above will actually work :(
I'll try it anyway, thanks a lot!
Edit:Er...as user or root? I'd say root but I'm not sure...
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: xset -dpms no worky...

Postby wolfden » Thu Mar 18, 2010 22:35

I usually run

xset -dpms
xset s noblank
xset s off

than my monitor will not go out, seems I need to run all 3, running just one of the 3 doesn't do it for me on my archlinux box.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: xset -dpms no worky...

Postby ReemZ » Thu Mar 18, 2010 22:39

Thanks wolf! Could I combine that with the script Fitz just told me (how) to write?
Does it make any difference in this case whether I perform these actions (either manually entering the commands or writing that script) as user or root?
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: xset -dpms no worky...

Postby Fitzcarraldo » Thu Mar 18, 2010 22:43

Just add the extra commands to the Bash script.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: xset -dpms no worky...

Postby wolfden » Thu Mar 18, 2010 22:54

as root I believe, memory is failing at the moment, order doesn't seem to matter
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: xset -dpms no worky...

Postby ReemZ » Thu Mar 18, 2010 22:57

Thank you both!
I'll try this and report back later with results (I don't think I'll stop giving my box input for a while now as my girl's online atm :mrgreen:)
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: xset -dpms no worky...

Postby ReemZ » Fri Mar 19, 2010 16:22

Alas, still no worky...
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest