Problem with optical drives from LG (HL-DT-ST) [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Problem with optical drives from LG (HL-DT-ST) [Solved]

Postby pavav » Tue Mar 09, 2010 10:36

Hi,
There is a problem with these optical devices:
HL-DT-ST DVD-RAM GSA-H58N
HL-DT-ST CD-RW GCE-8526B
these optical devices can not read CD-R (only Audio CD), DVD device also reads only DVD+-R.
I'm not sure, but maybe the reason is updating the kernel to version 2.6.32 or some other update?
I tried with other LiveCD Linux distribution, the problem is not in the devices...
Last edited by pavav on Mon Mar 22, 2010 16:58, edited 1 time in total.
pavav
Simple Hen
 
Posts: 59
Joined: Thu Dec 10, 2009 1:12

Re: Problem with optical drives from LG (HL-DT-ST)

Postby Darksurf » Thu Mar 11, 2010 5:27

Are you using cheap media? I like to use phillips,HP, and now Sony Accucore, and most expensive taiyo yuden(best of all). Cheap media (i've even had problems with memorex) can cause issues similar to this. And not all drives (older ones) support all versions such as DVD-R or DVD+R. I don't know if these are older or not, sorry :(

But cheap media will cause problems no matter what drive. Have you tried another media brand?
~ Y </0 5+Up1</ P30p[Ez +Ry 2 R34</ D1s? ~
Darksurf
Old Dear Hen
 
Posts: 782
Joined: Sat Sep 16, 2006 4:01

Re: Problem with optical drives from LG (HL-DT-ST)

Postby pavav » Thu Mar 11, 2010 10:55

Darksurf wrote:Are you using cheap media?...


No, this is not the problem, I also use Sony, Philips and TDK. As I mentioned above, the devices work perfectly when I run other distributions (from Live CD). The problem appeared when I installed all the updates of 19 December onwards (because I was not using this computer about two months), and installed a kernel version 2.6.32, which is currently in use.
pavav
Simple Hen
 
Posts: 59
Joined: Thu Dec 10, 2009 1:12

Re: Problem with optical drives from LG (HL-DT-ST)

Postby Darksurf » Fri Mar 12, 2010 5:14

FYI TDK is yuck. But everything else seems good, have you tried manually mounting the cd rom via (as root)

mkdir /media/cd ; mount -t iso9660 /dev/dvd /media/cd

See if it will mount the disc to that folder, if not read off the error logs or output.
~ Y </0 5+Up1</ P30p[Ez +Ry 2 R34</ D1s? ~
Darksurf
Old Dear Hen
 
Posts: 782
Joined: Sat Sep 16, 2006 4:01

Re: Problem with optical drives from LG (HL-DT-ST)

Postby pavav » Sat Mar 13, 2010 10:04

Well, it seems that some CD-s appear in the file manager (in my case PC-Man) and I can mount them as normal user, but others do not appear in the file manager and I have access to them only as root. This applies to both CD-RW and DVD-RW drive. What could be the reason for that?
pavav
Simple Hen
 
Posts: 59
Joined: Thu Dec 10, 2009 1:12

Re: Problem with optical drives from LG (HL-DT-ST)

Postby Darksurf » Sat Mar 13, 2010 20:04

Are you using KDE or Gnome? I've never had this issue under KDE and I have 2 laptops and 3 towers, all different ages.
And what version of Sabayon R U using?
~ Y </0 5+Up1</ P30p[Ez +Ry 2 R34</ D1s? ~
Darksurf
Old Dear Hen
 
Posts: 782
Joined: Sat Sep 16, 2006 4:01

Re: Problem with optical drives from LG (HL-DT-ST)

Postby pavav » Sat Mar 13, 2010 21:01

Yes, I also never had a similar problem before. I'm using LXDE, the version of Sabayon is 5. Any ideas what could be the reason for this "strange behavior"?
pavav
Simple Hen
 
Posts: 59
Joined: Thu Dec 10, 2009 1:12

Re: Problem with optical drives from LG (HL-DT-ST)

Postby Darksurf » Sun Mar 14, 2010 6:28

Do you have this issue under KDE or any other Desktop Environment? This may be related to LXDE alone.
~ Y </0 5+Up1</ P30p[Ez +Ry 2 R34</ D1s? ~
Darksurf
Old Dear Hen
 
Posts: 782
Joined: Sat Sep 16, 2006 4:01

Re: Problem with optical drives from LG (HL-DT-ST)

Postby pavav » Sun Mar 14, 2010 16:06

It is possible, but I do not think this is the reason. Perhaps the reason is the way to define the rights to mount removable media. In other distributions it is in the file /etc /fstab. I do not know exactly how this happens in Sabayon. Or maybe the reason is the configuration of some packages (hal, udev, hotplug) ...?
pavav
Simple Hen
 
Posts: 59
Joined: Thu Dec 10, 2009 1:12

Re: Problem with optical drives from LG (HL-DT-ST)

Postby Darksurf » Sun Mar 14, 2010 17:02

It has nothing to do with the fstab file. Thats not really used for things like that anymore.

policykit and udev control this if I remember correctly. And you should really see if this issue happens under KDE,
If it works properly under KDE then its not a policykit or udev issue. If you can mount stuff as a user, then its not a policykit issue. Give it a try and report back. If you don't like KDE, you can try gnome, but I don't use gnome and don't know where to start on that DE. I tried gnome years ago and quit using it the second day, I hated it.
~ Y </0 5+Up1</ P30p[Ez +Ry 2 R34</ D1s? ~
Darksurf
Old Dear Hen
 
Posts: 782
Joined: Sat Sep 16, 2006 4:01

Next

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 3 guests