Fonts in KDE [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Fonts in KDE [Solved]

Postby morgulbrut » Thu Mar 04, 2010 11:48

Yet another noob problem ;).

I' cant set the fonts in my KDE apps correctly, which ist quiet annoying, because umlauts appear in another font.
I use Openbox as my WM, and originally installed Gnome.

My installed packages (i hope ;) )
Code: Select all
# equo query installed kde | grep Paket
>>     @@ Paket: kde-base/libplasmagenericshell-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/pykde4-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/ksysguard-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/libplasmaclock-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdepimlibs-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/plasma-workspace-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/ksplash-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kcminit-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/ksmserver-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/krunner-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kreadconfig-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kwin-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/plasma-apps-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebase-wallpapers-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/knotify-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebase-startkde-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdelibs-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/dolphin-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/klipper-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kinfocenter-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/powerdevil-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kwrited-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/konsole-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kappfinder-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/ksystraycmd-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/nsplugins-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdepasswd-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebase-pam-7 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kcheckpass-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-misc/kcm_gtk-1.1 Branch: 5, [__system__]
>>      @@ Paket: x11-themes/sabayon-artwork-kde-5.2_beta2 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdm-4.4.0-r10 Branch: 5, [__system__]
>>      @@ Paket: sys-auth/polkit-kde-0.95.1 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kmenuedit-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kwrite-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kscreensaver-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/qguiplatformplugin_kde-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebase-cursors-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebase-meta-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kde-env-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/phonon-kde-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/libkcddb-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/libkcompactdisc-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdemultimedia-kioslaves-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/qimageblitz-0.0.4 Branch: 5, [__system__]
>>      @@ Paket: kde-base/okular-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/libkonq-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/keditbookmarks-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/svgpart-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kfind-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kfmclient-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/konqueror-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/libkdeedu-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kalzium-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/knewstuff-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/plasma-runtime-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebase-menu-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kpasswdserver-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kquitapp-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/ktimezoned-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebase-data-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kurifilter-plugins-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kuiserver-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/solid-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/solid-runtime-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/drkonqi-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kwalletd-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/nepomuk-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kglobalaccel-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/ktraderclient-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/renamedlg-plugins-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kfile-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kstyles-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/khelpcenter-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/attica-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/keditfiletype-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdnssd-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/libkworkspace-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/khotkeys-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kcontrol-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kiconfinder-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kmimetypefinder-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdialog-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebase-kioslaves-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/knetattach-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebugdialog-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebase-desktoptheme-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kcmshell-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kioclient-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebase-menu-icons-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kstart-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdesu-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kdebase-runtime-meta-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/systemsettings-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/automoc-0.9.88 Branch: 5, [__system__]
>>      @@ Paket: kde-base/oxygen-icons-4.4.0-r11 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kstartupconfig-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/kephal-4.4.0 Branch: 5, [__system__]
>>      @@ Paket: kde-base/libtaskmanager-4.4.0 Branch: 5, [__system__]

Code: Select all
# equo query installed qt | grep Paket
>>      @@ Paket: x11-themes/gtk-engines-qtpixmap-0.28-r2 Branch: 5, [__system__]
>>      @@ Paket: dev-python/PyQt4-4.7 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-dbus-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-script-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-gui-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-sql-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-qt3support-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-svg-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-opengl-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-xmlpatterns-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-webkit-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-assistant-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-core-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qt-test-4.6.2 Branch: 5, [__system__]
>>      @@ Paket: media-gfx/qtpfsgui-1.9.3 Branch: 5, [__system__]
>>      @@ Paket: x11-libs/qtscriptgenerator-0.1.0 Branch: 5, [__system__]
>>      @@ Paket: sys-auth/polkit-qt-0.95.1 Branch: 5, [__system__]
>>      @@ Paket: x11-themes/qtcurve-qt4-1.1.1 Branch: 5, [__system__]
>>      @@ Paket: x11-themes/gtk-engines-qtcurve-1.1.1 Branch: 5, [__system__]


Which packages do I need additionally?
morgulbrut
Baby Hen
 
Posts: 6
Joined: Thu Feb 25, 2010 3:07

Re: Fonts in KDE

Postby Fitzcarraldo » Sat Mar 06, 2010 14:21

Don't know, but have a look at the Gentoo Linux Localization Guide which covers setting up fonts correctly for your locale/language. (BTW, beware of the sections in the Gentoo Linux Localization Guide that relate to the time zone and hardware clock, as the configurations in that guide are currently still for Baselayout-1 installations, i.e. before Baselayout-2 and OpenRC. SL uses Baselayout-2 and OpenRC, so for the time zone and hardware clock configuration you should follow the article in the SL Wiki: HOWTO: Clock, Time, UTC, Dual boot with Windows.)
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Fonts in KDE

Postby morgulbrut » Sun Mar 07, 2010 18:29

I've tried... but didn't worked, yet...

After that I've installed kde-meta, it still didn't work... Systemsettings finds my fonts and let me choose fonts, but nothing changes.
morgulbrut
Baby Hen
 
Posts: 6
Joined: Thu Feb 25, 2010 3:07

Re: Fonts in KDE

Postby Fitzcarraldo » Mon Mar 08, 2010 2:55

Try changing the fonts as root user by launching systemsettings via kdesu:

Code: Select all
$ kdesu systemsettings

and enter your root user's password in the pop-up window.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Fonts in KDE

Postby giannis12a » Mon Mar 08, 2010 22:00

i have similar problem on archlinux , and the problem solved when removed the gtk-qt-engine. After that in konsole

Code: Select all
#equo install gtk-chtheme


and
Code: Select all
$gtk-chtheme

like user to set the theme for the gtk programms. After possible , the problem with the font not exist.

My English rules
:mrgreen:
Image
giannis12a
Simple Hen
 
Posts: 52
Joined: Sun Feb 21, 2010 16:07
Location: Athens

Re: Fonts in KDE

Postby morgulbrut » Tue Mar 16, 2010 13:56

@giannis, it didn't work...

but it's not longer that problem. I found a sexy jed hack which i use instead of kile. its faster and looks extremly more 1337 ;)
morgulbrut
Baby Hen
 
Posts: 6
Joined: Thu Feb 25, 2010 3:07


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest