Page 1 of 1

I can't search the forum for xorg.conf [Solved]

Posted: Sat Feb 27, 2010 3:41
by SpuriousBolognas
The search engine wouldn't allow a search on xorg.conf, so I'm posting here, although this has likely been covered. I have a Biostar MCP6P M2+ motherboard with onboard GEforce 6150 graphics and an Envision 19" monitor. I've altered the xorg.conf trying to get 1600X1200 resolution at 75Hz, but at startup it always defaults to "auto", which is 1200X1024 at 60Hz. If I manually select 1600X1200 resolution at 75Hz in the Nvidia server settings, it works well. I got the modeline by running gtf 1600 1200 75

Is there something obvious wrong with my xorg.conf file?

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ENVISIONEN-985e"
HorizSync 30.0 - 98.0
VertRefresh 50.0 - 160.0
Option "DPMS"
Modeline "1600x1200_75.00" 205.99 1600 1720 1896 2192 1200 1201 1204 1253 -HSync +Vsync

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6150SE nForce 430"

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1600x1200_75 +0+0"
SubSection "Display"
Depth 24

Re: I can't search the forum for xorg.conf, so I'm posting here

Posted: Sun Feb 28, 2010 19:30
by Fitzcarraldo
See the following thread for how to use the xrandr command to do it: Screen resolution & refresh rate problem.

Re: I can't search the forum for xorg.conf, so I'm posting here

Posted: Mon Mar 01, 2010 1:55
by SpuriousBolognas
I took the modeline out of the xorg.conf file, and now it starts up the way I want (1600X1200_75.00), but only if I log in as root. If I login with my user credentials, it defaults back to "auto". I tried running a startup command (Xrandr --output default --mode 1600x1200 --refresh 75) in the Startup Applications box, but when it executes, the screen has an unused portion at the top and bottom. Here is a partial out put from xrandr:
[email protected] ~ $ xrandr Screen 0: minimum 320 x 175, current 1600 x 1200, maximum 1600 x 1200 default connected 1600x1200+0+0 0mm x 0mm 1600x1200 50.0* 52.0 53.0 54.0 114.0 1280x1024 51.0 57.0 58.0 1400x1050 55.0 56.0 1280x960 59.0 60.0

Re: I can't search the forum for xorg.conf, so I'm posting here

Posted: Mon Mar 08, 2010 16:07
by SpuriousBolognas
I switched back to Ubuntu, and had the same problem. I found a simple solution here: ... buntu.html.

Just run these commands in a terminal

rm /etc/X11/xorg.conf

Then save the output to /etc/X11/xorg.conf after you get the desired settings.

It should work with Sabayon as well, I guess if you run as root.