how do I get libvdpau-0.3-r1?

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

how do I get libvdpau-0.3-r1?

Postby Metokra » Sat Feb 06, 2010 12:00

Hey guys,

everything worked fine with sabayon up to now. I wanted to perform updates, but by aybe 70% of I get an error saying, that libvdpau-0.3-r1 is in no repository available.
I tried adding these community repositories to it, but they don't seem to exist any more, nor any other repository I could find.
I'm using Sabayon 5.1 64 bit version.
Anyone got an idea.


Thank you :)
Metokra
Baby Hen
 
Posts: 1
Joined: Sat Feb 06, 2010 11:52

Re: how do I get libvdpau-0.3-r1?

Postby wolfden » Sat Feb 06, 2010 18:35

entropy has libvdpau-0.3

are you sure you need libvdpau-0.3-r1 ? portage doesn't even have that version

Can you explain more what you are doing and why that specific version is needed?
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: how do I get libvdpau-0.3-r1?

Postby mozart1 » Sun Feb 07, 2010 0:22

I have the same issue, just installed fresh copy of Sabayon 5.0 Gnome x86_64, it checked for updates, has found 800 updated packages, but is failing to update anything claiming that it can't find libvdpau-0.3-r1. The same thing with equo, it says that the libvdpau-0.3-r1 package is probably needed by nvidia driver package. I can't update/install anything except with emerge. Besides, Nautilus was buggy, I couldn't enter its Edit -> Preferences because it was crashing, I found the same problem and the solution (to reinstall it using emerge) in this forum, did it, now I can use Preferences, but, surprise-surprise, when I want to see the properties of any file with right-click -> Properties, Nautilus crashes. Sad.

Anyway, dear developers, thank you for your hard work, I hope I can fix these problems with your help.
mozart1
Baby Hen
 
Posts: 4
Joined: Sun Feb 07, 2010 0:11

Re: how do I get libvdpau-0.3-r1?

Postby djreedps » Tue Feb 09, 2010 23:47

I am not a developer, but I saw the same error trying to install updates. It said that nvidia-drivers was requiring >=libvdpau-0.3-r1. Entropy (equo) only has libvdpau-3.0 which didn't help. So I ran emerge --sync, and then emerge -av libvdpau. That allowed me to install libvdpau-0.3-r2, which should be sufficient. However, that still is not working on my system. I ran equo database gentoosync, thinking that the entropy database just did not get updated after the emerge. But I still am unable to use equo to update nvidia-drivers. equo search libvdpau shows that I have libvdpau-0.3-r2. I may try to emerge nvidia-drivers.
djreedps
Baby Hen
 
Posts: 10
Joined: Sun Mar 18, 2007 7:09

Re: how do I get libvdpau-0.3-r1?

Postby djreedps » Wed Feb 10, 2010 0:18

A couple more things...My equo problem where it didn't recognize libvdpau even after I emerged it and synced the database is probably due to equo being downlevel on my system. I am reluctant to update all 800+ packages because recently I did that and one of the more recent entropy packages killed KDE on my Macbook. That is a different topic.

But I was able to get nvidia-drivers installed once again through equo by using --nodeps. I wouldn't recommend doing that except that I knew that I had already uninstalled nvidia-drivers to get libvdpau emerged. But I think for most people, emerge --sync, emerge -av libvdpau, equo database gentoosync, and then equo --ask install nvidia-drivers (or whatever was being blocked by libvdpau) should work without the --nodeps option.

Ideally, >=libvdpau-0.3-r1 should be provided in entropy since other packages in entropy are now having dependencies on that package and version.

Good luck.
djreedps
Baby Hen
 
Posts: 10
Joined: Sun Mar 18, 2007 7:09

Re: how do I get libvdpau-0.3-r1?

Postby wolfden » Wed Feb 10, 2010 1:09

can you please file a bug:
http://bugs.sabayon.org/

I just updated a 5.1 KDE x86 and didn't run into this problem
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: how do I get libvdpau-0.3-r1?

Postby mozart1 » Wed Feb 10, 2010 1:35

hate registering, I could bug report if there were a possibility of doing that without registering another account for bugzilla.

here is the output of equo, maybe it can help you:
Code: Select all
user ~ # equo install codeblocks
>>  @@ Calculating dependencies ...
>>  @@ Cannot find needed dependencies:
>>     # Not found: >=x11-libs/libvdpau-0.3-r1
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] x11-drivers/nvidia-drivers-190.53-r1#2.6.31-sabayon
>>  @@ Caching complete.
user ~ #


And, I don't know why, but the nvidia driver is in the list of masked packages.
mozart1
Baby Hen
 
Posts: 4
Joined: Sun Feb 07, 2010 0:11

Re: how do I get libvdpau-0.3-r1?

Postby wolfden » Wed Feb 10, 2010 1:38

you shouldn't have to regisiter, forum login should work the same
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: how do I get libvdpau-0.3-r1?

Postby mozart1 » Wed Feb 10, 2010 1:48

wolfden wrote:you shouldn't have to regisiter, forum login should work the same


Hmm, I'm sorry ;) OK, I'll try to submit a bug report.
BTW, the links to Help pages of bugzilla (i.e. http://bugs.sabayon.org/docs/html/bugreports.html) are not found (404)

Added:
Bug report submitted.
mozart1
Baby Hen
 
Posts: 4
Joined: Sun Feb 07, 2010 0:11


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: aposteeltje and 2 guests