GDM missing

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Baby Hen
Posts: 7
Joined: Fri Dec 04, 2009 13:26

GDM missing

Post by warp4ever » Fri Dec 04, 2009 13:45

I'm new to Sabayon,(but not to Linux) and did a fresh install of v. 5.0 & Gnome.
Everything worked well, (exept Nautilus which would not start) and I did the update as asked, and after 45 minutes or so I rebooted to have a fresh session.
Oops, boot goes fine upto : "error while loading shared libraries: cannot open shared object file: No such file or directory" and so the desktop failes to start.
In both regular and safe mode: starting "gdm" or "startx" after login gives the same error.
I'm stuck.
Any ideas


Sagely Hen
Posts: 8200
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: GDM missing

Post by Fitzcarraldo » Fri Dec 04, 2009 14:03

I searched the SL Forums and found the following threads. Perhaps they will help if you're using an ATI GPU: missing, Re: spritz 0.24.8 64-bit doesn't work, closes right away, or nVidia 180.22 Drivers [Solved] if you use an nVidia GPU. Type "" into the Search box for the forums and you may come up with some other threads that help if those don't solve your problem.

Young Hen
Posts: 21
Joined: Sun Dec 28, 2008 1:26

Re: GDM missing

Post by nuovodna » Fri Dec 04, 2009 19:07

To solve nautilus start, you have to launch nautilus with this command

nautilus --no-desktop

or uncheck show desktop in nautilus preferences on gconf-editor

Young Hen
Posts: 20
Joined: Sun May 17, 2009 11:37

Re: GDM missing

Post by Pete333 » Sat Dec 05, 2009 11:48

I run into the same problem and it got solved by installing the following:

1. after the screen goes blank (after the boot process) press "ctrl-alt-F2"
2. login as "root"
3. type # equo install xorg-server xorg-x11 xorg-drivers xorg-sgml-doctools xorg-cf-files mesa mesa-progs
4. type # reboot
. ...What is the purpose of Life?

Land Owner
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: GDM missing

Post by lxnay » Sun Dec 06, 2009 12:09

The issue is being investigated, it's probably an ebuild issue, "eselect opengl set <your-profile>" fixes it. There's something that invalidates current GL profile.
Join us on IRC ( #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+

Baby Hen
Posts: 7
Joined: Fri Dec 04, 2009 13:26

Re: GDM missing

Post by warp4ever » Sun Dec 06, 2009 12:14

Thanks for your answers.
What I did was performing a text-based repair/reinstall, wich took about THREE hours.
At least this resulted in regaining a desktop, albeith a very feeble one which crashes after 30 secs or so, or even faster when I try to start anything at all.
The only thing I've changed from the defaults is the gdm config to allow the automatic login.

Baby Hen
Posts: 7
Joined: Fri Dec 04, 2009 13:26

Re: GDM missing

Post by warp4ever » Sun Dec 06, 2009 14:05

Well, problem <partly> solved !

I did the reinstall of the X-server, as mentioned here, but to no avail.
(mind you, during install there was a constant warning that ".usr/lib/ is NOT a symlink")
I looked into some X error logs and found no flaws whatsoever.

The only error that ever occurred was during boot-up concerning NFS.
NFS started fine, but connecting to the shares showed an error, but again did not interfere with the boot process.
So for a try I moved "nfs" and "nfsmount" out of /etc/init.d and rebooted.

And now I'm posting this from Firefox AND Sabayon. :D

Which makes Sabayon not very usefull to me at the moment since all my data is on the NFS-shares :cry:
Let's see if I can get NFS working, but all about that in another thread.

Baby Hen
Posts: 1
Joined: Thu Dec 10, 2009 18:53

Re: GDM missing

Post by ryan_n » Thu Dec 10, 2009 21:24

I'm curious if this problem is related to one that I've recently encountered.

About 2 weeks ago, I set up a Sabayon 5.0 Virtualbox client on my work laptop (Win XP - old Thinkpad Z60t - x86) and initially things worked great. However, I did a world update sometime this past week, after which, when I tried to run gvim I got the following error:
gvim: symbol lookup error: gvim: undefined symbol: PL_stack_sp
I ran 'revdep-rebuild -p' to see where the problem might be, and I found that a very large number of packages were broken because they required '/usr/lib/'. Everything works fine if I rollback my Virtualbox image to one that I backed up last weekend, so I'm fairly sure that the problem occurred with one of the most recent package updates.
I tried the fixes recommended in this post, but have not had any luck.
Is my problem related to the OP's or am I doing something else wrong?


Sagely Hen
Posts: 2755
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: GDM missing

Post by joost » Thu Dec 10, 2009 22:13

The perl / vim issue is a different issue and its resolved in the tree.
My blog | Mastodon | Please support Sabayon: Become a Patron

Baby Hen
Posts: 6
Joined: Wed Oct 28, 2009 4:30

Re: GDM missing

Post by HikariSoren » Tue Dec 15, 2009 6:21

I had the same error, but reinstalling x server with the above commands and the eselect opengl nvidia(i am actually using a nvidia legacy driver, 173, or something like that). I also ran on other problem, my desktop kept blinking with my icons and the cpu use was really high. Solved it using equo install gtk+, just in case someone runs in the same problem.

Post Reply