Page 2 of 2

Re: usb problems

Posted: Fri Oct 09, 2009 20:26
by Marvin
i thought that too

Re: usb problems

Posted: Sat Oct 10, 2009 3:18
by Marvin
i assume that both being the same is not a good thing ...

Re: usb problems

Posted: Sat Oct 10, 2009 3:39
by Marvin
i tried again, plugging in a usb card reader into a rear mobo slot, with a 2gb compact flash extreme 3 memory card in the reader. this is what i got:

Code: Select all

[email protected]:~$ su root                                                                          
Password:                                                                                        
Linux marvin # tail -f /var/log/messages                                                         
Oct 10 03:00:01 Linux cron[30135]: (root) CMD (rm -f /var/spool/cron/lastrun/cron.hourly)        
Oct 10 03:00:01 Linux cron[30136]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct 10 03:01:01 Linux cron[30158]: (root) CMD (rm -f /var/spool/cron/lastrun/cron.daily)           
Oct 10 03:10:01 Linux cron[30259]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct 10 03:10:01 Linux run-crons[30266]: (root) CMD (/etc/cron.daily/logrotate.cron)
Oct 10 03:10:01 Linux run-crons[30270]: (root) CMD (/etc/cron.daily/makewhatis)
Oct 10 03:20:01 Linux cron[30456]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct 10 03:20:05 Linux su[30454]: Successful su for root by marvin
Oct 10 03:20:05 Linux su[30454]: + pts/2 marvin:root
Oct 10 03:20:05 Linux su[30454]: pam_unix(su:session): session opened for user root by marvin(uid=1000)
lspci
lsusb
Oct 10 03:22:05 Linux [273310.059179] hub 6-0:1.0: unable to enumerate USB device on port 2
Oct 10 03:22:06 Linux [273311.270290] usb 6-2: new low speed USB device using ohci_hcd and address 8
Oct 10 03:22:06 Linux [273311.398071] usb 6-2: device descriptor read/64, error -62
Oct 10 03:22:06 Linux [273311.627053] usb 6-2: device descriptor read/64, error -62
Oct 10 03:22:07 Linux [273311.850055] usb 6-2: new low speed USB device using ohci_hcd and address 9
Oct 10 03:22:07 Linux [273311.977297] usb 6-2: device descriptor read/64, error -62
Oct 10 03:22:07 Linux [273312.206159] usb 6-2: device descriptor read/64, error -62
Oct 10 03:22:07 Linux [273312.429161] usb 6-2: new low speed USB device using ohci_hcd and address 10
Oct 10 03:22:08 Linux [273312.833157] usb 6-2: device not accepting address 10, error -62
Oct 10 03:22:08 Linux [273312.956344] usb 6-2: new low speed USB device using ohci_hcd and address 11
Oct 10 03:22:08 Linux [273313.359303] usb 6-2: device not accepting address 11, error -62
Oct 10 03:22:08 Linux [273313.359329] hub 6-0:1.0: unable to enumerate USB device on port 2
lspci
lsusb
ls
exit
exit
looks to me as if it's only seeing it as a low speed device; probably with other errors too; there's no reply from the lspci or lsusb commands (or an ls command i added for good measure); plus the exit commands didn't do anything (shouldn't they have dropped me out of su mode?)

what about repeating these tests after a cold restart? do you think that might show different results?

Re: usb problems

Posted: Sat Oct 10, 2009 11:20
by Marvin
do these screen shots of help at all?

Re: usb problems

Posted: Mon Oct 12, 2009 12:30
by Marvin
if this was happening on windows, i would be thinking that this smacks to me as if the "bit" that handles usb devices has gone to sleep ... or died, or ... well, not working. is it at all possible that this is what's happening here?
i've tried rebooting without any change. is there a "special" reboot that all resets device settings? or is it possible to reload the usb handling area? or, well, something along those lines??

Re: usb problems

Posted: Sat Nov 21, 2009 14:00
by Marvin
i tried a number of reboots.
left it switched off for a while.
couldn't think of anything else to try ...
then i wondered if another distro would be the same.
so i dl'd Kruchie Koala (whatever), installed it over the top of my sabayon / (keeping my /home from before) and everything seems fine.
i've even got my printer to work ...

thanks for the help.

//sorted

Re: usb problems [Solved]

Posted: Sat Nov 21, 2009 17:42
by Fitzcarraldo
"Kruchie Koala" :)

So you've gone over to the brown side, eh, Marvin? Anyway, glad you're sorted. Have fun with Ubuntu.

Re: usb problems [Solved]

Posted: Sat Nov 21, 2009 19:27
by Marvin
yeah, sorry m8 but having virtually no usb access for around 6 weeks plus needing to email everything i wanted to myself then having to logon to gmail using my kids lappy to print it ... it was just a non-starter. i also noticed a couple of weeks ago that i had no sound too (i rarely switch my pc speakers on), again fixed with the "U" word.
pity cos you guys certainly seem more like my sense of humour :)
still, i'm happy. i'm gonna put "U" on youngest's lappy too (that will stop the eldest screwing it up).
i might even re-build the eldest's machine with dual boot for "U" so that next time he screws his own windows system up i can say "just use Linux until i've got more time".
anyway, thanks again.

//sorted