Page 1 of 1

No sound on firefox

Posted: Mon Jul 20, 2009 6:21
by adrian78666
whenever I try to look at a flash video on firefox I get no sound but I can play streams on xbmc just fine I had a similar problem when I was using 2 soundcards on ubuntu ultimate edition and I just disabled the on board sound and everything worked just fine but now the hdmi sound port on my video card it's showing and I don't know how to disable it the output is already selected on my audigy please help I really like this distro sorry I just noticed that the screenshot doesn't show that well it says "HDA ATI HDMI"

Re: No sound on firefox

Posted: Tue Jul 21, 2009 0:42
by wolfden
so it's only with flash you have no sound?

Re: No sound on firefox

Posted: Tue Jul 21, 2009 12:36
by joost
If its flash try this:

Code: Select all

equo install libflashsupport
Also read here: ... dio#p99955

Re: No sound on firefox

Posted: Tue Jul 21, 2009 14:31
by Thev00d00
Personally I have to force libflashsupport to use PulseAudio, pulseaudio is very nice however.

add the line

Code: Select all

to the /usr/bin/firefox script, before it calls firefox itself

Re: No sound on firefox

Posted: Thu Sep 10, 2009 10:00
by onlyoneskwalla
got my solution to this from the gentoo forums
here ... dfa6f4ba30

pulseaudio user ?

then you might need


and set up pulseaudio correctly:

edit ~/.asoundrc :

Code: Select all

pcm.pulse { 
     type pulse 
 ctl.pulse { 
     type pulse 
 pcm.!default { 
    type pulse 
 ctl.!default { 
     type pulse 
btw this solved the sound problem of flash across konqueror too not just firefox.

64bit sabayon branch5 had the same issue in 4.2kde also

Re: No sound on firefox

Posted: Tue Oct 06, 2009 22:42
by frosch62
checked out the linked gentoo forum discussion on this topic and as of today it still doesn't seem solved. i thought i had this same "bug" after a clean install of sabayon 5 kde (x86), but i found a way around it. both amarok and flash are playing after i raised the PCM volume in KMix. it was turned all the way down by default, but doesn't appear to be having problems.

not an expert at all, so i can't help any further if this doesn't work, but it might be worth a try! good luck!