qbittorrent stopped working

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Post Reply
leo navis
Baby Hen
Posts: 2
Joined: Thu Mar 02, 2017 14:19

qbittorrent stopped working

Post by leo navis » Thu Mar 02, 2017 14:23

Hi,

When I try to start qbittorrent, it gives me this error:

Code: Select all

qbittorrent: error while loading shared libraries: libboost_system.so.1.56.0: cannot open shared object file: No such file or directory
I am quite certain the solution is quite simple, but have no idea what I should do.

Thanks!
Leo

svantoviit
Old Dear Hen
Posts: 724
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: qbittorrent stopped working

Post by svantoviit » Mon Mar 13, 2017 18:41

The fix is simple. Update your system.
Seems you have an old version of qbittorrent installed.
The update should solve your issues.

leo navis
Baby Hen
Posts: 2
Joined: Thu Mar 02, 2017 14:19

Re: qbittorrent stopped working

Post by leo navis » Wed Mar 15, 2017 10:36

It still does not work, although I have updated everything.

User avatar
sabayonino
Sagely Hen
Posts: 3190
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: qbittorrent stopped working

Post by sabayonino » Wed Mar 15, 2017 12:23

I think qbitorrent must be recompiled with
dev-libs/boost-1.62.0-r1

https://packages.sabayon.org/show/qbitt ... -show-what

your system is looking for libboost_system.so.1.56.0:
boost-1.56 was dropped

update your repository

Code: Select all

# equo update --force
try to reinstall
boost and qbitorrent

and run

Code: Select all

# equo deptest && equo libtest
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

svantoviit
Old Dear Hen
Posts: 724
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: qbittorrent stopped working

Post by svantoviit » Wed Mar 15, 2017 14:55

The latest version of qbittorrent is compiled with >=dev-libs/boost-1.62.0-r1:0 as dependency which is also the latest in Entropy, at least in weekly, therefore I suggested an update of the system ;)

Code: Select all

$ equo s -v qbittorrent
╠  @@ Searching...
╠      @@ Package: net-p2p/qbittorrent-3.3.10 branch: 5, [sabayon-weekly] 
╠          Category:        net-p2p
╠          Name:            qbittorrent
╠          Masked:          False
╠          Available:       version: 3.3.10 ~ tag: NoTag ~ revision: 1
╠          Installed:       version: Not installed ~ tag: n/a ~ revision: n/a
╠          Slot:            0
╠          Size:            3.5MB
╠          Download:        packages/amd64/5/net-p2p/net-p2p:qbittorrent-3.3.10.cf097b6f8e8670bf8244f4d058015d84020ccb2f~1.tbz2
╠          Checksum:        d82c97e99b61e8dff5611da137255053
╠          SHA1:            cf097b6f8e8670bf8244f4d058015d84020ccb2f
╠          SHA256:          53596ad7630dc725630be6c184f006fde3ded5fc0fd898cb5b24df3902425196
╠          GPG:             Yes
╠          ## Dependencies:
╠          ##               [0] >=dev-libs/boost-1.62.0-r1:0
╠          ##               [3] >=dev-libs/boost-1.62.0-r1:0
╠          ##               [3] dev-qt/linguist-tools:5
╠          ##               [0] dev-qt/qtconcurrent:5
╠          ##               [3] dev-qt/qtconcurrent:5
╠          ##               [0] dev-qt/qtcore:5
╠          ##               [3] dev-qt/qtcore:5
╠          ##               [0] dev-qt/qtdbus:5
╠          ##               [3] dev-qt/qtdbus:5
╠          ##               [0] dev-qt/qtgui:5
╠          ##               [3] dev-qt/qtgui:5
╠          ##               [0] dev-qt/qtnetwork:5[ssl]
╠          ##               [3] dev-qt/qtnetwork:5[ssl]
╠          ##               [0] >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5,X]
╠          ##               [3] >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5,X]
╠          ##               [0] dev-qt/qtwidgets:5
╠          ##               [3] dev-qt/qtwidgets:5
╠          ##               [0] dev-qt/qtxml:5
╠          ##               [3] dev-qt/qtxml:5
╠          ##               [3] >=dev-util/cmake-3.6.3
╠          ##               [0] >=net-libs/rb_libtorrent-1.0.6
╠          ##               [3] >=net-libs/rb_libtorrent-1.0.6
╠          ##               [3] sys-devel/make
╠          ##               [0] sys-libs/zlib
╠          ##               [3] sys-libs/zlib
╠          ##               [3] virtual/pkgconfig
╠          ##               Legend:
╠          ##               {0} Runtime dependency
╠          ##               {1} Post dependency
╠          ##               {2} Manually added (by staff) dependency
╠          ##               {3} Build dependency
╠          Homepage:        http://www.qbittorrent.org/ 
╠          Description:     BitTorrent client in C++ and Qt 
╠          USE flags:       -debug -webui X abi_x86_64 amd64 
╠                           dbus elibc_glibc kernel_linux 
╠                           userland_GNU 
╠          CHOST:           x86_64-pc-linux-gnu
╠          CFLAGS:          -O2 -march=x86-64 -pipe
╠          CXXFLAGS:        -O2 -march=x86-64 -pipe
╠          Sources:
╠                           mirror://sourceforge/qbittorrent/qbittorrent-3.3.10.tar.xz
╠          Entry API:       3
╠          Compiled with:   -O2 -march=x86-64 -pipe
╠          Keywords:        ~amd64 ~arm ~ppc64 ~x86 
╠          Created:         2017-03-07 20:17:11.540000
╠          License:         GPL-2
╠   Keywords:  qbittorrent
╠   Found:     1 entry

Code: Select all

 equo s dev-libs/boost
╠  @@ Searching...
╠      @@ Package: dev-libs/boost-1.62.0-r1 branch: 5, [sabayon-weekly] 
╠          Available:     version: 1.62.0-r1 ~ tag: NoTag ~ revision: 0
╠          Installed:     version: 1.62.0-r1 ~ tag: NoTag ~ revision: 0
╠          Slot:          0
╠          Homepage:      http://www.boost.org/ 
╠          Description:   Boost Libraries for C++ 
╠          License:       Boost-1.0
╠   Keywords:  dev-libs/boost
╠   Found:     1 entry

svantoviit
Old Dear Hen
Posts: 724
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: qbittorrent stopped working

Post by svantoviit » Wed Mar 15, 2017 15:22

leo navis wrote:It still does not work, although I have updated everything.
Qbittorrent runs just fine here. It seems you are still not updated. Please, post the output of

Code: Select all

$ equo q installed -vq qbittorrent dev-libs/bost
Or rather check, if you have really updated your system. I can just second what sabayonino wrote:

Code: Select all

# equo up --force && equo u -a && equo conf update
# equo deptest && equo libtest
If the issue persists, check if you haven't masked any of the packages. If it is the case, unmask and update again.

Code: Select all

$ grep -r "boost\|qbittorrent" /etc/entropy/packages/
They should not appear in any of the package.mask files.

As a last resort, you can create a symlink to the installed library:

Code: Select all

# cd /usr/lib64/
# ln -s libboost_system.so libboost_system.so.1.56.0

Post Reply