Duda sobre actualización de Sabayon

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

Post Reply
txemijendrix
Simple Hen
Posts: 43
Joined: Fri Jan 12, 2007 3:31
Location: Bilbao ~ Spain
Contact:

Duda sobre actualización de Sabayon

Post by txemijendrix » Tue Jan 30, 2007 22:32

Hola, estoy intentando actualizar mi sistema (sabayon linux 64bits 3.26) y para eso, siguiendo el manual de gentoo he tecleado en una consola como root

Code: Select all

emerge --update --ask world
Y la respuesta es que tengo un paquete enmascarado que no me deja actualizar nada:

Code: Select all

Calculating world dependencies |
!!! All ebuilds that could satisfy ">=sys-apps/dbus-0.94" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/dbus-1.0.2 (masked by: package.mask)
For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "dev-libs/dbus-glib-0.72" [ebuild])

!!! Problem resolving dependencies for gnome-extra/gnome-utils
!!! Depgraph creation failed.
Luego he leído en el manual que
package.mask implica que el paquete se ha encontrado corrupto, inestable o peor y ha sido marcada deliberadamente para que no se use.
Alguien tiene alguna solución para esto.

Es la primera vez que trabajo con gentoo, así es que perdonad si es una tontería.

Txemi Jendrix
http://www.txemijendrix.com 3D y Diseño Gráfico

gabrielTmB
Baby Hen
Posts: 5
Joined: Wed Oct 11, 2006 22:34

Post by gabrielTmB » Tue Jan 30, 2007 23:00

Yo creo que tenes que leer un poco mas, hay que modificar un archivo dentro del etc no me acuerdo cual,lo que te dice el mensaje es que el paquete esta enmascarado, no es otra cosa que esta en etapa de prueba.Modificas ese archivo y permitis instalar paquetes en etapa de prueba.Oviamente no es algo recomendado para un server en produccion.Pero para jugar en casa todo bien.

TaRbAll
Baby Hen
Posts: 6
Joined: Sun Jan 21, 2007 21:38

Es sencillo

Post by TaRbAll » Wed Jan 31, 2007 2:05

Es sencillo de hacer, solo tecleas:

nano -w /etc/portage/package.unmask
y le agregas la linea asi:
(normalmente aparece un ejemplo en los comentarios al tope del archivo de como colocar los nombres de los paquetes a desenmascarar)
>=sys-apps/dbus-1.0.2


Tambien podria ser:
nano -w /etc/portage/package.mask
luego buscas el nombre del paquete y lo borras o le pones el signo de "#" al comienzo de la linea

espero que tengas suerte

Post Reply