Page 1 of 1

inicio de sesion automatico xfce

PostPosted: Wed Jul 03, 2013 0:43
by pipo1342
Hola que tal. estoy usando sabayon 13.04 xfce pero he tenido un inconveniente y es que no he podido poner el auto login ya que es muy molesto cada que enciendo la pc me pide usuario y contraseña. use "nano /etc/lightdm/lightdm.conf" y puse #autologin-user= mi nombre pero no funciono. le agradesco su ayuda.

Re: inicio de sesion automatico xfce

PostPosted: Wed Jul 03, 2013 4:02
by Lemuriano
/etc/lxdm/lxdm.conf

Re: inicio de sesion automatico xfce

PostPosted: Wed Jul 03, 2013 4:12
by gabvil
Hola Pipo,

Probaste sacar el numeral supongo (?) :shock: (sin "descomentar" no lee esa variable entonces)

Yo los mejores resultados que obtuve para la sesión automática luego de varios inconvenientes fue con lxdm para con la sesión automática luego de varias pruebas y no estar muy bien resuelto lightdm con consolekit.

Saludos,

Re: inicio de sesion automatico xfce

PostPosted: Wed Jul 03, 2013 5:26
by pipo1342
entonces tengo q instalar lxde o lxdm? porque busque mucho en google pero no encontre nada solo cambiar lightdm por lxdm pero nose como hacer

Re: inicio de sesion automatico xfce

PostPosted: Wed Jul 03, 2013 5:54
by Lemuriano
En mi caso solo fui a nano /etc/lxdm/lxdm.conf (descomentar y usar tu nombre de usuario)

## uncomment and set autologin username to enable autologin
autologin=your username

Yo uso autologin ya que mi disco duro esta cifrado y así evito escribir tantas contraseñas pero he leido en el foro que de no ser ese el caso y por seguridad, no es recomendable usar el autologin.

Saludos

Re: inicio de sesion automatico xfce

PostPosted: Wed Jul 03, 2013 7:06
by gabvil
Con solo editar en la ruta /etc/lxdm/lxdm.conf el autologin y setear el timeout mayor o igual a 5 tendría que funcionar.

Esto luego de dejar el DM de lxdm en :

Code: Select all
6481 ~ # cat /etc/conf.d/xdm
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?  [ xdm | gdm | kdm | lxdm | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
DISPLAYMANAGER="lxdm"      #Aqui cambiar en caso de que diga lightdm


Saludos,

Re: inicio de sesion automatico xfce

PostPosted: Wed Jul 03, 2013 15:16
by pipo1342
que tal amigo. lo que pasa es que mi versión es daily 26-06-2013 y el login de inicio es lightdm y no lxdm por que yo puse el commando que me diste pero aparece vacio.

gracias

Re: inicio de sesion automatico xfce

PostPosted: Thu Jul 04, 2013 3:29
by gabvil
Hola,

Primero para poder editarlo habría que instalarlo.

Code: Select all
6481 ~ # equo search lxdm
>>  @@ Buscando...
>>      @@ Paquete: lxde-base/lxdm-0.4.1-r6 rama: 5, [sabayon-weekly]
>>         Disponible:    versión: 0.4.1-r6 ~ tag: NoTag ~ revisión: 1
>>         Instalado:     versión: No instalado ~ tag: N/D ~ revisión: N/D
>>         Bloque:        0
>>         Página:        http://lxde.org
>>         Descripción:   LXDE Display Manager
>>         Licencia:      GPL-3
>>  Palabras clave:  lxdm
>>  Encontradas:     1 entry


Simplemente reemplazando el "search" por install tendrías que en pocos minutos tenerlo instalado.

Saludos,

Re: inicio de sesion automatico xfce

PostPosted: Sat Jul 06, 2013 0:55
by pipo1342
que tal hombre. La verdad no pude poner el autologin. es una pena porque esta distro me gustaba instale otra distro rolling que si tiene la opcion de autologin. gracias de todas formas

Re: inicio de sesion automatico xfce

PostPosted: Sat Jul 06, 2013 4:16
by gabvil
Hola Pipo,

Lastima no haberte podido ayudar.

Saludos y pase bien.