problemas conexion repositorios! [Solved]

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

problemas conexion repositorios! [Solved]

Postby noxv » Tue Jul 02, 2013 16:32

holaaaa

estoy usando sabayon 10 xfce desde hace tiempo y fenomeno pero desde que formatee el pc y volvi a hacer la instalación
tengo problemas al actualizar sabayon, al principio me pregunta: ¿que si dispongo de conexión a internet? y acto seguido me pone que hay 3 grandes actualizaciones que hacer entropy, glib...

el caso esq acepto pero falla en la descarga! he provado con diferentes repositorios weekly, sabayonlinux.org....
y no entiendo nada porque no funciona...

mi conexión cableada esta perfecta! esta pasando algo en los servers?

me pondria a instalar sabayon 13.04 pero al igual que la 11 la instalación se queda bloqueada, por eso siempre me he quedado en la 10 y de lujo hasta hoy....

por favor soluciones :')
Last edited by noxv on Fri Jul 05, 2013 15:05, edited 1 time in total.
noxv
Baby Hen
 
Posts: 10
Joined: Tue Jul 02, 2013 16:24

Re: problemas conexion repositorios!

Postby gabvil » Wed Jul 03, 2013 4:10

Hola noxv,

Probaste con el comando equo via terminal ?

Capaz hay algo que no te este mostrando Entropy en caso de usarlo. Ahora con Rigo capaz cambio un poco el asunto de la descarga en los servidores. Otra opción se me ocurre es bajar manualmente y dejar en el /var/tmp/entropy/packages/tu_arquitectura/ los paquetes bajados directamente de packages.sabayon.org.

¿Logs con un poco de evidencia que muestren el error que recibis?

Saludos,
·Intel [email protected]/2Gb Ram/160Gb/82945GZ/Sabayon Mate 13.07 x64 @work X2
·Intel [email protected]/2Gb Ram/250Gb/x3100 GM965/Sabayon Mate 13.07 x64 @lappy
·Intel [email protected]/2Gb Ram/800 Gb/Zotac 8400GS-512Mb-HDMI/Sabayon Mate 13.07 x64 @HTPC
gabvil
Growing Hen
 
Posts: 119
Joined: Tue Sep 28, 2010 22:27
Location: Canelones, Uruguay

Re: problemas conexion repositorios!

Postby noxv » Wed Jul 03, 2013 15:00

si ya provee con equo varios comandos

te dejo unas fotos bastante mal hechas todo hay q decirlo xdd

http://imageshack.us/photo/my-images/405/3a3v.jpg/
http://imageshack.us/photo/my-images/811/0dit.jpg/
http://imageshack.us/photo/my-images/221/7uhd.jpg/

no me deja ni hacer capturas de pantallla sabayon.., usando el live del cd todo perfect y se conecta a internet pero una vez hecha la instalación ya no me funcionan ni rigo ni equo, aparentemente veras q en una de las ultimas fotos aparecen las actualizaciones que se pueden realizar, pero me dice de todos los repos "no disponible" y "descarga incompleta"

es super raro además la instalación la hice con el cable de red enchufado por si se actualizaba al instante...
ahh y por defecto la primera vez q instalas sabayon se abría siempre una ventana de midory con la web de sabayon pero como no hay conexion me pone problema entrada /salida...

voy a probar a descargarlos manualmente los tres paquetes importantes y guardarlos en el directorio q comentas y a ver si se soluciona..

graciass ;)

no hay nada que bloquee la conexión ni cortafuegos ni router... x eso pense en los servers
noxv
Baby Hen
 
Posts: 10
Joined: Tue Jul 02, 2013 16:24

Re: problemas conexion repositorios!

Postby gabvil » Thu Jul 04, 2013 3:20

Hola novx,

El problema aparentemente empieza por no poder rearmar la base de datos del repositorio.
Si en principio esta se podia conectar directamente sin ninguna intervención tuya en el Live CD ahora tendría.

Por lo que me mostras en las screenshot algo referente a los paquetes que requiere bajar no estan disponibles realmente en el repositorio remoto.

Muchas veces a mi me ocurrio de buscar un paquete, estar listado en la BD del repositorio y no encontrarlo localmente.

Por favor al realizar estos comandos entra como root, evita el sudo para estos comandos. (su -)
Vamos por lo primero:
Code: Select all
- equo update --force
- equo install entropy equo rigo --relaxed


De ser necesario y tener alguna dependencia necesaria por fuera de estos paquetes, instalarlas y reiniciar para estar seguros.

Luego de aplicados esos cambios:
Code: Select all
- equo repo mirrorsort sabayon-weekly


Dejalo correr, haría una prueba sobre los distintos mirrors encontrando el mas cercano y de mejor respuesta a tu localidad.

Después de eso proba actualizar y me contas a ver que tal.

Saludos,
·Intel [email protected]/2Gb Ram/160Gb/82945GZ/Sabayon Mate 13.07 x64 @work X2
·Intel [email protected]/2Gb Ram/250Gb/x3100 GM965/Sabayon Mate 13.07 x64 @lappy
·Intel [email protected]/2Gb Ram/800 Gb/Zotac 8400GS-512Mb-HDMI/Sabayon Mate 13.07 x64 @HTPC
gabvil
Growing Hen
 
Posts: 119
Joined: Tue Sep 28, 2010 22:27
Location: Canelones, Uruguay

Re: problemas conexion repositorios!

Postby noxv » Thu Jul 04, 2013 16:36

gracias por responder de nuevo!

todos esos comandos los prove antes de que me lo comentaras pero utilizando sudo,
no se yo si haciéndolo con su cambien mucho la cosa... pero provare!

descargue los cuatro paquetes básicos entropy,glibc.... de la web que me comentaste desde Windows, (pendrive) con las opciones download y las de source introduciendo carpeta por carpeta etc lib .. todos los archivos que pudiera necesitar para funcionar y nada.. quizás no era el método correcto..

otra opción que barajo es probar con sabayón 13.06 o la 13.07 que acabo de descubrir (aunq igual tengo problemas para iniciar el instalador como me pasaba con 13.04 que se congelaba... creo que por tema t.grafica geforce 6500)

en fin en cuanto pueda hago una instalación fresca por cualquier cosa que haya podido alterar en el sistema haciendo pruebas y te informo!

gracias por molestarte! ;)
noxv
Baby Hen
 
Posts: 10
Joined: Tue Jul 02, 2013 16:24

Re: problemas conexion repositorios!

Postby noxv » Thu Jul 04, 2013 19:08

no surgio con su

hice los comandos comentados y entiendo q le dices q mire en el repo de sabayon-weekly pero no se como hacer para cambiar al q tenga mas cercano a mi localidad, es decir hacer eso via comando
x cierto soy de españa como dato.

PARENTESIS:
ni con sabayon 13.06 ni .07 como era de esperar
me arroja el mensaje de q mi tarjeta geforce 6500 no es compatible ya... q rabia! lo curioso esq el instalador de 13.07 aparece en modo grafico pero para cuando quiero dale al icono de install to hard drive se qeda trabado!

como se come q me arroje el error de q mi grafica es incompatible y se levante via modo grafico!! q drivers usa??? para poder hacerlo? cuando estaba en sabayon 10 me funcionaban la 304.64 y la 304.88...

no se q hacer, se te ocurre alguna idea??



SOLUCIONADO: he podido instalar la version 13.07 gracias a q cuando se levanta el modo grafico via consola he hecho:
-liveinst
-su update
-equo search nvidia-drivers
-equo install x11-........ 304.88 ( q eran los q me funcionaban y han vuelto a funcionar en esta version con este kernel!)

el instalador modo grafico ya no se congelaba y tengo de nuevo mi sabayoon!!!! con los repos a tope a la ultima versión!!
y mas feliz que una perdiz, así lo dejo escrito por si alguien tubiese el mismo problema! alternativa!!

gracias por la ayuda gabvil aunq no se haya podido en sabayon 10 te lo agradezco!!

LO UNICO MALO es la resolucion de pantalla que se ve mas grande, esta puesto a 1024x768 y no puedo hacer q se vea mas pequeño, he probado mirando en /etc/X11/xorg.conf pero no aprece resolución alguna..
noxv
Baby Hen
 
Posts: 10
Joined: Tue Jul 02, 2013 16:24

Re: problemas conexion repositorios!

Postby gabvil » Fri Jul 05, 2013 2:49

Genial novx !!!

Supuestamente el comando comentado para cambiar el repositorio mas cercano a la localidad se lograría simplemente con el comando del mirrorsort, no es necesario nada mas. No puedo compartir mi localidad mas cercana contigo porque yo soy de Uruguay.

En cuanto a la resolución yo tengo la gráfica de Nvidia pero la 8400Gs y logro "tocar" la resolución simplemente con el Nvidia Settings.

Code: Select all
6481 ~ # equo search media-video/nvidia-settings
>>  @@ Buscando...
>>      @@ Paquete: media-video/nvidia-settings-319.23 rama: 5, [sabayon-weekly]
>>         Disponible:    versión: 319.23 ~ tag: NoTag ~ revisión: 0
>>         Instalado:     versión: No instalado ~ tag: N/D ~ revisión: N/D
>>         Bloque:        0
>>         Página:        http://www.nvidia.com/
>>         Descripción:   NVIDIA Linux X11 Settings Utility
>>         Licencia:      GPL-2
>>  Palabras clave:  media-video/nvidia-settings
>>  Encontradas:     1 entry


Instalalo y decime que tal, en el apartado de configurar la resolución pasa tu resolución ideal y dale a guardar (quizas tengas que ejecutarlo como root esto.)

Saludos,
·Intel [email protected]/2Gb Ram/160Gb/82945GZ/Sabayon Mate 13.07 x64 @work X2
·Intel [email protected]/2Gb Ram/250Gb/x3100 GM965/Sabayon Mate 13.07 x64 @lappy
·Intel [email protected]/2Gb Ram/800 Gb/Zotac 8400GS-512Mb-HDMI/Sabayon Mate 13.07 x64 @HTPC
gabvil
Growing Hen
 
Posts: 119
Joined: Tue Sep 28, 2010 22:27
Location: Canelones, Uruguay

Re: problemas conexion repositorios!

Postby noxv » Fri Jul 05, 2013 12:40

Grande gabvil !!

hoy se un poco más gracias a ti! todo solucionadisimo ;)
noxv
Baby Hen
 
Posts: 10
Joined: Tue Jul 02, 2013 16:24

Re: problemas conexion repositorios!

Postby gabvil » Fri Jul 05, 2013 14:47

Excelente noxv!!!

Me alegra quedara todo resuelto y en su resolucion.

Ahora agrega un [SOLVED] al titulo del asunto y quedaria para referencia de otro usuario.

Saludos y pase buena jornada.

Gabi.
·Intel [email protected]/2Gb Ram/160Gb/82945GZ/Sabayon Mate 13.07 x64 @work X2
·Intel [email protected]/2Gb Ram/250Gb/x3100 GM965/Sabayon Mate 13.07 x64 @lappy
·Intel [email protected]/2Gb Ram/800 Gb/Zotac 8400GS-512Mb-HDMI/Sabayon Mate 13.07 x64 @HTPC
gabvil
Growing Hen
 
Posts: 119
Joined: Tue Sep 28, 2010 22:27
Location: Canelones, Uruguay


Return to Spanish

Who is online

Users browsing this forum: No registered users and 1 guest

cron