problema con instalacion driver nvidia

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

problema con instalacion driver nvidia

Postby titopez » Thu Dec 13, 2012 19:15

Buenas tardes. espero me ayuden con la instalacion del driver nvidia.
Acabo de intalarme el sabayon 10 gnome de 64bits. Luego, loque hice para instalar el controlador nvidia fue lo siguiente:
busque un driver de nvidia con:
Code: Select all
equo search nvidia-drivers

luego elegi el siguiente paquete de la lista que me salio:
Code: Select all
equo install x11-drivers/nvidia-drivers-310.19#3.5.0-sabayon

despues de que termino todo el proceso de descarga e instalacion, lo que hice fue adicionar mi usuario al grupo nvidia:
Code: Select all
gpasswd -a titopez video

despues cambie el controlador a nvidia:
Code: Select all
eselect opengl set nvidia

y luego lo reinicie. Luego del reinicio vi que mi escritoio cambió a esa version antigua de gnome, es decir, donde en la parte de arriba aparece los menus de aplicaciones y lugares, y en la parte de abajo aparece todas las ventanas/aplicaciones abiertas y con los distintos 4 escritorios virtuales, supuse que el driver nvidia ya esta funcionando, porque no me explico que hizo que mi escritorio se cambiara.
Pero cuando abro la herramienta de configuracion de nvidia me sale este mensaje:
Code: Select all
You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

El cual no entiendo, supuestamente dice que mi driver nvidia no esta en uso.
Lo que quiero que me ayuden es, como puedo saber si mi controlador nvidia ya esta funcionando, talvez los pasos que hice para instalarlo no eran los correctos, o me falta algo.Por favor si me pudieran ayudar
Gracias!!!!
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

Re: problema con instalacion driver nvidia

Postby titopez » Thu Dec 13, 2012 21:12

Bueno, ahora todo ha empeorado. Despues de hacer una modificacion al archivo xorg.conf, en la seccion de Device, donde dice "nv", lo cambie por "nvidia" y luego de reiniciar, el programa de configuracion de nvidia ya me reconocio la tarjeta nvidia, pero sigo con el escritorio que tiene la pinta del antiguo gnome.
Y para colmo de males, luego de apagar mi compu y luego cuando volvi a encenderla ya no me carga el entorno grafico, termina de cargar esa barra de la parte de abajo cuando va arrancando el sistema, y luego se queda colgado. Ahora no puedo entrar a mi Sabayon.
Por favor, que puedo hacer, ayudenme a recuperar mi Sabayon. Gracias.
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

Re: problema con instalacion driver nvidia

Postby nachoig » Thu Dec 13, 2012 22:42

Cual es tu placa de video?
nachoig
Simple Hen
 
Posts: 68
Joined: Thu Oct 04, 2012 20:19

Re: problema con instalacion driver nvidia

Postby abs » Thu Dec 13, 2012 23:33

comprueba que no tengas instalado el driver nouveau.... porque igual el sistema esta intentando usarlo por mucho que tengas el de nvidia puesto.
abs
Growing Hen
 
Posts: 175
Joined: Sun Nov 26, 2006 13:46

Re: problema con instalacion driver nvidia

Postby titopez » Fri Dec 14, 2012 1:53

el modelo es nvidia Geforce 610M de 2Gb, en una Asus R500DV i7 de 64bits

El problema es que no puedo ingresar al sabayon en modo grafico, solo puedo ingresar al modo consola. Si alguien me pudiera explicar, dentro del modo consola, que puedo hacer para recuperar el entorno grafico. Gracias.
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

Re: problema con instalacion driver nvidia

Postby nachoig » Sat Dec 15, 2012 0:39

Como tenés 2 placas gráficas, lo que debe estar pasando es lo siguiente:

El sistema "piensa" que la gráfica primaria es la de Intel. Al poner eselect opengl set nvidia sólo cambia el driver que está siendo usado, pero la placa gráfica en uso todavía es la de Intel. Para recuperar de inmediato el modo gráfico:

Code: Select all
eselect opengl set xorg-x11


Eso debe hacer con que el sistema use los gráficos Intel con acceleración 3D por defecto. Reinicie la computadora.

Bueno, en seguida, debemos atualizar el kernel Linux, visto que el 3.5 fue discontinuado. Abra la consola y ejecute:

Code: Select all
su


Code: Select all
equo update


Code: Select all
equo upgrade --ask


Code: Select all
equo install --ask linux-sabayon-3.6-r3


Code: Select all
kernel-switcher switch linux-sabayon-3.6-r3


Reinicie la computadora. Para confimar que estás usando el Linux 3.6 ejecute este comando.
Code: Select all
uname -r


Bueno, una recomendación para tu caso es usar el Bumblebee. Tratase de una aplicacion que alterna entre las gráficas conforme la aplicación que esteas usando. Si necesitas de una aplicacion que haga intenso uso de 3D, podés activar la placa de nVidia. Y cuando uses aplicaciones 2D o algo que no requiera mucho de los gráficos, la placa de nVidia es desactivada, ahorrando energía.

Code: Select all
su


Code: Select all
equo install --ask bumblebee bbswitch-0.4.2#3.6.0-sabayon


Code: Select all
gpasswd -a titopez bumblebee


Code: Select all
echo modules="bbswitch" > /etc/conf.d/modules


Code: Select all
rc-update -s add bumblebee default


Code: Select all
nano /etc/bumblebee/bumblebee.conf


Cambie esta línea de:

Code: Select all
VirtualDisplay=:8


para:

Code: Select all
VirtualDisplay=:1


Ctrl + O e Intro para salvar y Ctrl + X para salir.

Reinicie la computadora. para hacer que una determinada apliacción use la placa de nVidia:

Code: Select all
optirun aplicacción


abs wrote:comprueba que no tengas instalado el driver nouveau.... porque igual el sistema esta intentando usarlo por mucho que tengas el de nvidia puesto.


Por defecto, al detectar una placa de nVidia, Sabayon pone Nouveau en la lista negra. En todo caso, por vía de las dudas, se puede hacer lo siguiente:

Code: Select all
su


Code: Select all
nano /etc/modprobe.d/blacklist.conf


E insertar esta línea caso no se la encuentre o estea con una cerquilla (#)
Code: Select all
blacklist nouveau
nachoig
Simple Hen
 
Posts: 68
Joined: Thu Oct 04, 2012 20:19

Re: problema con instalacion driver nvidia

Postby titopez » Wed Dec 26, 2012 22:22

disculpen la tardanza, pero anduve de viaje y no lleve mi portatil, y no tuve tiempo de realizar la solucion que me propones nachoig.

Cuando ejecuto el comando: eselect opengl set xorg-x11 me sale el sgte mensaje de error:

Code: Select all
Switching to xorg-x11 OpenGL interface...rm: cannot remove ´/etc/env.d/03opengl´: Read-only file system
!!!Error: Failed to remove /etc/env.d/03opengl
exiting


eso lo escribi estando como usuario root, y nada. Si saben por qué me sale ese error. Para que pueda volver al entorno gráfico. Gracias
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

Re: problema con instalacion driver nvidia

Postby titopez » Wed Dec 26, 2012 23:00

Bueno al parecer, el error anterior era porque no estaba en el modo consola, que debia estar, bueno si estaba, pero parece que estaba en modo a prueba de fallos.
Bueno, ahora supuestamente ya se ejecuto correctamente el comando eselect opengl set xorg-x11 porque cuando escribo eselect opengl list me muestra seleccionada la opcion de xorg-x11.

Pero el problema persiste, sigo sin poder entrar a mi modo grafico. Despues de cargar la barrita celeste, al inicio del sistema, aparece un recuadro negro que cubre casi toda la pantalla, y se queda asi todo el tiempo.

Como puedo solucionar eso, por favor. Ayudaaaaa!!!!
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

Re: problema con instalacion driver nvidia

Postby nachoig » Thu Dec 27, 2012 0:26

A ver...

Code: Select all
equo up


Code: Select all
equo u -a


Code: Select all
equo i -a linux-sabayon-3.7-r2


Code: Select all
equo i -a nvidia-drivers-310.19#3.7.0-sabayon


Code: Select all
eselect opengl set nvidia


Reinicie.

Por defecto, el modo de recuperación de Sabayon trabaja con los discos em modo sólo lectura,
nachoig
Simple Hen
 
Posts: 68
Joined: Thu Oct 04, 2012 20:19

Re: problema con instalacion driver nvidia

Postby titopez » Thu Dec 27, 2012 2:27

bueno, a ver... voy de mal en peor, resulta que ahora no puedo ingresar al modo consola, me explico:
de las opciones que me salen en el grub, entro a el que dice recovery mode. Luego de que va cargando varias cosas del sistema, en ese fondo negro, me pregunta esto:
Code: Select all
Give root password for maintenance
(or type Control-D to continue):

Entonces cuando le pongo mi contraseña de root, el prompt se pone con el simbolo del root #, listo para ejecutar comandos. Pero en este estado, cualquier comando que escribo, que es para modificar algo, me sale una serie de errores pero siempre relacionados con el mensaje de ReadOnly file system.
Ahora, cuando le pongo Control-D para continuar en la pregunta de arriba. El fondo de pantalla cambia a ese fondo de sabayon celeste/violeta y con el simbolo del guionbajo en la esquina superior derecha, sin parpadear, y se queda asi todo el rato.
Entonces, la verdad que ya no se que hacer, porque no puedo ejecutar ningun comando del que me dices.
Creo que voy a formatearlo y reinstar el sistema.
O si tienes alguna sugerencia, seria de ayuda. Gracias.
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

Next

Return to Spanish

Who is online

Users browsing this forum: No registered users and 1 guest