problema con instalacion driver nvidia

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

Re: problema con instalacion driver nvidia

Postby titopez » Thu Dec 27, 2012 2:52

bueno, solucione el problema de la consola de comandos, no se que teclas estaba presionando para probar algo, pero creo que fue algo con ctrl+alt y creo que algun numero, pero bueno, en fin, ya esta, ahora estoy ejecutando los demas comandos. Estoy actulizando sus repos y luego te cuento como me fue. Gracias.
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

Re: problema con instalacion driver nvidia

Postby titopez » Thu Dec 27, 2012 21:18

Bueno, sigo con el mismo problema, no cambio nada. Ejecute todos estos comandos, en este orden:
Code: Select all
equo update
equo upgrade --ask
equo install --ask linux-sabayon-3.6-r3

Luego reinicie la maquina. y luego instale el nuevo driver nvidia.
Code: Select all
equo i -a nvidia-drivers-310.19#3.6.0-sabayon

y luego cambie el controlador:
Code: Select all
eselect opengl set nvidia

Reinicie la maquina, pero sigo con el mismo problema, se queda con ese recuadro negro que cubre casi toda la pantalla.
Con Alt+F2, cambio al modo consola y luego para probar otra cosa, cambie la resolucion del archivo xorg.conf, porque pensé que tal vez ese era el problema, el de la resolución, pero tampoco.
Pienso que hay algo que no estoy haciendo, tal vez me falta algo, algun paso que estoy omitiendo. Alguien puede ayudarme porfa a recuperar mi entorno grafico????? Gracias
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

Re: problema con instalacion driver nvidia

Postby nachoig » Fri Dec 28, 2012 4:05

No haga más modificaciones en el xorg.conf.

Contenido de este archivo, por favor:

/etc/modprobe.d/blacklist.conf
nachoig
Simple Hen
 
Posts: 68
Joined: Thu Oct 04, 2012 20:19

Re: problema con instalacion driver nvidia

Postby titopez » Thu Jan 03, 2013 21:38

Bueno, perdon por la tardanza, aqui esta el contenido del archivo etc/modprobe.d/blacklist.conf:
Code: Select all
# This file lists modules which will not be loaded by udev,
# not at coldplugging and not on hotplug events.

# Add your own entries to this file
# in the format "blacklist <name of module>"

# Some examples:
# evbug is a debug tool and should be loaded explicitly
blacklist evbug

# Autoloading eth1394 most of the time re-orders your network
# interfaces, and with buggy kernel 2.6.21, udev persistent-net
# is not able to rename these devices, so you get eth?_rename devices
# plus an exceeded 30sec boot timeout
blacklist eth1394

# You probably want this to not get the console beep loud on every tab :)
#blacklist pcspkr

# these drivers are very simple, the HID drivers are usually preferred
#blacklist usbmouse
#blacklist usbkbd

# Sometimes loading a framebuffer driver at boot gets the console black
#install pci:v*d*sv*sd*bc03sc*i* /bin/true

# hplip and cups 1.4+ use raw USB devices, so it requires usblp not be loaded
blacklist usblp

## make broadcom-sta happy
## <2012-12-08.
#blacklist ssb
#blacklist bcma
#blacklist brcmsmac
#blacklist b43

# make b43 happy (ditch broadcom-sta)
# 2012-12-08. Testing needed.
blacklist wl

# keep nvidia-drivers working, sorry nouveau
blacklist nouveau

# Known to cause kernel OOPS at boot
blacklist ite_cir


Espero por tu respuesta y tu ayuda. Gracias.
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

Re: problema con instalacion driver nvidia

Postby nachoig » Sat Jan 05, 2013 3:12

El Bumblebee está instalado?
nachoig
Simple Hen
 
Posts: 68
Joined: Thu Oct 04, 2012 20:19

Re: problema con instalacion driver nvidia

Postby titopez » Sat Jan 05, 2013 3:30

Nop, al menos yo no lo instale.

Tengo que instalarlo????
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

Re: problema con instalacion driver nvidia

Postby nachoig » Sat Jan 05, 2013 22:59

Por ahora, no lo instales. Intentá esto (usando el root):

Code: Select all
equo update


Code: Select all
equo upgrade -a


Code: Select all
kernel-swicher switch linux-sabayon-3.7-r3


Code: Select all
equo i -a nvidia-drivers-310.19#3.7.0-sabayon


Code: Select all
equo dt


Reinicie el PC.

Y si depués de eso todavía no subir los entornos gráficos (sólo haga eso si lo que puse arriba no surtir efecto)


Code: Select all
nano /etc/modprobe.d/blacklist.conf


Y adccione esta línea:
Code: Select all
blacklist intel


Ctrl + O e Intro grabar las modificaciones. Reinicie.

Sí no anda:

Code: Select all
equo remove nvidia-userspace


Code: Select all
nano /etc/modprobe.d/blacklist.conf


Remueva estas líneas:
Code: Select all
# keep nvidia-drivers working, sorry nouveau
blacklist nouveau


Ctrl + O e Intro grabar las modificaciones.

Y después ejecute:

Code: Select all
eselect opengl set xorg-x11


Reinicíe la computadora. Si no anda...

Code: Select all
nano /etc/X11/xorg.conf


Vea si está así en "Section Device"

Code: Select all
Section "Device"

    Identifier  "SabayonVga0"
    Driver      "nouveau"


Y si no anda todavía:

Code: Select all
nano /etc/modprobe.d/blacklist.conf


Remueva la línea:
Code: Select all
blacklist intel


Y ponga esta otra:
Code: Select all
blacklist nouveau
nachoig
Simple Hen
 
Posts: 68
Joined: Thu Oct 04, 2012 20:19

Re: problema con instalacion driver nvidia

Postby titopez » Fri Jan 25, 2013 0:18

hola de nuevo, je je paso mucho tiempo. Te cuento que he hecho todo lo que indicas en tu anterior comentario, paso por paso haber si algo de eso funcionaba pero nada, sigo igual. Después he estado probando varias cosas, leyendo en algun otro foro, pero nada, sigo igual, he modificado el archivo xorg.conf, y el de blacklist.conf, de varias formas, tb he reinstalado el driver nvidia y nada. Pienso que, al menos eso creo, es solo de modificar de manera adecuada el xorg.conf, no se, supongo, pero bueno, te pido que si no tienes alguna otra nueva sugerencia o idea de que puedo hacer, me avises y lo reinstalo de una vez mi sistema. Porque la verdad ya me canse, creo que mejor es reinstalarlo.
Gracias por tu tiempo, espero tu respuesta.
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

Re: problema con instalacion driver nvidia

Postby nachoig » Sun Feb 03, 2013 3:59

Primer intento:

Code: Select all
nano /etc/modprobe.d/blacklist.conf

Remueva la línea
Code: Select all
blacklist nouveau


Salve el archivo con Ctrl + O, Intro, y en seguida cierre el edictor con Ctrl + X.

Code: Select all
cp /etc/X11/xorg.conf /etc/xorg.conf.old


Code: Select all
rm -Rf /etc/X11/xorg.conf


Reinicie.

Segundo intento:
Code: Select all
nano /etc/default/grub


Hay dos parametros que talvez estean presentes en esta línea:
GRUB_CMDLINE_LINUX_DEFAULT=

Los parametros son estos dos:
vga (o algo como vga=791)
nomodeset

Apague esos parametros caso estean presentes (y avisáme cual de ellos estaba presente). Salve el archivo con Ctrl + O, Intro, y en seguida cierre el edictor con Ctrl + X.

En seguida ejecute este comando:
Code: Select all
grub2-mkconfig -o /boot/grub/grub.cfg


Reinicie.
nachoig
Simple Hen
 
Posts: 68
Joined: Thu Oct 04, 2012 20:19

Re: problema con instalacion driver nvidia

Postby titopez » Tue Feb 05, 2013 5:28

Bueno, te cuento, buenas noticias (en parte). Logré recuperar mi entorno gráfico, resulta que vi un archivo dentro de /etc/X11 que se llamaba xorg.conf.nvidia-xconfig-original, entonces lo que hice fue copiar todo tal y como estaba en ese archivo y pegarlo en el archivo xorg.conf. Luego reinicie, y volvio mi entorno grafico, pero el problema era que me mostraba la apariencia del antiguo gnome, y ademas, con fallas, es decir los iconos se repetian y los nombres del menu de arriba tb se repetian. Luego me fije con el comando eselect opengl list, y estaba seleccionado el de nvidia. Lo cambie a xorg-x11 y reinicie. Y ahora esta todo bien, con el gnome actual, con todas sus animaciones, que se yo, esta como cuando lo instale. Ahora lo que voy a hacer es desinstalar todo lo que hay de nvidia mas sus dependencias, y probar con una nueva version del controlador, porque lo que yo quiero es utilizar mi tarjeta nvidia. Luego te cuento como me fue. Gracias por tu tiempo.
titopez
Baby Hen
 
Posts: 16
Joined: Wed Dec 05, 2012 19:14

PreviousNext

Return to Spanish

Who is online

Users browsing this forum: No registered users and 2 guests

cron