Problema con actualizar "sudo emerge mysql"

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

Post Reply
NeriNeri
Baby Hen
Posts: 5
Joined: Thu Oct 04, 2012 2:03

Problema con actualizar "sudo emerge mysql"

Post by NeriNeri » Wed Oct 31, 2012 22:52

Hola amigos, nuevamente molestando. He tenido muchas dudas sobre esto, pero tengo un error principal es este:
Primero mas que nada actualice todo mis ficheros. Y después quice instalar MYSQL,pero primero quice actualizar con el comando:sudo emerge mysql. Y me aparece este mensaje:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "mysql".

Y en rigo quice instalar apache y el mensaje que me aparece es:

no puede ser instalado en este momento, ya que existe dependencias no encontradas/enmascaradas o dependencias con conflictos.

No se como solucionarlo, ha por cierto como le ago para poner una palomita en mis temas que ya han sido solucionado, disculpen si soy muy novato. Saludos

abs
Growing Hen
Posts: 179
Joined: Sun Nov 26, 2006 13:46

Re: Problema con actualizar "sudo emerge mysql"

Post by abs » Thu Nov 01, 2012 0:27

Buenas noches,

En caso de toparte con problemas en dependencias no resueltas te recomiendo usar "equo", a través de "equo search" y "equo install";
¿Por qué?
Porque a través de equo te vas a encontrar los paquetes estables y sus dependencias bien resueltas. A través de emerge muchas veces te vas a encontrar paquetes inestables o que tienen depencias aún sin actualizar en esa rama "inestable".

Es decir que por norma general:

->emerge=paquetes nuevos=paquetes menos estables=algunos problemas de dependencias
->equo=no siempre tienen la ultima versión de todo=paquetes probados y estables=por lo general no se mete un paquete en equo si no estan sus dependencias ,


A ver si hay suerte!!

fbsduser
Baby Hen
Posts: 4
Joined: Sat Jun 05, 2010 5:47

Re: Problema con actualizar "sudo emerge mysql"

Post by fbsduser » Fri Dec 28, 2012 3:20

En realidad emerge es parte de portage, el cual es el gestor de paquetes de Gentoo (Sabayon esta basado en Gentoo).
equo es parte de entropy, el cual es un gestor de paquetes hecho especificamente para Sabayon. El gestor de paquetes que sabayon heredo del gentoo no es muy recomendado, pero con este puedes aprovechar los overlays (equivalente en gentoo a los ppa del ubuntu).

Post Reply