Kernel Headers 3.4.0

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

Post Reply
5475UK1
Baby Hen
Posts: 3
Joined: Thu Aug 16, 2012 18:46

Kernel Headers 3.4.0

Post by 5475UK1 » Thu Oct 11, 2012 4:28

Vengo con otra duda, para variar (?) D':
El asunto es que busco lograr hacer funcionar la VMware Player 3.1.3
Lo instalo ..

$sudo sh VMware-Player-3.1.3-324285.i386 (Linux).bundle

Bueno, hasta ahí todo perfecto. Me sale el instalador gráfico, puro next, next... al más estilo win2.
Luego de que me ha dicho que se ah instalado correctamente me sale un mensaje diciendome lo siguiente:

No rc*.d style init script directories were given to the installer. You must manually add the necessary links to ensure that the vmware service at /etc/init.d/vmware is automatically started and stopped on startup and shutdown.

Si bien puedo leer lo que dice, no termino de entender qué es lo que tengo que hacer en realidad.
Admito que me eh perdido bastante con el asunto de que aún me queda demasiado que aprender de linux, pero... en fin.

El archivo vmware allí mensionado claramente no existe. Y si tengo que crearlo, realmente no se qué debo poner dentro.

En el directorio /etc/rc.d/vmware.d se encuentran otras 8 carpetas :

init.d
rc0.d
rc1.d
rc2.d
rc3.d
rc4.d
rc5.d
rc6.d


Todas absolutamente vacias :/

Luego, ignorando eso primero, intento arrancarlo de todos modos. Y me sale lo siguiente:

Image
___________
"Before you can run VMware, several modules must be compiled and loaded into de running kernel.

Kernel Headers 3.4.0-sabayon

Kernel headers for version 3.4.0-sabayon were not found. If you installed them in a non-default path you can specify the path below. Otherwise refer to your distributionś documentation for installation instructions and click Refresh to search again in default location"
___________

Ahora el problema es que los ultimos linux headers que me aparecen en los repositorios son los 3.1 y no consigo en ningun lado los mismos para instalar. (incluso me fijé en los repositorios que estaban desactivados por seguridad y ni modo .-.)
Esto es lo que me muestra el equery:

Code: Select all

~ $ equery d linux-headers
 * These packages depend on linux-headers:
media-libs/libv4l-0.8.8 (>=sys-kernel/linux-headers-2.6.30-r1)
media-video/libav-0.8.3 (sys-kernel/linux-headers)
media-video/transcode-1.1.7-r1 (>=sys-kernel/linux-headers-2.6.11)
net-dialup/rp-pppoe-3.10-r1 (<sys-kernel/linux-headers-2.6.24)
                            (>=sys-kernel/linux-headers-2.6.25)
net-misc/dcbd-0.9.24-r1 (>=sys-kernel/linux-headers-2.6.29)
net-misc/fcoe-utils-1.0.12 (>=sys-kernel/linux-headers-2.6.32)
net-misc/networkmanager-0.9.4.0-r7 (>=sys-kernel/linux-headers-2.6.29)
net-wireless/wimax-1.5.2 (>=sys-kernel/linux-headers-2.6.34)
net-wireless/wimax-tools-1.4.5-r1 (>=sys-kernel/linux-headers-2.6.34)
sys-apps/busybox-1.20.2 (>=sys-kernel/linux-headers-2.6.39)
sys-apps/iproute2-3.1.0 (>=sys-kernel/linux-headers-2.6.27)
sys-apps/keyutils-1.5.5 (>=sys-kernel/linux-headers-2.6.11)
sys-fs/udisks-1.99.0-r1 (>=sys-kernel/linux-headers-3.1)
sys-libs/libcap-2.22 (sys-kernel/linux-headers)
sys-libs/libcap-ng-0.6.6 (sys-kernel/linux-headers)
sys-libs/mtdev-1.1.2 (>=sys-kernel/linux-headers-2.6)
virtual/linuxtv-dvb-headers-5.3 (>=sys-kernel/linux-headers-3.0)
virtual/os-headers-0 (sys-kernel/linux-headers:0)
x11-drivers/xf86-input-evdev-2.7.3 (>=sys-kernel/linux-headers-2.6)
x11-drivers/xf86-input-synaptics-1.6.2 (>=sys-kernel/linux-headers-2.6.37)
Realmente no se si ayuda de algo esta data... pero ya no se me ocurre mucho.
Me estoy basando en las mil y un cosas que estoy leyendo, y realmente comienzo a marearme un poco :/.

Bueno, el kernel acabo de actualizarlo a la ultima versión (3.5 r7)
No sabia si realmente podía llegar a tener algo que ver, pero no perdía nada y de paso lo ponía al día xD
Pero por lo visto ni modo.

Y a no ser que esté enmascarado o algo de eso los paquetes del 3.4... pero realmente no recuerdo cómo fijarme desde la terminal, y en modo gráfico no hay nada al respecto.

Tambien estaba viendo esto => http://packages.gentoo.org/package/sys- ... ux-headers
Pero creo que nada que ver, cierto? tienen idea si son especificamente para gentoo o tambien para el resto de las distros basadas en la misma ?
Igual me bajé para probar el .ebuild que aparece ahí (justamente el 3.4) pero no tengo idea cómo correrlo ._.
Probé abrirlo con el rigo, pero me largó un "repository metadata not found". "Obvio que iba a tirarte algo así" dirán, pero la verdad no estaba de más intentar para quitarme un poco la ignorancia, igual, sigo leyendo algunas cosas al respecto. Y abrirlo cuando me sale el mensaje que mensioné antes, tampoco. Idem, con el sh.

Ojala puedan orientarme un poco mas, puesto que a pesar de buscar aun no le eh encontrado solución .-.

Ojalá fuera tan facil como en el f* Ubuntu ¬.¬
http://www.xtandard.com/2006/09/20/actu ... ne-vmware/

En fin, no se... mucho más no se me ocurre.
Les agradesco de antemano si pueden ayudarme y disculpas por el testamento xD
Image

abs
Growing Hen
Posts: 179
Joined: Sun Nov 26, 2006 13:46

Re: Kernel Headers 3.4.0

Post by abs » Thu Oct 11, 2012 22:34

buenas,

¿probaste a instalar los fuentes del kernel y reinstalarlo? prueba a instalarlo con equo y vuelve meter el player...

sys-kernel/sabayon-sources-3.5-r7

Post Reply