¿Como instalo Lamp en sabayon 5.2?

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

¿Como instalo Lamp en sabayon 5.2?

Postby yigo1980 » Thu Jul 08, 2010 5:33

y es que no hay caso, no me funciona la instalacion, me aparece lo siguiente:

Kahn ~ # equo install php
>> @@ Calculando dependencias ...
>> ## [R] [sabayonlinux.org] dev-lang/php-5.3.2|1 [5.3.2|1]
>> @@ Paquetes que necesitan ser instalados/actualizados/desactualizados: 1
>> @@ Paquetes que necesitan ser eliminados: 0
>> @@ Tamaño de la descarga: 0b
>> @@ Espacio liberado en disco: 0.0b
>> @@ Necesitas al menos: 18.6MB de espacio libre
>> :: (1/1) >>> dev-lang/php-5.3.2
>> ## La comprobación de suma del paquete coincide: dev-lang:php-5.3.2~1.tbz2
>> ++ (1/1) >>> dev-lang/php-5.3.2
>> ## Desempaquetando el paquete: dev-lang:php-5.3.2~1.tbz2
>> ## Instalando el paquete: dev-lang/php-5.3.2
>> ## [The PHP language runtime engine: CLI, CGI, Apache2 and embed SAPIs.]
>> ## Actualizando en la base de datos: dev-lang/php-5.3.2
>> ## Cleaning previously installed information...
>> ## SPM: post-install phase
* CPV: dev-lang/php-5.3.2
* REPO:
* USE: apache2 bcmath berkdb bzip2 calendar cgi cjk cli crypt ctype curl elibc_glibc exif fileinfo filter ftp gd gdbm gmp hash iconv imap ipv6 json kerberos kernel_linux ldap mysql mysqli nls pcntl pdo phar posix postgres readline session simplexml snmp soap sockets spell sqlite ssl tidy tokenizer truetype unicode userland_GNU wddx x86 xml xpm zip zlib
*
* To enable php, you need to edit your /etc/conf.d/apache2 file and
* add '-D PHP5' to APACHE2_OPTS.
*
*
* Configuration file installed as
* /etc/apache2/modules.d/70_mod_php5.conf
* You may want to edit it before turning the module on in /etc/conf.d/apache2
*
* You may have to recompile third-party extensions now
* (includes every dev-php5/pecl-* package and probably others in that category)
*
>>> Regenerating /etc/ld.so.cache...
>> ## Limpiando: dev-lang/php-5.3.2
>> @@ Instalación completada.
>> @@ Configuration files scan complete.
Kahn ~ #
Kahn ~ #
Kahn ~ # equo install apache

>> @@ Calculando dependencias ...
>> ## [R] [sabayonlinux.org] www-servers/apache-2.2.15|3 [2.2.15|3]
>> @@ Paquetes que necesitan ser instalados/actualizados/desactualizados: 1
>> @@ Paquetes que necesitan ser eliminados: 0
>> @@ Tamaño de la descarga: 0b
>> @@ Espacio liberado en disco: 0.0b
>> @@ Necesitas al menos: 1.8MB de espacio libre
>> :: (1/1) >>> www-servers/apache-2.2.15
>> ## La comprobación de suma del paquete coincide: www-servers:apache-2.2.15~3.tbz2
>> ++ (1/1) >>> www-servers/apache-2.2.15
>> ## Desempaquetando el paquete: www-servers:apache-2.2.15~3.tbz2
>> ## Instalando el paquete: www-servers/apache-2.2.15
>> ## [The Apache Web Server.]
>> ## Actualizando en la base de datos: www-servers/apache-2.2.15
>> ## Cleaning previously installed information...
>> ## SPM: post-install phase
* CPV: www-servers/apache-2.2.15
* REPO:
* USE: apache2_modules_actions apache2_modules_alias apache2_modules_asis apache2_modules_auth_basic apache2_modules_auth_digest apache2_modules_authn_alias apache2_modules_authn_anon apache2_modules_authn_dbd apache2_modules_authn_dbm apache2_modules_authn_default apache2_modules_authn_file apache2_modules_authz_dbm apache2_modules_authz_default apache2_modules_authz_groupfile apache2_modules_authz_host apache2_modules_authz_owner apache2_modules_authz_user apache2_modules_autoindex apache2_modules_cache apache2_modules_cern_meta apache2_modules_charset_lite apache2_modules_dav apache2_modules_dav_fs apache2_modules_dav_lock apache2_modules_dbd apache2_modules_deflate apache2_modules_dir apache2_modules_disk_cache apache2_modules_dumpio apache2_modules_env apache2_modules_expires apache2_modules_ext_filter apache2_modules_file_cache apache2_modules_filter apache2_modules_headers apache2_modules_imagemap apache2_modules_include apache2_modules_info apache2_modules_log_config apache2_modules_log_forensic apache2_modules_logio apache2_modules_mem_cache apache2_modules_mime apache2_modules_mime_magic apache2_modules_negotiation apache2_modules_proxy apache2_modules_proxy_ajp apache2_modules_proxy_balancer apache2_modules_proxy_connect apache2_modules_proxy_ftp apache2_modules_proxy_http apache2_modules_rewrite apache2_modules_setenvif apache2_modules_speling apache2_modules_status apache2_modules_substitute apache2_modules_unique_id apache2_modules_userdir apache2_modules_usertrack apache2_modules_version apache2_modules_vhost_alias apache2_mpms_prefork elibc_glibc kernel_linux ldap ssl suexec userland_GNU x86
*
* Selected MPM: prefork
*
* You can manipulate several configure options of suexec
* through the following environment variables:
*
* SUEXEC_SAFEPATH: Default PATH for suexec (default: /usr/local/bin:/usr/bin:/bin)
* SUEXEC_LOGFILE: Path to the suexec logfile (default: /var/log/apache2/suexec_log)
* SUEXEC_CALLER: Name of the user Apache is running as (default: apache)
* SUEXEC_DOCROOT: Directory in which suexec will run scripts (default: /var/www)
* SUEXEC_MINUID: Minimum UID, which is allowed to run scripts via suexec (default: 1000)
* SUEXEC_MINGID: Minimum GID, which is allowed to run scripts via suexec (default: 100)
* SUEXEC_USERDIR: User subdirectories (like /home/user/html) (default: public_html)
* SUEXEC_UMASK: Umask for the suexec process (default: 077)
*
* Please note that you need SysV IPC support in your kernel.
* Make sure CONFIG_SYSVIPC=y is set.
*
>>> Regenerating /etc/ld.so.cache...
>> ## Limpiando: www-servers/apache-2.2.15
>> @@ Instalación completada.
>> @@ Configuration files scan complete.
Kahn ~ #
Kahn ~ #
Kahn ~ # equo install mysql
>> !!! No hay coincidencias para mysql en los repositorios.
>> ? Cuando escribiste mysql ¿en realidad quisiste decir alguno de los siguientes paquetes?
>> # games-mud/mcl:0 ?
>> # games-arcade/missile:0 ?
>> # sci-biology/muscle:0 ?
>> # virtual/mysql:0 ?
>> # dev-db/mysql:0 ?
>> No se han encontrado paquetes.
Kahn ~ # equo install dev-db/mysql
>> @@ Calculando dependencias ...
>> ## [R] [sabayonlinux.org] dev-db/mysql-5.1.46|2 [5.1.46|2]
>> @@ Paquetes que necesitan ser instalados/actualizados/desactualizados: 1
>> @@ Paquetes que necesitan ser eliminados: 0
>> @@ Tamaño de la descarga: 0b
>> @@ Espacio liberado en disco: 0.0b
>> @@ Necesitas al menos: 51.7MB de espacio libre
>> :: (1/1) >>> dev-db/mysql-5.1.46
>> ## La comprobación de suma del paquete coincide: dev-db:mysql-5.1.46~2.tbz2
>> ++ (1/1) >>> dev-db/mysql-5.1.46
>> ## Desempaquetando el paquete: dev-db:mysql-5.1.46~2.tbz2
>> ## SPM: pre-install phase
* CPV: dev-db/mysql-5.1.46
* REPO:
* USE: community elibc_glibc embedded kernel_linux perl pic ssl userland_GNU x86
>> ## SPM: post-remove phase
>> ## Instalando el paquete: dev-db/mysql-5.1.46
>> ## [A fast, multi-threaded, multi-user SQL database server.]
>> ## Actualizando en la base de datos: dev-db/mysql-5.1.46
>> ## Cleaning previously installed information...
>> ## SPM: post-install phase
*
* You might want to run:
* "emerge --config =dev-db/mysql-5.1.46"
* if this is a new install.
*
>>> Regenerating /etc/ld.so.cache...
>> ## Limpiando: dev-db/mysql-5.1.46
>> @@ Instalación completada.
>> @@ Configuration files scan complete.
Kahn ~ # emerge --config =dev-db/mysql-5.1.46


Configuring pkg...

* You have already a MySQL database in place.
* (///var/lib/mysql/*)
* Please rename or delete it if you wish to replace it.
* ERROR: dev-db/mysql-5.1.46 failed:
* MySQL database already exists!
*
* Call stack:
* ebuild.sh, line 48: Called pkg_config
* environment, line 4256: Called mysql_pkg_config
* environment, line 3798: Called die
* The specific snippet of code:
* die "MySQL database already exists!";
*
* If you need support, post the output of 'emerge --info =dev-db/mysql-5.1.46',
* the complete build log and the output of 'emerge -pqv =dev-db/mysql-5.1.46'.
* This ebuild is from an overlay named 'sabayon': '//var/db/pkg/'
* The complete build log is located at '/var/lib/entropy/logs/dev-db:mysql-5.1.46:20100708-032103.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-db/mysql-5.1.46/temp/environment'.
* S: '/var/tmp/portage/dev-db/mysql-5.1.46/work/mysql-5.1.46'

Kahn ~ #


Hasta aqui todo bien, ahora inicio los servicios:
kahn ~ # /etc/init.d/mysql start
* WARNING: mysql has already been started
Kahn ~ # /etc/init.d/apache2 start
* WARNING: apache2 has already been started
Kahn ~ # /etc/init.d/http start
-su: /etc/init.d/http: No existe el fichero o el directorio
Kahn ~ #


como pueden ver, ya se habian iniciado tanto mysql como apache, pero el servicio http no me aparece, entoces lo trato de instalar:
Kahn ~ # equo install http
>> @@ Calculando dependencias ...
>> ## [R] [sabayonlinux.org] dev-haskell/http-4000.0.8|0 [4000.0.8|0]
>> @@ Paquetes que necesitan ser instalados/actualizados/desactualizados: 1
>> @@ Paquetes que necesitan ser eliminados: 0
>> @@ Tamaño de la descarga: 0b
>> @@ Espacio liberado en disco: 0.0b
>> @@ Necesitas al menos: 929.8kB de espacio libre
>> :: (1/1) >>> dev-haskell/http-4000.0.8
>> ## La comprobación de suma del paquete coincide: dev-haskell:http-4000.0.8~0.tbz2
>> ++ (1/1) >>> dev-haskell/http-4000.0.8
>> ## Desempaquetando el paquete: dev-haskell:http-4000.0.8~0.tbz2
>> ## SPM: pre-remove phase
* Unregistering HTTP-4000.0.8 ... [ ok ]
>> ## Instalando el paquete: dev-haskell/http-4000.0.8
>> ## [A library for client-side HTTP]
>> ## Actualizando en la base de datos: dev-haskell/http-4000.0.8
>> ## Cleaning previously installed information...
>> ## SPM: post-install phase
* CPV: dev-haskell/http-4000.0.8
* REPO:
* USE: elibc_glibc kernel_linux userland_GNU x86
* The package dev-haskell/cabal is not correctly installed for
* the currently active version of ghc (6.10.4). Please
* run ghc-updater or haskell-updater or re-build dev-haskell/cabal.
* ERROR: dev-haskell/http-4000.0.8 failed:
* cabal is not correctly installed
*
* Call stack:
* ebuild.sh, line 48: Called pkg_setup
* environment, line 1661: Called haskell-cabal_pkg_setup
* environment, line 1470: Called die
* The specific snippet of code:
* die "cabal is not correctly installed";
*
* If you need support, post the output of 'emerge --info =dev-haskell/http-4000.0.8',
* the complete build log and the output of 'emerge -pqv =dev-haskell/http-4000.0.8'.
* The complete build log is located at '/var/lib/entropy/logs/dev-haskell:http-4000.0.8:20100708-042555.log'.
* The ebuild environment file is located at '/var/tmp/entropy/packages/x86/5/dev-haskell:http-4000.0.8~0.tbz2/portage/dev-haskell/http-4000.0.8/temp/environment'.
* S: '/var/tmp/entropy/packages/x86/5/dev-haskell:http-4000.0.8~0.tbz2/portage/dev-haskell/http-4000.0.8/work/http-4000.0.8'
* Registering HTTP-4000.0.8 ... [ ok ]
>>> Regenerating /etc/ld.so.cache...
>> ## Limpiando: dev-haskell/http-4000.0.8
>> @@ Instalación completada.
>> @@ Configuration files scan complete.
Kahn ~ #


que estoy haciendo mal??
y aqui es donde no se que es lo que pasa, en el navegador al tipear localhost me aparecen los directorios :
/htdig
/man2html

y debiera aparecerme el mensaje "It's Works" para comprobar que funciona y al teclear en el navegador phpinfo debiera darme la informacion de php para comprobar su instalacion, pero no lo hace.
que puede suceder???

atento a sus comentarios, muchas gracias
yigo1980
Baby Hen
 
Posts: 18
Joined: Tue Apr 27, 2010 18:51

Re: ¿Como instalo Lamp en sabayon 5.2?

Postby ColDrake » Thu Jul 08, 2010 6:31

no se si lo leii aqui o fue en la pagina de archlinux, pero creoo que para poder entrar a la pagina, debes hacer uans configuracion, no se muy bien donde lo lei.. le echare una mirada.. las ultiamso actaulisaciones se cambio todo eso..
Magnifico Tester,donde voy siempre dejo la grande..
ColDrake
Simple Hen
 
Posts: 64
Joined: Wed Jun 02, 2010 2:08

Re: ¿Como instalo Lamp en sabayon 5.2?

Postby DHalens » Thu Jul 08, 2010 14:15

No mezcles entropy y portage si no estas completamente seguro de lo que haces.
Lee bien el mensaje que aparece al instalar php. Habla sobre cómo habilitarlo.
No tengo apenas idea sobre montar un servidor lamp, pero creo que si muestra algo al entrar en localhost, es que está funcionando.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: ¿Como instalo Lamp en sabayon 5.2?

Postby yigo1980 » Thu Jul 08, 2010 20:47

segun estuve viendo, la cosa es que si esta instalado, pero no funciona de la manera en que funcionaba en windows o en Mandriva, puesto que ahi, bastaba con guardar tus archivos php o html en la ruta /var/www/html y visualizabas sin problemas. Aca la cosa va de la siguiente manera /var/www/localhost/htdocs. He guardado los php y html ahi, pero aun no hago funcionar con mysql, apenas tengaa un tiempito lo hago y les cuento como va la cosa.
yigo1980
Baby Hen
 
Posts: 18
Joined: Tue Apr 27, 2010 18:51

Re: ¿Como instalo Lamp en sabayon 5.2?

Postby ColDrake » Fri Jul 09, 2010 3:15

hiciste todos estos pasos??(algo parecido en realidad)
http://wiki.archlinux.org/index.php/LAMP
Magnifico Tester,donde voy siempre dejo la grande..
ColDrake
Simple Hen
 
Posts: 64
Joined: Wed Jun 02, 2010 2:08


Return to Spanish

Who is online

Users browsing this forum: No registered users and 1 guest