[Solucionado / Fix] Problema luego de actualizar sistema

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

[Solucionado / Fix] Problema luego de actualizar sistema

Postby lea_b » Tue Apr 06, 2010 0:02

Hola gente, luego de varios dias de ausencia, al regresar a mi pc, actualize el sistema (algo asi de 360 paquetes nuevos) y luego de la actualizacion empezaron los problemas:

1. el gnome ya no carga adecuadamente, no aparecen los iconos de ninguna app, carga con errores y en color rojo y verde bastante fuerte, no carga el fondo de pantalla.

2. al iniciar el gdm me indica "Ha ocurrido un error al cargar el tema y el tema predeterminado tampoco pudo cargarse. Se intentara iniciar la interfaz de entrada estandar"

tambien otro que dice "Ocurrio un error al cargar el tema Sabayon_Linux"

probe reinstalar gdm pero sin exito

3. otro error es que ya no abre archivos .jpg nautilus indica "No se ha reconocido el formato de imagen del archivo"

alguien sabe como puedo solucionarlo?, probe tmb cambiar el theme y iniciar desde fluxbox, pero sigue con errores.

4. al iniciar emesene desde consola arroja "Libmimic not found, webcam not available
Try to compile it with 'python setup.py build_ext -i' (dev packages required)
Traceback (most recent call last):
File "/usr/bin/emesene", line 33, in <module>
Controller.main()
File "/usr/share/emesene/Controller.py", line 909, in main
controller = Controller(*parseArgs())
File "/usr/share/emesene/Controller.py", line 160, in __init__
self.mainWindow = MainWindow.MainWindow(self)
File "/usr/share/emesene/MainWindow.py", line 79, in __init__
theme.getImage('icon96'))
TypeError: icons must be GdkPixbufs"


ayudas?'
Last edited by lea_b on Tue Apr 06, 2010 13:01, edited 1 time in total.
lea_b
Young Hen
 
Posts: 23
Joined: Mon Jun 08, 2009 15:05

Re: Problema luego de actualizar sistema

Postby DHalens » Tue Apr 06, 2010 0:42

Ni idea de cual puede ser el problema exactamente así que te pongo lo que haría yo: instalar el set de paquetes de gnome, hacer test de dependencias, hacer test de bibliotecas. En comandos:
Code: Select all
equo update && equo install @gnome
equo deptest
equo libtest
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Problema luego de actualizar sistema

Postby lea_b » Tue Apr 06, 2010 1:26

si hice el test de dependencias y librerias y salio OK

tambien reinstale gnome-base/gnome-desktop-2.28.2-r1

pero sin suerte.
lea_b
Young Hen
 
Posts: 23
Joined: Mon Jun 08, 2009 15:05

Re: Problema luego de actualizar sistema

Postby lea_b » Tue Apr 06, 2010 13:00

Bueno he conseguido solucionarlo.

Decidi primero encarar el problema por el lado de los codecs, ya que al no cargar los jpeg ni png supuse que de alli venia el error con todos los themes, reinstale las librerias png y jpeg pero sin suerte.
Luego decidi probar con reinstalar todo lo que sea gtk y alli si tuve suerte y ahora todo funciona correctamente.

sudo equo install x11-themes/gtk-theme-switch-2.0.0_rc2-r2 x11-themes/gtk-engines-murrine-0.90.3-r1 x11-themes/gtk-engines-2.18.4 x11-misc/magneto-gtk-0.99.40.2 x11-misc/efax-gtk-3.0.18 x11-libs/wxGTK-2.8.10.1-r3 x11-libs/gtksourceview-2.8.2 x11-libs/gtksourceview-1.8.5-r1 x11-libs/gtk+-2.18.9 net-libs/webkit-gtk-1.1.15.4 gnome-extra/gtkhtml-3.28.3


reinstalando todo eso, el sistema al reiniciar la sesion funciono OK
lea_b
Young Hen
 
Posts: 23
Joined: Mon Jun 08, 2009 15:05


Return to Spanish

Who is online

Users browsing this forum: No registered users and 1 guest