Instalación de Gambas2 en Sabayon 5.2. [NO SOLUCIONABLE]

Conversaciones generales alrededor Sabayon Linux

Moderator: Moderators

Instalación de Gambas2 en Sabayon 5.2. [NO SOLUCIONABLE]

Postby raregazz » Sat Apr 03, 2010 2:19

Buenas, he instalado la ultima versión de Sabayon Linux en mi portátil (5.2), puesto que estoy aprendiendo algo de programación y me he decantado por Gambas. El problema me surge cuando quiero instalar el IDE desde los repos oficiales ya que existe un paquete con el nombre de Gambas IDE pero lo único que me instala es el Gambas Database Manager.
He intentado realizar la instalación con emerge (emerge gambas)después de sincronizar el repositorio (sync) pero también me fue imposible.
raregazz@raregazz-laptop ~ $ sudo emerge gambas
Contraseña:

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-util/gambas".


* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

raregazz@raregazz-laptop ~ $


Después he intentado compilar el paquete del fuente descargado desde la página oficial del proyecto, inicialmente al realizar el ./configure me indica que faltan dependencias por resolver. Finalmente lo que me indica es lo siguiente.
************************************************************

THESE COMPONENTS ARE DISABLED:

- gb.corba
- gb.db.firebird
- gb.db.postgresql
- gb.db.sqlite2
- gb.qt
- gb.qt.kde
- gb.qte

************************************************************


Aún así, al finalizar la compilación y ejecutar Gambas obtengo lo siguiente.

raregazz@raregazz-laptop ~ gambas2
ERROR: ld.so: object 'libqt-mt.so.3' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: #27: Cannot load component 'gb.qt': cannot find library file
raregazz@raregazz-laptop ~



Las librerias no constan tampoco en los repos oficiales.

Finalmente también he probado un script realizado por la comunidad Gambas en español (aunque es para ubuntu principalmente) y me indica que no se cumplen los requisitos. :cry:

La verdad, no se que más probar, ya que no he encontrado en los foros de internet ninguna respuesta válida.
Por eso recurro a ustedes a ver si alguien me puede ayudar a resolver este problema que no consigo solventar.

Perdonen por la extensión y les doy las gracias anticipadas.

raregazz
Last edited by raregazz on Sun Apr 04, 2010 15:28, edited 6 times in total.
raregazz
Baby Hen
 
Posts: 9
Joined: Sat Apr 03, 2010 1:58

Re: Instalación de Gambas2 en Sabayon 5.2.

Postby DHalens » Sat Apr 03, 2010 11:43

Si no terminas de tener claro cómo manejar portage, lo mejor es que uses entropy (que es el administrador de paquetes propio de sabayon).
gambas-2.X está disponible en entropy y no te dará mas quebraderos de cabeza que ejecutar un comando o hacer un par de clics (dependiendo de si lo instalas con equo o con sulfur).

Eso sí, para evitar destrozar el sistema, usa uno u otro pero no los mezcles.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Instalación de Gambas2 en Sabayon 5.2.

Postby raregazz » Sat Apr 03, 2010 12:03

DHalens wrote:Si no terminas de tener claro cómo manejar portage, lo mejor es que uses entropy (que es el administrador de paquetes propio de sabayon).
gambas-2.X está disponible en entropy y no te dará mas quebraderos de cabeza que ejecutar un comando o hacer un par de clics (dependiendo de si lo instalas con equo o con sulfur).

Eso sí, para evitar destrozar el sistema, usa uno u otro pero no los mezcles.


Gracias DHalen, pero precisamente el primer intento de instalación fue con Entropy (0.99.40) y como comenté si sale un paquete de gambas pero solo instala el Gambas Data Manager (que tampoco corre, como era de esperar).

Image

Estoy desesperado, y no me gustaría tener que cambiar de distro por este problema... :cry:

Un saludo y gracias por la respuesta.
raregazz
Baby Hen
 
Posts: 9
Joined: Sat Apr 03, 2010 1:58

Re: Instalación de Gambas2 en Sabayon 5.2.

Postby DHalens » Sat Apr 03, 2010 17:49

He leído un poco y parece que el ide de gambas2 está hecho con qt3 por lo que no puede ser compilado en Sabayon. qt3 y kde3 fueron eliminados completamente de Sabayon hace unos meses porque era algo inestable comparado con sólo usar qt4 y kde4.

La única opción que queda creo que sería deshacer todas las instalaciones y modificaciones que hayas hecho para intentar instalarlo y posteriormente instalar manualmente la versión en desarrollo (gambas3).

Reportaré la baja utilidad del actual paquete de gambas2 en Sabayon y probablemente sea eliminado del repositorio para evitar que otros usuarios encuentren un problema similar al tuyo.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Instalación de Gambas2 en Sabayon 5.2.

Postby raregazz » Sat Apr 03, 2010 20:11

DHalens wrote:He leído un poco y parece que el ide de gambas2 está hecho con qt3 por lo que no puede ser compilado en Sabayon. qt3 y kde3 fueron eliminados completamente de Sabayon hace unos meses porque era algo inestable comparado con sólo usar qt4 y kde4.

La única opción que queda creo que sería deshacer todas las instalaciones y modificaciones que hayas hecho para intentar instalarlo y posteriormente instalar manualmente la versión en desarrollo (gambas3).

Reportaré la baja utilidad del actual paquete de gambas2 en Sabayon y probablemente sea eliminado del repositorio para evitar que otros usuarios encuentren un problema similar al tuyo.


Buenas DHalens.

Efectivamente has dado en el clavo. He estado "investigando" un poco y precisamente las versiones de gambas estables se basan en librerías qt3, que no son accesibles en la última versión de Sabayon (por eso marqué en rojo la librería del primer post).

He realizado la limpieza de las compilaciones de Gambas2 y he probado a instalar la versión en desarrollo (alfa) de Gambas3 realizándola de forma exitosa. El único inconveniente que he tenido es que mis proyectos anteriores de gambas no son compatibles (es necesario modificarlos para conseguir la compatibilidad total) con esta versión.

De todas maneras considero que todavía esta en una fase muy temprana para su utilización en el desarrollo de aplicaciones (me ha dado varios problemas, es normal puesto que es una alfa). Preveo que la única solución posible será trabajar con alguna distro que use qt3 emulada en VirtualBox ya que no me quiero deshacer de esta gran distribución.

De todas formas, te agradezco encarecidamente tus respuestas, y si puedo contribuir en algo a esta comunidad no dudes en planteármelo.

Gracias y un saludo.

P.D: Estaría bien que eliminasen del repositorio el paquete de Gambas, puesto que puede dar lugar a futuras confusiones. Indícame por favor que debo poner en el título del post, [NO SOLUCIONADO]???? :)

raregazz.
raregazz
Baby Hen
 
Posts: 9
Joined: Sat Apr 03, 2010 1:58

Re: Instalación de Gambas2 en Sabayon 5.2.

Postby DHalens » Sun Apr 04, 2010 2:41

Si quieres contribuir, cualquier cosa que se te ocurra servirá. El equipo de Sabayon es realmente pequeño y hay hueco para gente en cualquiera de los puestos (menos en el de jefe supremo, que está muy solicitado :mrgreen: ).

Respecto al título del post, este pequeño subforo no tiene normas al respecto. A mi se me ocurre que lo mas correcto sería [NO SOLUCIONABLE] pero puedes poner lo que quieras.

PD: Si programas algo medianamente interesante, no dudes en abrir un hilo para hablar sobre el programa y solicitar que sea añadido a Sabayon. :wink:
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Instalación de Gambas2 en Sabayon 5.2.

Postby raregazz » Sun Apr 04, 2010 15:24

DHalens wrote:Si quieres contribuir, cualquier cosa que se te ocurra servirá. El equipo de Sabayon es realmente pequeño y hay hueco para gente en cualquiera de los puestos (menos en el de jefe supremo, que está muy solicitado :mrgreen: ).

Respecto al título del post, este pequeño subforo no tiene normas al respecto. A mi se me ocurre que lo mas correcto sería [NO SOLUCIONABLE] pero puedes poner lo que quieras.

PD: Si programas algo medianamente interesante, no dudes en abrir un hilo para hablar sobre el programa y solicitar que sea añadido a Sabayon. :wink:


Buenas DHalens.

Gracias ante todo por tu pronta respuesta.

Ya veo que a nivel del Spanish Forum, la cosa esta un poco "parada", por lo que si tengo cualquier idea o sugerencia que crea que merezca la pena ser planteada, no dudes que será posteada para así contribuir a esta comunidad.

Por otro lado, de momento aún estoy muy verde con el tema de programación, pero a ver si con un poco de tiempo, empeño, y dedicación, va saliendo alguna cosilla que realmente valga la pena (tengo algunas ideas, pero bueno, a ver que pasa) para ser publicada.

De otra manera, te agradezco encarecidamente el interés que has puesto en el planteamiento de mis dudas, creo que todo foro necesitaría de gente que como tú, que se "molestan" en echar una mano, a gente recientemente ingresada como yo.

Muchas gracias y un saludo desde Galicia.

raregazz.
raregazz
Baby Hen
 
Posts: 9
Joined: Sat Apr 03, 2010 1:58


Return to Spanish

Who is online

Users browsing this forum: No registered users and 1 guest

cron