Page 1 of 1

[RESOLU] Problème de résolution

PostPosted: Thu Jul 05, 2007 16:05
by sinji
Bonjour,

J'ai testé sabayon 3.3 (livedvd) sans l'installer (très joli au passage; je suis accro à beryl maintenant), tout marche bien, même ma carte graphique n'a pas posé de problèmes (contrairement à la version 3.2) mais quand je veux changer de résolution je ne peux pas passer à plus de 1024x800. Je l'ai testé sur mon pc portable, l'écran fait du 1280x800 normalement; (j'ai une ati x1400 si ça peut servir).

Pourriez-vous m'indiquer comment augmenter la résolution (ou me dire si c'est impossible). Merci d'avance ;)

PostPosted: Thu Jul 05, 2007 18:06
by philisse
bonjour

la version 3.4 a simplifié la chose en incorporant Catalyst pour les ATI

lis ton fichier xorg.conf

cat /etc/X11/xorg.conf

il est probable que c'est la plus haute définition paramétrée et que tu es à meme de modifier en indiquant une valeur supérieure

PostPosted: Thu Jul 05, 2007 18:10
by sinji
Oki, la version 3.4 était encore en test donc je ne l'ai pas pris. Je vais essayer de modifier le fichier dont tu me parles.

Merci ^^

PostPosted: Fri Jul 06, 2007 13:59
by sinji
J'ai tester la version 3.4 et ça ne donne pas plus de résultats malheureusement. De plus je ne peux pas lancer le ati control center? Aurais-je plus de chance si je l'installe? Est-il possible que sabayon ne prenne pas en compte les résolution comme la mienne?

Merci de répondre à ces questions, même stupides ^^

PostPosted: Sat Jul 07, 2007 13:39
by turquoise
Peut-être en mettant seulement la résolution désirée dans la section screen du xorg.conf?

PostPosted: Mon Jul 09, 2007 18:24
by webby
avec l'éditeur " nano " .. cela devrais bien fonctionner ! :wink:

nano /etc/X11/xorg.conf

si tu n'y arrive pas , fait un redémarrage ..

ou , dit-nous ton problème !

petit lien pratique pour les résolutions :
http://interfacelift.com/wallpaper/inde ... 680&h=1050

à + .. :wink:

PostPosted: Mon Jul 16, 2007 19:05
by Toudix
Pour t'indiquer plus précisément quoi faire. Pour editer ton Xorg.conf, tu fais ALT + F2, cela ouvre une fenêtre de commande, puis tu tape :
sous KDE
Code: Select all
kdesu kate /etc/X11/xorg.conf

sous Gnome
Code: Select all
gksudo gedit /etc/X11/xorg.conf

Le mot de passe root demandé, sur le LiveCD/DVD est
root
ou ton mot de passe root (configuré à l'install) si tu as installé Sabayon Linux.
En bas de ton xorg.conf, tu trouveras une section Screen :
Code: Select all
Section "Screen"
# The Identifier, Device and Monitor lines must be present
    Identifier   "Screen 1"
    Device   "VESA"
    Monitor   "Generic Monitor"
    #Option "AddARGBGLXVisuals" "true"
# The favoured Depth and/or Bpp may be specified here
    DefaultDepth 24
    SubSection "Display"
        Depth      8
        ViewPort   0 0
        Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
    SubSection "Display"
        Depth           16
        ViewPort        0 0
        Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
    SubSection "Display"
        Depth           24
        ViewPort        0 0
        Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
EndSection
(extrait de mon Xorg.conf sur le LiveDVD de la 3.4 Loop 3).
Tu remarques des Subsection "Display" avec des paramètres : Depth pour la profondeur des couleur (8 / 16 / 24 bits) et des "Modes" qui sont les résolutions configurées. Tu dois donc rentrer ta résolution voulue dans la subsection de la profondeur de couleur voulue (mets la dans toutes comme ça tu ne te poses pas la question). Tu sauvegardes le xorg.conf et tu redémarres le serveur X (Ctrl + Alt + Backspace). Tu ne pourras PAS profiter de tes changements si tu ne redémarres pas le serveur X, c'est indispensable !

PostPosted: Mon Jul 16, 2007 23:49
by sinji
Merci beaucoup à tous pour ces réponses, j'ai réussi à changer la résolution et je peux apprécier tranquillement cet os :)

PostPosted: Tue Jul 17, 2007 5:25
by Toudix
Enjoy !

N'oublie pas de passer ton post en [RESOLU] en éditant ton premier message (et en rajoutant le flag au titre) :)