Blocage au redémarrage [Résolu]

Conversations générales au sujet de Sabayon Linux

Moderator: Moderators

Blocage au redémarrage [Résolu]

Postby gnuwalker » Wed Nov 21, 2012 19:15

Bonjour,
J'ai installé Sabayon X KDE sur un HD interne neuf (Toshiba 500 Go) sans pb mais au redémarrage le chargement bloque à 15% !
Partitionnement standard Sabayon avec LVM et /boot à 500 Mo
Réduction du swapp à 4 Go et augmentation de /home
HD connecté sur prise sata n°1 et DVD sur prise sata n°2

Séquence init :
1 Initializing the kernel
2 Preparing the system for boot
3 set keymap to fr
4 booting the system (15%) et là blocage : ni clavier ni souris, reset au bouton !

J'ai essayé une instal en EXT4 et une autre en XFS : même pb

Comment savoir ce qui coince à 15% ?

En vous remerciant d'avancer pour votre aide
Last edited by gnuwalker on Fri Nov 30, 2012 14:47, edited 1 time in total.
gnuwalker
Baby Hen
 
Posts: 8
Joined: Wed Nov 21, 2012 17:23

Re: Blocage au redémarrage

Postby manifesto » Thu Nov 22, 2012 13:41

Est ce que tu utilise le splash screen de boot ?
Si c est le cas desactive le en changeant les parametres de grub (il faut enlever le quiet/splash de la ligne linux).
Tu devrais avoir les details de ton boot et voir ou ca bloque.
manifesto
Growing Hen
 
Posts: 169
Joined: Mon Jul 19, 2010 22:21

Re: Blocage au redémarrage

Postby gnuwalker » Thu Nov 22, 2012 17:32

Oui, j'ai le bootsplash graphique standard (lancer Sabayon ou options avancées)
en bas de l'écran l'option e affiche les options grub 2
sur la ligne linux il y a avec un splash=silent que je supprime au clavier mais je ne sais pas comment enregistrer cette modif (la touche entrée me renvoie à la ligne); ça a l'air d'être du Emacs et je ne connais pas. En bas de cet écran F10 permet de booter mais je retrouve l'arrêt à 15%
il y a aussi une option c par F2 qui affiche l'invite "grub>"; j'ai essayé initrd mais ça donne : "error: filename expected"
Avec les options avancées je peux lancer en recovery mode; à la fin du chargement je tape ctrl D pour maintenance; Loading module radeon s'affiche et ... freeze du pc, plus de clavier. Je pense que le pb vient de là; c'est un shipset intégré RS690 (X1200). Est-ce qu'on peut désactiver cette étape et comment ?
gnuwalker
Baby Hen
 
Posts: 8
Joined: Wed Nov 21, 2012 17:23

Re: Blocage au redémarrage

Postby gnuwalker » Thu Nov 22, 2012 17:53

Pour info, dans la ligne linux de grub il y a :
video=vesafb:ywrap,mtrr:3 vga=791 gfxpayload=1024x768x16
je suppose que ce sont les paramètres basiques avant la recherche du module radeon et qu'on ne peut pas faire grand chose avec...
gnuwalker
Baby Hen
 
Posts: 8
Joined: Wed Nov 21, 2012 17:23

Re: Blocage au redémarrage

Postby manifesto » Thu Nov 22, 2012 23:06

C'est ennuyeux ces problemes avec les cartes ATI/NV c'est pour ca que je prends du intel !
Sinon tu dois pouvoir essayer de changer le driver mais je connais pas trop les pb ATI.
Pour la modif de grub au boot tu ne peux pas sauvegarder par contre l'editeur est assez basique avec les fleches, clavier et delete sauf que retour ca fait effectivement sauter une ligne.
Pour les parametres il y a des infos la : http://wiki.sabayon.org/index.php?title ... ayon_Linux
Tu devrait de toute facon, bloquer le lancement de X :
1-boot en single (rescue)
2-regarde le nom du service x (je pense xdm )
rc-config show --all
3-disable xdm
rc-update del xdm (tu pourra l'ajouter plus tard avec rc-update add xdm default)
4-Tu regarde le driver utilisé dans le log X11 (/var/log/Xorg.log ou Xorg.0.log)
5 - tu passe à l'autre driver (il y a un open source et un proprio, je pense que tu dois passer de flgxchaipasquoi à l'opensource ati qui est x11-drivers/xf86-video-ati)

Voir les infos la : http://en.gentoo-wiki.com/wiki/Radeon#M ... 11_Drivers
(c'est pour gentoo toi sous sabayon tu recompiles pas)

Regarde la version de ton kernel (uname -r) il y a peut etre des pb en 3.6

En esperant t'avoir aidé !


Pour editer le grub.cfg il faut le faire de l'OS, il y a des details en bas de cette page :
manifesto
Growing Hen
 
Posts: 169
Joined: Mon Jul 19, 2010 22:21

Re: Blocage au redémarrage

Postby gnuwalker » Fri Nov 23, 2012 22:22

"En espérant t'avoir aidé !"
Oui, super coup de main, merci.
Comme c'est un pb de shipset ATI je ne vais pas bidouiller (je ne saurai peut-être pas tout faire); je vais plutôt chercher une carte vidéo PCI d'occas, Sabayon aura les bons pilotes.
En attendant je vais essayer ton lancement sans X, ça peut servir (mais j'espère que non ;-) )
Bonne soirée et encore merci
gnuwalker
Baby Hen
 
Posts: 8
Joined: Wed Nov 21, 2012 17:23

Re: Blocage au redémarrage [résolu]

Postby gnuwalker » Fri Nov 30, 2012 14:47

Pb résolu après ajout d'une carte ATI R5450; ça fait des écrans zarbi au démarrage mais une fois la session ouverte kwin fonctionne avec la rotation du cube activée; seul petit hic : je ne peux pas piloter le cube à la souris (sans doute un pb de driver) tant pis, je me passerai du gadget en espérant que ça ne m'empêche pas de dormir ;-)
à+
gnuwalker
Baby Hen
 
Posts: 8
Joined: Wed Nov 21, 2012 17:23


Return to French

Who is online

Users browsing this forum: No registered users and 2 guests

cron