Keine Installation mit Hybrid-Grafik? [Gelöst]

Allgemeine Gespräche hinsichtlich Sabayon Linux

Moderator: Moderators

Keine Installation mit Hybrid-Grafik? [Gelöst]

Postby pitt » Wed Sep 18, 2013 20:17

Hallo,

ich habe ein neues Notebook mit Hybrid-System, eine Intel HD4000 und eine Nvidia GeForce 660M Grafikkarte.
Leider ist eine Installation nicht möglich, beim start der Live-CD stop das System mit schwarzen Bildschirm und Cursor oben links. Die Optionen nomodeset und noacpi habe ich schon versucht.
Es ist auch zu sehen wie die Auflösung umgeschaltet wird auf der Intel HD4000.

Wer kann mir da mehr sagen, ein Versuch mit 2 anderen Distri zeigte diesen Fehler allerdings nicht.

Gruß
Last edited by pitt on Sat Sep 21, 2013 20:29, edited 1 time in total.
pitt
Baby Hen
 
Posts: 18
Joined: Sun Jun 09, 2013 10:40

Re: Keine Installation mit Hybrid-Grafik?

Postby linuxfluesterer » Thu Sep 19, 2013 6:37

Mal ganz auf die Schnelle:
Wie sind die Bootparameter bei den beiden anderen Distris?
Könntest Du versuchen, mit den selben Werten das Sabayon Live System zu starten?
Anmerkung:Ich habe auch ein Notebook (Acer V3-571G) mit NVidia Optimus 630M und Intel als shared.
Ich habe aber im BIOS die NVidia abgeschaltet (auf 'shared Video' gesetzt), weil mein Rechner immer noch alles schnell genug anzeigt, und ich obendrein noch Energie spare, speziell beim Akkubetrieb. Könnte eine Überlegung wert sein.

-Linuxfluesterer (I love KDE ...)
TTIP is NOT YET stopped. Especially consider NHS and ISDS topics. Talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 699
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Keine Installation mit Hybrid-Grafik?

Postby pitt » Thu Sep 19, 2013 19:42

linuxfluesterer wrote:Mal ganz auf die Schnelle:
Wie sind die Bootparameter bei den beiden anderen Distris?
Könntest Du versuchen, mit den selben Werten das Sabayon Live System zu starten?

Dann bricht der Bootvorgang sofort ab!
Anmerkung:Ich habe auch ein Notebook (Acer V3-571G) mit NVidia Optimus 630M und Intel als shared.
Ich habe aber im BIOS die NVidia abgeschaltet (auf 'shared Video' gesetzt), weil mein Rechner immer noch alles schnell genug anzeigt, und ich obendrein noch Energie spare, speziell beim Akkubetrieb. Könnte eine Überlegung wert sein.

Leider bei mir nicht möglich

Es scheint so das es an initramfs liegt, das Sabayon möglichs alles reingepackt hat und der X-Server durch 2 GK-Treiber hängen bleibt - da erinnere ich mich ein einen früheren Leitfaden von mir "Weniger kann mehr sein".
Im Moment hab ich keine Ahnung was ich noch machen kann :(

Gruß
pitt
Baby Hen
 
Posts: 18
Joined: Sun Jun 09, 2013 10:40

Re: Keine Installation mit Hybrid-Grafik?

Postby linuxfluesterer » Thu Sep 19, 2013 21:06

Du kommst aber doch ins BIOS, oder? Welches Notebook (Typ/Modell) hast Du bitte?

-Linuxfluesterer (I love KDE ...)
TTIP is NOT YET stopped. Especially consider NHS and ISDS topics. Talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 699
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Keine Installation mit Hybrid-Grafik?

Postby pitt » Fri Sep 20, 2013 8:51

linuxfluesterer wrote:Du kommst aber doch ins BIOS, oder? Welches Notebook (Typ/Modell) hast Du bitte?

-Linuxfluesterer (I love KDE ...)

Ja, ins Bios komme ich und mein Notebook ist Tuxedo DX1701. Eine Anfrage beim Hersteller ist schon am laufen.

Gruß
pitt
Baby Hen
 
Posts: 18
Joined: Sun Jun 09, 2013 10:40

Re: Keine Installation mit Hybrid-Grafik?

Postby linuxfluesterer » Fri Sep 20, 2013 12:37

Hallo Pitt.
Um auf meine Grafik zu ändern, boote ich ins BIOS, wie Du hier siehst.
1. Dann gehe auf 'Main' runter (Cursor) auf 'Graphic mode'.

Image

2. Nach <Enter> habe ich ein neues Menu, hier:
Image

3. Mit Cursor auf [Integrated] gehen:
Image

4. <Enter> drücken, und der Graphic mode ist auf [Integrated], sprich Intel, geändert:
Image

Wie Du auch, kann ich nicht mit einem im [Switchable] Modus befindlichen BIOS setting von einem Sabayon Live USB Stick booten. Auch bei mir ist der Bildschirm schwarz und oben links bleibt ein blinkender schwarze Strich, Ende Gelände. Und ich kann mir nur vorstellen, dass nach einem erfolgreichen Boot, wenn man denn was sehen kann, weitere NVidia-Treiber, sowie Bumblebee installiert werden müssen.
Wichtig ist, dass Du irgendwie schaffst, auf Deinen integrierten (vielleicht auch Shared genannten) Grafikmodus gelangst. Dann kannst Du Dein Sabayon installieren und nach Installation fortfahren.
Viel Erfolg.

-Linuxfluesterer (I love KDE ...)
TTIP is NOT YET stopped. Especially consider NHS and ISDS topics. Talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 699
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Keine Installation mit Hybrid-Grafik?

Postby pitt » Fri Sep 20, 2013 20:31

Hallo,

wie ich schon schrieb, mein Bios läßt das nicht zu, gibt es nicht. Eine Anfrage beim Hersteller ob man im Bios die GK abstellen kann erfolgte die Antwort" man solle Bumblebee benutzen" Die Firma TuxedoComputer hats nicht verstanden.

Interresant ist auch das weder Fedore, ubuntu, Debian, Arch und und und keine Probleme haben nur eben Sabayon.
Da werde ich wohl warten bis die merken das es Hybrid-Notebook gibt, sind in Italien wahrscheinlich noch selten anzutreffen!? :mrgreen:

Danke für deine Hilfe.

Viele Grüße
pitt
Baby Hen
 
Posts: 18
Joined: Sun Jun 09, 2013 10:40

Re: Keine Installation mit Hybrid-Grafik?

Postby pitt » Sat Sep 21, 2013 20:29

Hallo linuxfluesterer,

wollte es nicht vorenthalten, mit einer älteren Version, hier Sabayon 13.04, konnte ich das ganze starten und installieren, dann das ganze auf systemd umgestellt und ein langes upgrade durchgeführt und es läuft mit beiden GK. nutze aber nur die Intel.

Gruß und schönes WE
pitt
Baby Hen
 
Posts: 18
Joined: Sun Jun 09, 2013 10:40


Return to German

Who is online

Users browsing this forum: No registered users and 1 guest

cron