Schriftprobleme in Firefox und Gimp [Solved]

Allgemeine Gespräche hinsichtlich Sabayon Linux

Moderator: Moderators

Schriftprobleme in Firefox und Gimp [Solved]

Postby kutte128 » Tue Jan 15, 2013 22:13

Hi,

habe auf mein Laptop (ati opensource) ein Sabayon KDE installiert. Der proprietäre ATI Treiber ünterstützt meine Karte nicht mehr.
KDE sieht toll aus, aber firefox und gimp haben teilweise eine grottenschlechte Schrift.
Gimp ist mit fonts überhaupt nicht nutzbar, Firefox hat beim einer Seite das Problem, dass mache Passagen fett dargestellt werden, manche Zeilen haben einen verlauf von schwarz nach grau. Nach dem markieren ist die Schrift glockenklar. Das passiert jeweils beim öffnen der Seite oder beim scrollen.
Gimp hat mal wieder das Problem mit dem grünen Halo.
Inkscape z.b. funktioniert wunderbar

Hier mal die fontconfig:
Code: Select all
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf *
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-dejavu-sans.conf *
  [10]  20-unhint-small-dejavu-sans-mono.conf *
  [11]  20-unhint-small-dejavu-serif.conf *
  [12]  20-unhint-small-vera.conf *
  [13]  25-ttf-arphic-ukai-render.conf
  [14]  25-ttf-arphic-uming-bitmaps.conf
  [15]  25-ttf-arphic-uming-render.conf
  [16]  25-unhint-nonlatin.conf
  [17]  30-metric-aliases.conf *
  [18]  30-urw-aliases.conf *
  [19]  35-ttf-arphic-ukai-aliases.conf
  [20]  35-ttf-arphic-uming-aliases.conf
  [21]  40-nonlatin.conf *
  [22]  41-ttf-arphic-ukai.conf
  [23]  41-ttf-arphic-uming.conf
  [24]  45-latin.conf *
  [25]  49-sansserif.conf *
  [26]  50-user.conf *
  [27]  51-local.conf *
  [28]  52-infinality.conf *
  [29]  57-dejavu-sans.conf *
  [30]  57-dejavu-sans-mono.conf *
  [31]  57-dejavu-serif.conf *
  [32]  60-latin.conf *
  [33]  60-liberation.conf
  [34]  62-croscore-arimo.conf
  [35]  62-croscore-cousine.conf
  [36]  62-croscore-symbolneu.conf
  [37]  62-croscore-tinos.conf
  [38]  64-ttf-arphic-uming.conf
  [39]  65-fonts-persian.conf *
  [40]  65-khmer.conf
  [41]  65-nonlatin.conf *
  [42]  66-lohit-assamese.conf
  [43]  66-lohit-bengali.conf
  [44]  66-lohit-gujarati.conf
  [45]  66-lohit-hindi.conf
  [46]  66-lohit-kannada.conf
  [47]  66-lohit-kashmiri@devanagari.conf
  [48]  66-lohit-konkani.conf
  [49]  66-lohit-maithili.conf
  [50]  66-lohit-marathi.conf
  [51]  66-lohit-oriya.conf
  [52]  66-lohit-punjabi.conf
  [53]  66-lohit-sindhi@devanagari.conf
  [54]  66-lohit-tamil.conf
  [55]  66-lohit-telugu.conf
  [56]  67-lohit-malayalam.conf
  [57]  67-lohit-nepali.conf
  [58]  69-unifont.conf *
  [59]  70-no-bitmaps.conf *
  [60]  70-yes-bitmaps.conf
  [61]  75-ttf-arphic-ukai-select.conf
  [62]  80-delicious.conf *
  [63]  90-synthetic.conf *
  [64]  90-ttf-arphic-ukai-embolden.conf
  [65]  90-ttf-arphic-uming-embolden.conf
  [66]  99pdftoopvp.conf


an der xorg habe ich nichts geändert und auch sonst ist alles noch wie nach der Installation.
Firefox vorher (Screenshot):
Image


Firefox nachher (Screenshot):
Image
Der Unterschied ist einzig und allein das markieren vom Text.

Gimp (gespeichert):
Image

Woran könnte das liegen?

Viele Grüße,
kutte128
Last edited by kutte128 on Tue Jan 29, 2013 12:56, edited 1 time in total.
kutte128
Simple Hen
 
Posts: 67
Joined: Fri Feb 12, 2010 13:19

Re: Schriftprobleme in Firefox und Gimp

Postby paul » Wed Jan 16, 2013 9:56

Hallo kutte128,

Firefox und Gimp sind beides gtk-Programme. Spontan würde ich also sagen, dass eine Einstellungen in den Systemeinstellungen Abhilfe schaffen würde. Ich bin mir aber im moment gerade nicht sicher, ob das Paket hierfür bei Sabayon vorinstalliert ist (oder ich das nachträglich installiert habe).

Auf jeden findest du es unter "Systemeinstellungen -> Erscheinungsbild von Anwendungen -> GTK-Konfiguration". Dort könnest du versuchen, eine andere Schrift einzustellen.

Wenn dieser Einstellungsreiter nicht vorhanden sein sollte, kannst du ihn über
Code: Select all
equo install kde-gtk-config

nachinstallieren.

Viel Erfolg!
paul
Baby Hen
 
Posts: 15
Joined: Tue Nov 13, 2012 14:49
Location: Germany

Re: Schriftprobleme in Firefox und Gimp

Postby kutte128 » Wed Jan 16, 2013 23:19

Hi,

ja, das ist installiert.
Ich habe auch mal XFCE4 installiert, da habe ich die gleichen Probleme.
kutte128
Simple Hen
 
Posts: 67
Joined: Fri Feb 12, 2010 13:19

Re: Schriftprobleme in Firefox und Gimp

Postby kutte128 » Mon Jan 21, 2013 12:36

Habe jetzt nochmal auf zwei anderen getestet. Am ATI Treiber liegt es schon mal nicht, der eine nutzt nvidia, der andere intel hd.
Ich habe haufenweise Einträge in anderen Foren gefunden, aber keine der "Lösungen" hat was gebracht.
Sowohl das Firefoxprobem als auch das Gimpproblem habe ich überall.
Chromium macht die Schriften auch schön, ich brauche aber Firefox.

Subpixel Rendering habe ich alle 4 versucht und auch mal deaktiviert, keine Änderung. Es ist auch egal welche Schrift ich nutze.
kutte128
Simple Hen
 
Posts: 67
Joined: Fri Feb 12, 2010 13:19

Re: Schriftprobleme in Firefox und Gimp

Postby kutte128 » Mon Jan 21, 2013 15:20

zumindest das Gimpproblem habe ich gelöst.
Ich habe alles aus /etc/fonts/conf.d/ gelöscht und nach und nach wieder aktiviert.
Ich muss
52-infinality.conf
und
50-user.conf
deaktivieren, dann kann ich auch Gimp wieder nutzen.

Allerdings ist Firefox noch immer nicht schön, andere gtk Progs wie Claws-Mail haben keine Probleme
kutte128
Simple Hen
 
Posts: 67
Joined: Fri Feb 12, 2010 13:19


Re: Schriftprobleme in Firefox und Gimp

Postby kutte128 » Wed Jan 23, 2013 10:31

hi,

die sind schon installiert
kutte128
Simple Hen
 
Posts: 67
Joined: Fri Feb 12, 2010 13:19

Re: Schriftprobleme in Firefox und Gimp

Postby Ryuno-Ki » Wed Jan 23, 2013 13:52

Wie steht's mit dem anderen Beitrag von mir?
Get GTK+ programs respect KDE font settings [Solved]
Alle .gtk*-Dateien in $HOME entfernen/umbenennen.
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: Schriftprobleme in Firefox und Gimp

Postby kutte128 » Wed Jan 23, 2013 19:53

Das und ein komplett leeres home war das erste was ich versucht hatte.
Aufgefallen ist mir aber, dass Firefox das nicht überall macht, und auch nicht immer.
Meistens ist z.b. die Fontconfig aus dem gentoo wiki sehr häufig schlecht, manchmal aber nicht.

Ich werd erstmal einen alten FF testen ob der das gleiche problem hat
kutte128
Simple Hen
 
Posts: 67
Joined: Fri Feb 12, 2010 13:19

Re: Schriftprobleme in Firefox und Gimp

Postby kutte128 » Fri Jan 25, 2013 11:26

habe jetzt mal den FF 16 installiert - komplett mit frischem .mozilla und ohne addons.
Der macht keine Probleme. Scheint wohl am FF18 zu hängen
kutte128
Simple Hen
 
Posts: 67
Joined: Fri Feb 12, 2010 13:19

Next

Return to German

Who is online

Users browsing this forum: No registered users and 1 guest