3D NVIDIA [Solved]

Allgemeine Gespräche hinsichtlich Sabayon Linux

Moderator: Moderators

Post Reply
fabdo
Baby Hen
Posts: 18
Joined: Thu Dec 29, 2011 18:49
Location: Germany
Contact:

3D NVIDIA [Solved]

Post by fabdo » Sun Jan 01, 2012 10:05

habe ja nun seit ein paar Tagen hier Sabayon mit Xfce laufen. nun wollte ich dann auch ein paar spiele spielen, doch musste festestellen, das anscheinend gar kein 3D NVIDIA Treiber installiert bzw. aktiviert wurde.

der nvidia treiber (290.10) ist auf der platte und die nvidia-settings habe ich auch schon nachinstalliert.

Code: Select all

[email protected] ~ $ glxinfo | grep direct
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
wenn ich das spiel urbanterror starten will:

Code: Select all

[email protected] ~/fd-daten/games/UrbanTerror $ ./ioUrbanTerror.x86_64
ioQ3 1.35urt linux-x86_64 Dec 21 2007
----- FS_Startup -----
Going through search path...

----------------------
10593 files in pk3 files
execing default.cfg
couldn't exec q3config.cfg
execing autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
Initializing OpenGL display
...setting mode 4: 800 600
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
Couldn't get a visual
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
Couldn't get a visual
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem
wäre toll, wenn mir jemand helfen könnte, denn bisher habe ich weder im forum noch sonst wo, eine anleitung finden können. danke!
Last edited by fabdo on Sun Jan 01, 2012 11:37, edited 1 time in total.

fabdo
Baby Hen
Posts: 18
Joined: Thu Dec 29, 2011 18:49
Location: Germany
Contact:

Re: 3D NVIDIA

Post by fabdo » Sun Jan 01, 2012 11:36

ich konnte mir schon selber helfen.
habe doch eine seite gefunden mit der es geht
http://de.gentoo-wiki.com/wiki/Nvidia#Treiber

die 4 schritte haben funktioniert und geholfen :)

Datei: /etc/make.conf
VIDEO_CARDS="nvidia"

# nvidia-xconfig
# eselect opengl set nvidia
# gpasswd -a DeinBenutzerName video

Post Reply