Beschaedigtes Klient-Repositorium reparieren

Allgemeine Gespräche hinsichtlich Sabayon Linux

Moderator: Moderators

Post Reply
raifi1234
Simple Hen
Posts: 48
Joined: Mon Aug 18, 2008 14:08

Beschaedigtes Klient-Repositorium reparieren

Post by raifi1234 » Wed Jul 06, 2011 16:48

Obwohl Sabayon ein Rolling Release ist, musste ich
Version 6 (64-Bit) neu installieren.

Danach meldete der Magneto-Anwendungs Update Notifier:

sys-apps/portage 2.2.0_alpha37
sys-libs/glibc 2.11.2-r3
sys-devel/gcc 4.5.2

Doch leider:
"Entropy läuft im Sicherheitsmodus: Beschädigtes
Klient-Repositorium. Bitte spiele ein Backup zurück.
Bitte behebe dies so schnell wie möglich"

Darauf hin wird sabyonlinux.org zum Herunterladen angeboten.

Das führt aber zu der folgenden Fehlermeldung:

@@ Repository Synchronisierung ...
# Sabayon Linux Official Repository
# Repositoriums-URL: http://pkg.sabayon.org[/standard/sabayonlinux.org/database/amd64/5
# Lokaler Repositoriums-Pfad: /var/lib/entropy/client/database/amd64/sabayonlinux.org/standard/amd64/5
# Repositoriums-API: 2
Exception in thread Thread-6:
Traceback (most recent call last):
File "/usr/lib64/python2.7/threading.py", line 530, in __bootstrap_inner
self.run()
File "/usr/lib/entropy/libraries/entropy/misc.py", line 353, in run
self.__rc = self.__function(*self.__args, **self.__kwargs)
File "/usr/lib/entropy/sulfur/sulfur/__init__.py", line 1594, in run_up
rc = repoConn.sync()
File "/usr/lib/entropy/libraries/entropy/client/interfaces/repository.py", line 296, in sync
rc = self._run_sync()
File "/usr/lib/entropy/libraries/entropy/client/interfaces/repository.py", line 120, in _run_sync
repo, self.force, self._gpg_feature)
File "/usr/lib/entropy/libraries/entropy/client/interfaces/db.py", line 2398, in update
force, gpg).update()
File "/usr/lib/entropy/libraries/entropy/client/interfaces/db.py", line 1756, in update
locked = self.__handle_repository_lock()
File "/usr/lib/entropy/libraries/entropy/client/interfaces/db.py", line 399, in __handle_repository_lock
unlocked = self._is_repository_unlocked()
File "/usr/lib/entropy/libraries/entropy/client/interfaces/db.py", line 882, in _is_repository_unlocked
rc = self._download_item("lock", disallow_redirect = True)
File "/usr/lib/entropy/libraries/entropy/client/interfaces/db.py", line 868, in _download_item
rc = fetcher.download()
File "/usr/lib/entropy/libraries/entropy/fetchers.py", line 317, in download
status = downloader()
File "/usr/lib/entropy/libraries/entropy/fetchers.py", line 517, in _urllib_download
req = urlmod.Request(url, headers = headers)
File "/usr/lib64/python2.7/urllib2.py", line 205, in __init__
origin_req_host = request_host(self)
File "/usr/lib64/python2.7/urllib2.py", line 179, in request_host
host = urlparse.urlparse(url)[1]
File "/usr/lib64/python2.7/urlparse.py", line 134, in urlparse
tuple = urlsplit(url, scheme, allow_fragments)
File "/usr/lib64/python2.7/urlparse.py", line 182, in urlsplit
raise ValueError("Invalid IPv6 URL")
ValueError: Invalid IPv6 URL

Was tun?

Rainer
--
Rainer Fischer
[email protected]
http://www.raifischer.de

Sisko43
Growing Hen
Posts: 195
Joined: Sun Mar 29, 2009 12:59

Re: Beschaedigtes Klient-Repositorium reparieren

Post by Sisko43 » Wed Jul 06, 2011 18:34

Was ergibt

Code: Select all

eselect python list
Ist python2.7 mit einem Sternchen versehen?

raifi1234
Simple Hen
Posts: 48
Joined: Mon Aug 18, 2008 14:08

Re: Beschaedigtes Klient-Repositorium reparieren

Post by raifi1234 » Thu Jul 07, 2011 8:58

eselect python list ergibt:

Available Python interpreters:
[1] python2.7 *

Fazit: Sternchen vorhanden. Offenbar ist das nicht der Fehler.

BTW: Beim erstmaligen Auftreten des Fehlers
meldete sich der Online-Support und versprach, sich des
Problems anzunehmen.
Bisher kam noch keine Antwort von dort.
Soll ich das Subject auch in die englische Seite posten?

Rainer
Bitte folgene Mailadresse verwenden: [email protected]

raifi1234
Simple Hen
Posts: 48
Joined: Mon Aug 18, 2008 14:08

Re: Beschaedigtes Klient-Repositorium reparieren

Post by raifi1234 » Mon Jul 11, 2011 9:19

Wo bleibt die Hilfe???
equo install entropy liefert:

...
:: (33/36) >>> 3 Pakete
>> ## Paketprüfsumme stimmt überein: sys-libs:db-4.6.21_p4~0.tbz2
>> ## Paketprüfsumme stimmt überein: app-arch:zip-3.0~2.tbz2
>> ## Paketprüfsumme stimmt überein: app-arch:unzip-6.0-r2~0.tbz2
>> :: (34/36) >>> 3 Pakete
>> ## Paketprüfsumme stimmt überein: dev-libs:mpfr-3.0.0_p3~0.tbz2
>> ## Paketprüfsumme stimmt überein: dev-libs:mpc-0.9~0.tbz2
>> ## Paketprüfsumme stimmt überein: media-libs:libart_lgpl-2.3.21-r1~0.tbz2
>> :: (35/36) >>> 3 Pakete
>> ## Paketprüfsumme stimmt überein: sys-devel:gcc-config-1.4.1-r1~0.tbz2
>> ## Paketprüfsumme stimmt überein: sys-devel:gcc-4.5.2~2.tbz2
>> ## Paketprüfsumme stimmt überein: app-misc:sabayon-version-6~0.tbz2
>> :: (36/36) >>> 2 Pakete
>> ## Paketprüfsumme stimmt überein: app-admin:gam-server-0.1.10~0.tbz2
>> ## Paketprüfsumme stimmt überein: app-admin:perl-cleaner-2.8~0.tbz2
>> ++ (1/107) >>> sys-apps/debianutils-3.4.4
>> ## Entpacke Paket: sys-apps:debianutils-3.4.4~0.tbz2
>> ## Installiere Paket: sys-apps/debianutils-3.4.4
>> ## [A selection of tools from Debian]
>> ## Aktualisiere Datenbank: sys-apps/debianutils-3.4.4
>> * cannot execute handlePackage on this repository. Kann nicht weiterarbeiten.

Leider gibt es auf der Install-DVD keine Reparaturoption.

Ratlos - Rainer

raifi1234
Simple Hen
Posts: 48
Joined: Mon Aug 18, 2008 14:08

Re: Beschaedigtes Klient-Repositorium reparieren

Post by raifi1234 » Mon Jul 11, 2011 12:44

Ich bin einen Schritt weiter:

1. Login als root.
2. Zusaetzliche Dienste freischalten.
3. Paketmanager aufrufen.

Heruntergeladen werden u.a. ein neuer 3.6.39er Kernel
und ein nVidia-Treiber .

Nur passen die nicht zueinander ;-((.

raifi1234
Simple Hen
Posts: 48
Joined: Mon Aug 18, 2008 14:08

Re: Beschaedigtes Klient-Repositorium reparieren

Post by raifi1234 » Mon Jul 11, 2011 14:30

Und so endete alles ;-((
HIERMIT MELDE ICH (den offensichtlichen BUG) (s.u.)
...
Entpacke Paket: x11-libs:pixman 0.22.0.
SPM: Traceback (most recent call last):
File /usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugins
licenses = package_metadata.get('accept_license´))
File /usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugins/ild
mysettings = self.get_portage_config(os.path.sep, root)
File /usr/lib/entropy/libraries/entropy/spm/plugins/interfaces/portage_plugins/config
raise SPMError("SPMError: %s" % (repr(e),))
SPMError: SPMError: ParseError()
## QA: Kann Schalter des QuellPaketmanagers nicht ausführen für x11-libs/pixman-0.22.0
## Bitte dies melden. Hänge dies an: /var/log/entropy/entropy.log
## Installiere Paket: x11-libs/pixman-0.22.0
## [Low-level pixel Manipulation routines]
## Aktualisiere Datenbank: x11-libs/pixman-0.22.0
cannot execute handlePackage on this repository. Kann nicht weiterarbeiten

raifi1234
Simple Hen
Posts: 48
Joined: Mon Aug 18, 2008 14:08

Re: Beschaedigtes Klient-Repositorium reparieren [moved]

Post by raifi1234 » Mon Jul 11, 2011 21:16

Thema in das englischsprachige Forum verschoben:
--> entropy update 1.0rc_21 to rc_25 impossible.

Post Reply