Verzerrter Bildschirm mit ATI M880G bei Vollbild [Solved]

Allgemeine Gespräche hinsichtlich Sabayon Linux

Moderator: Moderators

kutte128
Simple Hen
Posts: 67
Joined: Fri Feb 12, 2010 13:19

Re: Verzerrter Bildschirm mit ATI M880G bei Vollbild

Post by kutte128 » Mon Jan 31, 2011 18:01

hmm wenn ich das in die modules eintrage stürzt das teil beim starten schon sehr früh ab. lange bevor der gdm gestartet werden würde. Leider taucht auch nichts in der messages auf, ne Xorg.log wird dann nicht erstellt

so wies aussieht läufts ohne KMS.
Ich muss nur drauf achten, das im Hintergrund keine animierten gifs oder flash ist. das drängt sich bei einigen Anwendungen in den Vordergrund.

Edit:
schade, inksape ist leider mit dem Treiber nicht nutzbar, das wäre aber schon wichtig.

Edit2:
Baaah ist das schlecht.
Sogar mit dem fglrx ist inkscape nicht mehr zu gebrauchen.
Also sollte ich demnächst wieder auf Nvidia GraKas achten.

smb96
Simple Hen
Posts: 70
Joined: Mon Nov 23, 2009 11:44

Re: Verzerrter Bildschirm mit ATI M880G bei Vollbild [Solved

Post by smb96 » Tue Feb 01, 2011 12:56

Also, so richtig erfolgreich war das ja noch nicht. Wenn der PC beim Hochfahren stoppt wenn radeon in /etc/conf.d/modules eingefügt is, is das nen Bug. Ich nehme mal an du kommst nicht an die messages oder dmesg ran wenn der hängen bleibt? Dann könnte man vielleicht etwas forschen. Du sagtest ja das die ati-drivers (fglrx) gelöscht waren als du das probiert hast, stimmts?

Eine Sache kannst du noch probieren, falls noch genug Motivation da ist. Via Portage kann man eine Menge anderer Treiberversionen bekommen. Wenn ich suche bekomme ich das hier:

Code: Select all

 # eix ati-drivers
* x11-drivers/ati-drivers
     Available versions:  
	(0)	(~)8.522-r1[3] (~)8.602[4] (~)8.612[4] (~)9.5[4]
	(1)	[M](~)8.780 (~)10.3-r1[2] (~)10.4[2] (~)10.4-r1[2] (~)10.5-r1[2] (~)10.6[2] 10.8 10.8[1] 10.8[2] 10.8[5] 10.9[1] 10.9[2] 10.9[5] 10.9-r1!d (~)10.9-r1!d[1] (~)10.9-r1!d[5] (~)10.10 (~)10.10[1] 10.10[2] (~)10.10[5] 10.11 (~)10.11[1] (~)10.11[5] (~)10.12 (~)10.12[1] (~)10.12[5]
	{acpi debug kernel_linux +modules multilib qt4}
     Homepage:            http://www.ati.com
     Description:         Ati precompiled drivers for r600 (HD Series) and newer chipsets

[1] "sabayon" /var/lib/layman/sabayon
[2] "gentoo-quebec" layman/gentoo-quebec
[3] "lordvan" layman/lordvan
[4] "pentoo" layman/pentoo
[5] "sabayon" layman/sabayon
jetzt kann man einfach mal ältere Versionen testen, manchmal hilft das. Etwas Vorbarbeit:

Code: Select all

# equo install eix sabayon-sources-2.6.37 && emerge --sync && eix-update && eix-remote update && eix ati-drivers
dann mal als Beispiel den 10.11:
zuerst checken daß uname -a und eselect kernel list den .37er Kernel zeigen.
dann:

Code: Select all

emerge -pv =x11-drivers/ati-drivers-10.11
Wenn das deps zusätzlich will, die mit entropy installieren. Wenn nicht dann das p weglassen und wenn nix schief geht sollte es das gewesen sein.
Anschließend noch ein

Code: Select all

equo rescue spmsync
Dann weiß Entropy auch was da mit Portage gemacht wurde.

den gleichen Spass kann man dann natürlich nach Lust und Laune mit allen anderen Versionen machen. Ich bin mir auch nicht sicher ob das was ändern wird, mir fällt nur leider sonst nix mehr ein was man noch probieren könnte.

kutte128
Simple Hen
Posts: 67
Joined: Fri Feb 12, 2010 13:19

Re: Verzerrter Bildschirm mit ATI M880G bei Vollbild [Solved

Post by kutte128 » Tue Feb 01, 2011 13:49

nun ja, alles in allem läuft die kiste sehr viel besser als mit fglrx :)

dmesg kann ich nicht aurufen und in der messages steht nichts ungewöhnliches drin.
radeon in der modules ist an sich kein Problem, nur in verbindung mit radeon.modeset=1 habe ich den absturz.
jepp,der fglrx ist definitiv gelöscht, auch die reste vom autoinstaller sind entfernt

laut den bugmeldungen bei kernel.org ist das problem mit 2.6.37 bekannt,mit 36 soll es noch funktioniert haben. auch div kernel-patches existieren.
Ich werd den 36er heute im laufe des abends mal testen

kutte128
Simple Hen
Posts: 67
Joined: Fri Feb 12, 2010 13:19

Re: Verzerrter Bildschirm mit ATI M880G bei Vollbild [Solved

Post by kutte128 » Tue Feb 01, 2011 18:30

mit dem 36er Kernel läufts mit modeset und gallium, allerdings ohne framebuffer - was mir aber egal ist.
keine warnungen oder fehler in der Xorg.log

allerdings:
ohne modeset läufts auch hier sehr viel schneller.

also ich bin ohne rundum zufrieden

grüße,
kutte128

Post Reply