Pedindo keymap na inicialização [Resolvido]

Conversações gerais a respeito de Sabayon Linux

Moderator: Moderators

Pedindo keymap na inicialização [Resolvido]

Postby deusr » Wed Jun 18, 2014 5:07

Alguém sabe como faço para parar de pedir escolher uma linguagem no boot do sistema? Isso começou a aparecer depois que fiz uma atualização:

Image
Last edited by deusr on Mon Jun 30, 2014 22:40, edited 1 time in total.
deusr
Growing Hen
 
Posts: 168
Joined: Mon Feb 23, 2009 7:23

Re: Pedindo keymap na inicialização

Postby albfneto » Wed Jun 18, 2014 14:55

Isso é um bug do pacote keymap quando funciona com o systemd. ainda não resolvido.
de início, isso funcionaria bem escolhendo o teclado brasileiro, número 4. Mas se vc fizer isso, ele vai dar mensagem de keymap errado e pode parar o boot.

para vc contornar o problema, edite a linha de boot do kernel em (/boot/grub/grub.cfg) e remova as cheat-codes referentes ao mapa de teclado:

Code: Select all
dokeymap keymap=pt_BR


remova essas linhas, no arquivo /etc/default/sabayon-grub e depois regenere o grub:

Code: Select all
grub2-mkconfig -o /boot/grub/grub.cfg


Detalhes, veja isto:

viewtopic.php?f=56&t=31755

Porém eu descobri uma coisa... se vc só tem um HDD e não usa RAID, remova o cheat-code : "domdadm" ou o coloque com "nomdadm", Isso é feito como acima, só o cheat code é outro... e misteriosamente o mapa de teclado entra normal... é estranho pq "mdadm" é referente somente a RAID, somente ao disco rígido.
Last edited by albfneto on Sat Jun 21, 2014 4:17, edited 1 time in total.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Pedindo keymap na inicialização

Postby deusr » Thu Jun 19, 2014 4:14

Funcionou só com a remoção do "dokeymap keymap=pt-a" de ambos os arquivos, mas quando fui regenerar o grub, olha o que aconteceu!!

Code: Select all
neit talesam # grub2-mkconfig -o /boot/grub/grub.cfg
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Generating grub.cfg ...
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Found background: /boot/grub/default-splash.png
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Found linux image: /boot/kernel-genkernel-x86_64-3.13.0-sabayon
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Found initrd image: /boot/initramfs-genkernel-x86_64-3.13.0-sabayon
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Found linux image: /boot/kernel-genkernel-x86_64-3.9.0-sabayon
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
Found initrd image: /boot/initramfs-genkernel-x86_64-3.9.0-sabayon
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
  No volume groups found
Failed to load ZFS module stack.
Load the module manually by running 'insmod <location>/zfs.ko' as root.
done
neit talesam #


Acho que ta certinho, só não tenho modulo ZFS para carregar, mas estranho aparecer isso!
deusr
Growing Hen
 
Posts: 168
Joined: Mon Feb 23, 2009 7:23

Re: Pedindo keymap na inicialização

Postby albfneto » Sat Jun 21, 2014 4:28

Normal, tá dizendo que seu sistema não tem ZFS, não usa ZFS.È pq o kernel está otimizado para usar ZFS.
se quiser, remova algum serviço que está ativando o ZFS, pode ver com este comando (se for sabayon novo):

Code: Select all
# systemctl status zfs


a seguir remova o módulo zfs:

Code: Select all
# rmmod zfs


e se estiver instalado, remova o pacote ZFS, verifique com cuidado,por causa das deps:

Code: Select all
$ equo s zfs (se estiver instalado o pacote chamado ZFS, execute:)
# equo rm --pretend zfs (se parecer que vão sair muitas deps, faça assim:)
# equo rm --nodeps --pretend zfs (se tudo OK, só ZFS vai sair aí faz)
# equo rm -a --nodeps zfs


Ou simplesmente deixe assim, ele procura o ZFS e não acha.

Se desejar testar ZFS, precisará reinstalar tudo usando, partição com sistema de arquivos ZFS. No meu não o fiz, meu sistema é antigo, é um Sabayon rolado desde o 5.2, tem 4 anos.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Pedindo keymap na inicialização

Postby deusr » Sat Jun 21, 2014 5:03

Ok, muito obrigado!!
deusr
Growing Hen
 
Posts: 168
Joined: Mon Feb 23, 2009 7:23

Re: Pedindo keymap na inicialização

Postby albfneto » Mon Jun 30, 2014 22:09

pode marcar o tópico como resolvido.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil


Return to Portuguese

Who is online

Users browsing this forum: No registered users and 1 guest

cron