Fonts

Algemene gesprekken over Sabayon Linux

Moderator: Moderators

Post Reply
warp4ever
Baby Hen
Posts: 7
Joined: Fri Dec 04, 2009 13:26

Fonts

Post by warp4ever » Sun Dec 06, 2009 23:46

Natuurlijk weer die "fonts"
Ik krijg het maar niet voor elkaar om een vergelijkbaar GUI beeld te krijgen met mijn ander distro's:
Ubuntu, Puppy en Fedora.
De fonts in Sabayon komen ronduit lelijk over, of ik nu Arial, Freesans, Liberation family of zelf het van windos geleende Segoe Ui gebruik, de schuine delen in een letter (M, N, K, W, etc) worden dikker weergegeven.

Ondanks dat mijn systeem/desktop perfect werkt incl emerald/compiz en LCD smooth rendering, stoor ik me nogal aan die vreselijke lettertype weergave.

Is er een oplossing danwel lichtend idee hierover?

dyingmuppet
Growing Hen
Posts: 130
Joined: Sun Jan 07, 2007 15:43
Location: Netherlands

Re: Fonts

Post by dyingmuppet » Tue Jan 05, 2010 9:43

ik denk dat je de dpi waarde moet instellen van je lettertypen, als je niet toevallig al een oplossing hebt gevonden ;)

dit is te vinden in KDE4 onder systemsettings > uiterlijk > lettertype en dan de dropdown voor 120 of 96 dpi, probeer een van de twee en kijk wat jouw het best overkomt.

Grtzz

Crypto_ahash
Young Hen
Posts: 33
Joined: Wed Aug 10, 2011 13:06

Re: Fonts

Post by Crypto_ahash » Wed Aug 10, 2011 19:26

Mijn font configuraties:

Code: Select all

layman -a lcd-filtering
in /etc/make.conf add je:

Code: Select all

 -bindist -cleartype
In /etc/portage/package.use add je:

Code: Select all

##LCD Filtering Overlay
media-libs/fontconfig lcdfilter -cleartype
media-libs/freetype lcdfilter -cleartype
x11-libs/cairo lcdfilter -cleartype
x11-libs/libXft lcdfilter -cleartype
Dan:

Code: Select all

emerge -av1 freetype fontconfig libXft cairo
Mijn ~/.fonts.conf: http://pastebin.com/9Hx1mg33

Misschien even fontconfig aan passen naar:

Code: Select all

eselect fontconfig list
Available fontconfig .conf files (* is enabled):
  [1]   10-antialias.conf
  [2]   10-autohint.conf
  [3]   10-hinting.conf *
  [4]   10-hinting-full.conf
  [5]   10-hinting-medium.conf
  [6]   10-hinting-slight.conf
  [7]   10-no-sub-pixel.conf
  [8]   10-sub-pixel-bgr.conf
  [9]   10-sub-pixel-rgb.conf *
  [10]  10-sub-pixel-vbgr.conf
  [11]  10-sub-pixel-vrgb.conf
  [12]  10-unhinted.conf
  [13]  11-lcd-filter-lcddefault.conf *
  [14]  20-fix-globaladvance.conf
  [15]  20-unhint-small-dejavu-sans.conf
  [16]  20-unhint-small-dejavu-sans-mono.conf
  [17]  20-unhint-small-dejavu-serif.conf
  [18]  20-unhint-small-vera.conf
  [19]  25-unhint-nonlatin.conf
  [20]  30-metric-aliases.conf
  [21]  30-urw-aliases.conf
  [22]  31-cantarell.conf
  [23]  40-nonlatin.conf
  [24]  45-latin.conf
  [25]  49-sansserif.conf
  [26]  50-user.conf *
  [27]  51-local.conf
  [28]  53-monospace-lcd-filter.conf
  [29]  57-dejavu-sans.conf
  [30]  57-dejavu-sans-mono.conf
  [31]  57-dejavu-serif.conf
  [32]  60-latin.conf
  [33]  60-liberation.conf
  [34]  65-culmus.conf
  [35]  65-fonts-persian.conf
  [36]  65-khmer.conf
  [37]  65-nonlatin.conf
  [38]  69-unifont.conf
  [39]  70-no-bitmaps.conf
  [40]  70-yes-bitmaps.conf
  [41]  80-delicious.conf
  [42]  90-synthetic.conf
Restart je X en done. Super mooie gladde font rendering :)
Image

Post Reply