upgrade error with equo [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
User avatar
tazinblack
Baby Hen
Posts: 19
Joined: Wed Jul 19, 2017 8:37

upgrade error with equo [Solved]

Post by tazinblack » Thu Jul 23, 2020 9:25

Hi together,

I'm facing this problem while upgrading:

Code: Select all

  +++ >>>  (15/610) sys-apps/sabayon-lib-migration-1
╠    ## Entpacke: sys-apps:sabayon-lib-migration-1.6af6cdb177132f2c8963216f8b5733b9cd77442c~2.tbz2
╠    ## Installiere Paket: sys-apps/sabayon-lib-migration-1
╠    ## [Migrate lib* as per default/linux/amd64/17.1/desktop]
╠    ## Updating installed packages repository: sys-apps/sabayon-lib-migration-1
╠    ## Package phase: postinstall
lrwxrwxrwx 1 root root      5 Nov  5  2018 /lib -> lib64
drwxr-xr-x 1 root root   1518 Jan 23 16:15 /lib32
drwxr-xr-x 1 root root   5770 Mär  2 07:25 /lib64
lrwxrwxrwx 1 root root      5 Nov  4  2018 /usr/lib -> lib64
drwxr-xr-x 1 root root  64002 Mär  2 07:26 /usr/lib32
drwxr-xr-x 1 root root 116138 Jul 23 10:14 /usr/lib64
drwxr-xr-x 1 root root   3040 Jul 23 10:14 /usr/libexec
 * *******************
 * 
 * migration of lib* will be performed
 * do not interrupt this process
 * 
 * *******************
 * !!!! calling unsymlink-lib --analyze
Traceback (most recent call last):
  File "/usr/bin/unsymlink-lib", line 827, in <module>
    main()
  File "/usr/bin/unsymlink-lib", line 717, in main
    m.analyze(usr_merge, prefixes)
  File "/usr/bin/unsymlink-lib", line 167, in analyze
    from portage import create_trees, _encodings
ImportError: No module named portage
 * The program failed.
Fortunately I took a snapshot before starting the upgrade so I was able to go back to a functional system.
I'm not sure if the

Code: Select all

No module named portage 
is the reason or if it is just an after effect.

Any ideas how to fix this? Help is very appreciated!

Thanks a lot!
Gruß
tazinblack

User avatar
sabayonino
Sagely Hen
Posts: 3555
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: upgrade error with equo

Post by sabayonino » Thu Jul 23, 2020 10:35

There are a lot of discussions about lib migration issue in the forum.
Please check it out

User avatar
tazinblack
Baby Hen
Posts: 19
Joined: Wed Jul 19, 2017 8:37

Re: upgrade error with equo

Post by tazinblack » Fri Jul 24, 2020 8:15

Thanks for the hint.
Shame on me that I did not look around before posting this.

I try to work this out here -> viewtopic.php?f=57&t=35756&p=185920#p185920

And this is the solution, that was working for me -> viewtopic.php?f=57&t=35756&p=185921#p185921
Gruß
tazinblack

Post Reply