Page 1 of 1

Equo upgrade error [Solved]

Posted: Thu Dec 13, 2018 0:17
by denijane
I just reinstalled Sabayon on my new hard and I tried to run
$equo upgrade
but got the following error:

Code: Select all

Source Package Manager is too old, please update it: UsuportedAPIException()
I read somewhere in the forum that the problem is with the stable release and one should use the daily iso, however, it's already installed so I'd like to know if there is any way to repair entropy without reinstalling everything.

Re: Equo upgrade error

Posted: Thu Dec 13, 2018 12:13
by joost
I'd try this:

Code: Select all

equo install equo entropy --relaxed
Then try to upgrade again.

Re: Equo upgrade error

Posted: Thu Dec 13, 2018 17:26
by denijane
Nope,same error

Re: Equo upgrade error

Posted: Thu Dec 13, 2018 18:43
by denijane
Well, I did
#equo install equo entropy --nodeps
#equo install binutils portage --nodeps
#equo upgrade
Still installing. Don't know if it will produce a working OS,but who cares,it's either that or fresh install, lol :)
Edit: Ok, this really helped,system upgraded normally. So yay! :)

Re: Equo upgrade error [Solved]

Posted: Wed Jan 23, 2019 15:31
by ethicalfive
This link should be corrected with this solution. Both me and another user joined the sabayon irc channel (at the exact same time!) with this exact problem while following that wiki( https://wiki.sabayon.org/index.php?title=En:Entropy ) and getting the same error. We were told there is no solution and to download the latest daily. Which would have been quite annoying.