upgrade to sys-apps/portage-2.3.1 [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
pottzie
Young Hen
Posts: 39
Joined: Thu Feb 16, 2012 2:42

upgrade to sys-apps/portage-2.3.1 [Solved]

Post by pottzie » Mon Jan 02, 2017 21:01

I'm installing Sabayon from an older install disc and can't update. I keep seeing "Please update the following critical packages:
☛ # >=sys-apps/portage-2.3.1"

But I haven't found a way to make that happen. How do I get bash to update portage?
Last edited by pottzie on Wed Jan 04, 2017 3:20, edited 1 time in total.

Stupot
Sagely Hen
Posts: 1631
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: upgrade to sys-apps/portage-2.3.1

Post by Stupot » Tue Jan 03, 2017 3:14

If you are using entropy, just stick with that, do your standard equo updates and you'll end up with portage 2.3.1.

Where is it that you're seeing that message? Please give as much information as you can so that we can help you better.

pottzie
Young Hen
Posts: 39
Joined: Thu Feb 16, 2012 2:42

Re: upgrade to sys-apps/portage-2.3.1

Post by pottzie » Tue Jan 03, 2017 4:32

It pretty much comes up 'everywhere.' For instance if I try to follow the guide for a fresh install, I can get it when running 'equo deptest.' It shows that I have a ton of dependancies that need updating, but can't until I update or install sys-apps/portage-2.3.1

The deptest has downloaded everything, but quits with a fatal error. I assume that's what's keeping the deptest from finishing, but I get the sys-apps/portage when I try to do just about anything in the terminal. This is on a fresh install, but it's Sabayon 15! I have a DVD that's installed several times, and works. I just downloaded 17.01 and it wouldn't get past the flash screen or I would have just installed that.

pottzie
Young Hen
Posts: 39
Joined: Thu Feb 16, 2012 2:42

Re: upgrade to sys-apps/portage-2.3.1

Post by pottzie » Tue Jan 03, 2017 21:43

I thought maybe just installing portage would cure it, so I did 'equo install portage.' After portage installed, tried to run 'equo deptest,' and things looked good, but when deptest tried to install packages ( I've switched to weekly mirrors):

Code: Select all

  ## Package phase: setup
☢    ## Source Package Manager is too old, please update it: UnsupportedAPIException()
☢    ## An error occurred. Action aborted.

If this gives a clue to what I've got happening. Still says I need to upgrade sys-apps/portage too

joost
Sagely Hen
Posts: 2669
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: upgrade to sys-apps/portage-2.3.1

Post by joost » Wed Jan 04, 2017 0:36

older install disc
Define old.

pottzie
Young Hen
Posts: 39
Joined: Thu Feb 16, 2012 2:42

Re: upgrade to sys-apps/portage-2.3.1 [Solved]

Post by pottzie » Wed Jan 04, 2017 3:25

Old as in 15 something. And now it's fixed, as I was finally able to get past the UEFI on this (new to me) laptop! Now have 16.07 installed ( I thought 17.01 was what was keeping me from installing, so I downloaded 16.07 thinking it might work instead.) So I marked it solved, and am about to update and hope all goes well.

Post Reply