QT transmission freezes up the laptop

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
User avatar
adRn
Baby Hen
Posts: 11
Joined: Wed Oct 28, 2015 17:58
Location: Buenos Aires, Argentina

QT transmission freezes up the laptop

Post by adRn » Wed Oct 28, 2015 18:07

I'm running sabayon 15.10 KDE amd64. Installed Qt transmission torrent client and works fine until it starts a download and freezes up the whole laptop. Tried it 3 times, cant precise the source of problem.

Completely new here, sorry if posting on bad forums. Searched and only found this, which I think its the exact same problem.

1- What shall I do? How can I debug to see what's happening?

2- How can I avoid it? Shall I try compiling from source? Never done such thing, I'm in the mood of learning but right now I've no time. Anyway, if someone can point me to some guide I'll be glad to go along with it next week.

In the meantime I wanted to install KTorrent but Rigo told me he had to uninstall "Sabayon Arwork KDE" (or similiar) so I cancelled it. Not that I matter a few wallpapers, just that I didn't get why that need...

P.S. I think that a torrent client should be installed by default anyways. Just like we have a music player. Maybe more important, since you can play music on VLC but you cant download torrent without a client :P
running Inspiron 7548 i7-5500U

spylinux
Baby Hen
Posts: 5
Joined: Tue Oct 27, 2015 22:57

Re: QT transmission freezes up the laptop

Post by spylinux » Wed Oct 28, 2015 20:47

I use Sabayon 15.10 with mate, and i have the same problem, i try to download a fila with Transmission, and freeze all my laptop.
I solve uninstall transmission and install other app for torrent. Now i'm using rtorrent, a cli torrent app.

User avatar
adRn
Baby Hen
Posts: 11
Joined: Wed Oct 28, 2015 17:58
Location: Buenos Aires, Argentina

Re: QT transmission freezes up the laptop

Post by adRn » Fri Oct 30, 2015 0:51

Yeah, using tixati here. You have to "manual" install it. Its great and has GUI.

Extract after download: http://download1.tixati.com/download/ti ... all.tar.gz

And you should run the followin as super user to make it avaiable to all users:

cp $PWD/tixati /usr/bin/tixati
cp $PWD/tixati.png /usr/share/icons/hicolor/48x48/apps/tixati.png
cp $PWD/tixati.desktop /usr/share/applications/tixati.desktop
gtk-update-icon-cache
gconftool-2 --set --type=string /desktop/gnome/url-handlers/magnet/command 'tixati "%s"'
gconftool-2 --set --type=string /desktop/gnome/url-handlers/magnet/enabled true
gconftool-2 --set --type=string /desktop/gnome/url-handlers/magnet/need-terminal false
running Inspiron 7548 i7-5500U

Post Reply