glibc upgrade problem [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
redwood
Young Hen
Posts: 25
Joined: Sat Jan 25, 2014 19:20

glibc upgrade problem [Solved]

Post by redwood » Mon Aug 17, 2015 18:55

equo says I need to upgrade glibc from 2.19-r1 to 2.20-r2 and
it won't let me install any other software until I do so.

So after issuing "equo upgrade" I get the following:


>>> (1/21 sys-libs/glibc-2.20-r2
## Unpacking sys-libs:glibc-2.20-r2.5303d576a64ab1b32709b963db4ffc661eccdda~0.tbz2
# Package phase: setup
<builtin>: recipe for 'glibc-test' failed
PIE hardening not applied, as your compiler doesn't default to PIE
!!! Error during package files permissions setup: could not change mode
## An error occurred. Action aborted.

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: glibc upgrade problem

Post by wolfden » Tue Aug 18, 2015 7:16

moved your topic to entropy section of forum

I assume you have done

Code: Select all

equo update

Code: Select all

equo install entropy equo --nodeps

Code: Select all

equo install sys-libs/glibc-2.20-r2

Code: Select all

equo upgrade

redwood
Young Hen
Posts: 25
Joined: Sat Jan 25, 2014 19:20

Re: glibc upgrade problem

Post by redwood » Tue Aug 18, 2015 16:08

Thanks.

I think I missed the step

Code: Select all

equo install entropy equo --nodeps
which fixed the issue.

Post Reply