dev-ruby/rubygems[ruby_targets_ruby19] missing. [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
abadonna
Young Hen
Posts: 24
Joined: Mon Jun 21, 2010 5:49

dev-ruby/rubygems[ruby_targets_ruby19] missing. [Solved]

Post by abadonna » Thu Feb 26, 2015 2:57

After the last update (or the last but one. I am not sure.) dependency test started to give me this error:

Code: Select all

╠  @@ Running dependency test...
╠  @@ These are the dependencies not found:
╠    # dev-ruby/rubygems[ruby_targets_ruby19]
╠       # Needed by:
╠       # virtual/rubygems-4
╠  @@ Installing available packages in 10 seconds ...
☢ No packages found.
Any Idea what is missing and how to fix this?

I have got dev-ruby/rubygems-2.4.5 installed. Looks like 1.9 version is missing...
Last edited by abadonna on Sat Feb 28, 2015 22:42, edited 1 time in total.

joost
Sagely Hen
Posts: 2818
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: Package dev-ruby/rubygems[ruby_targets_ruby19] missing.

Post by joost » Thu Feb 26, 2015 12:38

virtual/rubygems-4 is not in Entropy anymore.

Try: equo upgrade --purge
My blog | Mastodon | Please support Sabayon: Become a Patron

abadonna
Young Hen
Posts: 24
Joined: Mon Jun 21, 2010 5:49

Re: Package dev-ruby/rubygems[ruby_targets_ruby19] missing.

Post by abadonna » Sat Feb 28, 2015 0:30

Did not help. It is still winging...

Stupot
Sagely Hen
Posts: 1815
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Package dev-ruby/rubygems[ruby_targets_ruby19] missing.

Post by Stupot » Sat Feb 28, 2015 19:44

remove rubygems-4 manually to resolve it. What joost gave you should have worked, but this will as well.

Code: Select all

# equo remove virtual/rubygems-4

abadonna
Young Hen
Posts: 24
Joined: Mon Jun 21, 2010 5:49

Re: Package dev-ruby/rubygems[ruby_targets_ruby19] missing.

Post by abadonna » Sat Feb 28, 2015 22:41

Removed.

Looks like the problem is gone.

Thanks

Post Reply