spmsync pull wrong packages

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
skullbocks
Baby Hen
Posts: 19
Joined: Sun Dec 24, 2006 11:53

spmsync pull wrong packages

Post by skullbocks » Mon Jan 12, 2015 2:18

Hi everybody, since I'm installing some packages from portage I want to sync my db with:

Code: Select all

equo rescue spmsync --ask
When I run this command equo told me that I removed with portage the following packages:

Code: Select all

╠     # app-emulation/virtualbox-guest-additions-4.3.20#3.17.0-sabayon
╠     # app-emulation/virtualbox-modules-4.3.20#3.17.0-sabayon
╠     # x11-drivers/xf86-video-virtualbox-4.3.20#3.17.0-sabayon
╠     # sys-power/bbswitch-0.8#3.17.0-sabayon
╠     # app-laptop/nvidiabl-0.83#3.17.0-sabayon
╠     # x11-drivers/nvidia-drivers-340.58#3.17.0-sabayon
╠     # x11-drivers/ati-drivers-14.4#3.17.0-sabayon
But this is the kernel that I'm currently running and I didn't removed those packages using portage.
Did anyone experience with this problem? How could I solve it?
Thank you all for your answers! :D

User avatar
albfneto
Sagely Hen
Posts: 1938
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil
Contact:

Re: spmsync pull wrong packages

Post by albfneto » Tue Jan 13, 2015 0:16

seems to be normal behaviour.
The packages not removed, only info data is removed from one of the databases, in order to compatibilize Entropy with Portage.

This command thau you used is only necessary if you mix Portage with Entropy. If this is the case, remenber to edit /etc/entropy/client.conf and change,in the in line "ignore spmdowgrades", change disable to enable.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE

skullbocks
Baby Hen
Posts: 19
Joined: Sun Dec 24, 2006 11:53

Re: spmsync pull wrong packages

Post by skullbocks » Wed Jan 28, 2015 12:41

Thank you albfneto for your reply. But my problem is different!
I know that mixing the installation method the sync between the two database could cause some little problems, but that's not that case.
I found that kernel-switcher remove those packages from spmdb when switching to another kernel, so If I want to remove them later I need to re-install and then remove those packages. Isn't this a wrong behavior of kernel-switcher?

Post Reply