equo crashing on app-accessibility/brltty-5.1

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
dan.kasak
Baby Hen
Posts: 8
Joined: Tue Nov 15, 2011 7:09

equo crashing on app-accessibility/brltty-5.1

Post by dan.kasak » Fri Dec 19, 2014 0:41

Hi all.

I'm getting the following error while doing an 'equo upgrade"

Code: Select all

╠  +++ >>>  (1/2) app-accessibility/brltty-5.1
╠    ## Unpacking: app-accessibility:brltty-5.1.a2029bf61ff480078c63b0bb35b08b11d9322acc~2.tbz2
╠    ## Package phase: setup
!!! Repository 'anderse' is missing masters attribute in '/var/lib/layman/anderse/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'x-dkasak' is missing masters attribute in '/var/lib/layman/dkasak/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
╠    ## Package phase: preinstall
╠    ## Installing package: app-accessibility/brltty-5.1
╠    ## [Daemon that provides access to the Linux/Unix console for a blind person]
☢ Hi. My name is Bug Reporter. I am sorry to inform you that the program crashed. Well, you know, shit happens.
☢ But there's something you could do to help me to be a better application.
☢ -- BUT, DO NOT SUBMIT THE SAME REPORT MORE THAN ONCE --
☢ Now I am showing you what happened. Don't panic, I'm here to help you.
Traceback (most recent call last):
  File "/usr/bin/equo", line 15, in <module>
    main()
  File "/usr/lib/entropy/client/solo/main.py", line 332, in main
    exit_st = func(*func_args)
  File "/usr/lib/entropy/client/solo/commands/command.py", line 435, in _call_shared
    return func(client)
  File "/usr/lib/entropy/client/solo/commands/install.py", line 192, in _install
    relaxed, multifetch, packages)
  File "/usr/lib/entropy/client/solo/commands/install.py", line 645, in _install_action
    exit_st = pkg.start()
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/action.py", line 218, in start
    exit_st = self._run()
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 260, in _run
    exit_st = method()
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 1361, in _install_phase
    return self._install_phase_unlocked(inst_repo)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 1398, in _install_phase_unlocked
    inst_repo, remove_package_id)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 1268, in _install_package_unlocked
    items_installed, items_not_installed)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 1962, in _move_image_to_system_unlocked
    move_st = workout_file(currentdir, item)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 1755, in workout_file
    protect, mask, protectskip, fromfile, tofile)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/_manage.py", line 336, in _handle_config_protect
    protected = entropy.tools.istextfile(tofile)
  File "/usr/lib/entropy/lib/entropy/tools.py", line 1929, in istextfile
    r = istext(f.read(blocksize))
  File "/usr/lib64/python3.4/codecs.py", line 313, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xe9 in position 96: invalid continuation byte

Frame decode in /usr/lib64/python3.4/codecs.py at line 313
                       input = b"Help: VisioBraille\n\nLes touches du clavier auxiliaire s'utilisent comme sous DOS/Windows.\nLes op\xe9rations de changement de mode d'affichage (6-8 points), de simulation de\ntouches... se font \xe9galement comme sous DOS/Windows.\nEn outre, quelques commandes ~~ suivi d'une lettre sont disponibles,\nreportez-vous au fichier README du r\xe9pertoire VisioBraille pour en savoir\nplus.\n \n"
                       final = False
                        self = <encodings.utf_8.IncrementalDecoder object at 0x7f77b5d57978>
                        data = b"Help: VisioBraille\n\nLes touches du clavier auxiliaire s'utilisent comme sous DOS/Windows.\nLes op\xe9rations de changement de mode d'affichage (6-8 points), de simulation de\ntouches... se font \xe9galement comme sous DOS/Windows.\nEn outre, quelques commandes ~~ suivi d'une lettre sont disponibles,\nreportez-vous au fichier README du r\xe9pertoire VisioBraille pour en savoir\nplus.\n \n"
☢ 
Erm... Can I send the error, along with some other information
about your hardware to my creators so they can fix me? (Your IP will be logged) [Yes/No] Yes
Additionally, the crash reporter appears to be crashing:

Code: Select all

☢ If you want to be contacted back (and actively supported), also answer the questions below:
Your Full name:Daniel Kasak
Your E-Mail address:[email protected]
What you were doing:equo upgrade
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/entropy/lib/entropy/client/interfaces/qa.py", line 83, in submit
    self._webserv.report_error(self.params)
  File "/usr/lib/entropy/lib/entropy/client/services/interfaces.py", line 1490, in report_error
    sio.write(v)
TypeError: string argument expected, got 'bytes'

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/equo", line 15, in <module>
    main()
  File "/usr/lib/entropy/client/solo/main.py", line 332, in main
    exit_st = func(*func_args)
  File "/usr/lib/entropy/client/solo/commands/command.py", line 435, in _call_shared
    return func(client)
  File "/usr/lib/entropy/client/solo/commands/install.py", line 192, in _install
    relaxed, multifetch, packages)
  File "/usr/lib/entropy/client/solo/commands/install.py", line 645, in _install_action
    exit_st = pkg.start()
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/action.py", line 218, in start
    exit_st = self._run()
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 260, in _run
    exit_st = method()
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 1361, in _install_phase
    return self._install_phase_unlocked(inst_repo)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 1398, in _install_phase_unlocked
    inst_repo, remove_package_id)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 1268, in _install_package_unlocked
    items_installed, items_not_installed)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 1962, in _move_image_to_system_unlocked
    move_st = workout_file(currentdir, item)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/install.py", line 1755, in workout_file
    protect, mask, protectskip, fromfile, tofile)
  File "/usr/lib/entropy/lib/entropy/client/interfaces/package/actions/_manage.py", line 336, in _handle_config_protect
    protected = entropy.tools.istextfile(tofile)
  File "/usr/lib/entropy/lib/entropy/tools.py", line 1929, in istextfile
    r = istext(f.read(blocksize))
  File "/usr/lib64/python3.4/codecs.py", line 313, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xe9 in position 96: invalid continuation byte
This is my main development box, so hopefully it's fixable :) Any ideas?

Fitzcarraldo
Sagely Hen
Posts: 8218
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: equo crashing on app-accessibility/brltty-5.1

Post by Fitzcarraldo » Fri Dec 19, 2014 1:02

I don't know why the error is occurring, but I see that the britty package is 'a daemon that provides access to the Linux/Unix console for a blind person'. Are you blind? Do you need that package? If you don't, I would try un-installing it to see if you can then complete the upgrade:

Code: Select all

# equo remove britty
# equo update
# equo upgrade
It might make no difference, but it's worth a shot.

dan.kasak
Baby Hen
Posts: 8
Joined: Tue Nov 15, 2011 7:09

Re: equo crashing on app-accessibility/brltty-5.1

Post by dan.kasak » Fri Dec 19, 2014 1:14

Yeah it occurred to me that I might not need this package, but it's pulled in by qemu, which I most certainly need.

Post Reply