Problems with repositories (again)

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
User avatar
SysOp
Baby Hen
Posts: 16
Joined: Wed Sep 17, 2014 5:11
Location: Brasil
Contact:

Problems with repositories (again)

Post by SysOp » Wed Nov 26, 2014 14:17

Greetings Sabayon community.

Some time ago I published this post a request for help: Problems with repositories [Solved]. Apparently, everything was resolved ... however, the problem came back some time later. As I intended to format the Sabayon, I did, hoping he solved the problem ... not solved. Even reinstalling the OS, it still showing the same message.

Let me describe the problem: first, I try to update the Sabayon repositories using the following command:

Code: Select all

sabayon sysop # equo update
In carrying out the order, it shows the following:

Code: Select all

☛ sabayon-weekly Repository has not been received yet.
☛ sabayon-weekly Repository is not available. Unable to validate
☛ RepositoryError ()
☛ !!! Please update your repositories now to remove this message!
╠@@Sync repositories ...
╠ # Sabayon Linux Official Repository
╠ # URL Repository: http://pkg.sabayon.org/standard/sabayon-weekly/database/amd64/5 [bz2]
╠ # URL Repository: http://pkg.repo.sabayon.org/standard/sabayon-weekly/database/amd64/5 [bz2]
╠ # Local Directory database: / var / lib / entropy / client / database / amd64 / sabayon-weekly / standard / amd64 / 5
╠ # API repository: 2
╠ # (1/2) Checking URL: http://pkg.sabayon.org/standard/sabayon-weekly/dat╠ # URL Selected: http://pkg.sabayon.org/standard/sabayon-weekly/database/ amd64 / 5 [bz2]
╠ Receiving repository database ...
╠ Receiving sum of packages.db.dumplight.bz2.md5 check ...
╠ packages.db.meta: available, IEEI !.
╠ << unpacked target file: 00-sabayon.package.keywords
╠ << unpacked target file: 00-sabayon.package.mask
╠ << unpacked target file: 00-sabayon.package.unmask
╠ << unpacked meta file: 00-sabayon.package.use
╠ << unpacked target file: cross-armv6j-hardfloat-linux-gnueabi
╠ << unpacked target file: cross-ARMv7A-hardfloat-linux-gnueabi
╠ << unpacked target file: cross-ARMv7A-unknown-linux-gnueabi
╠ << unpacked file goal: eAPI
╠ << unpacked target file: make.conf
╠ << unpacked target file: make.profile
╠ << unpacked target file: packages.db.critical
╠ << unpacked target file: packages.db.fallback_mirrors
╠ << unpacked target file: packages.db.keywords
╠ << unpacked target file: packages.db.lic_whitelist
╠ << unpacked target file: packages.db.mask
╠ << unpacked target file: packages.db.mirrors
╠ << unpacked target file: packages.db.post_update.sh
╠ << unpacked target file: packages.db.post_upgrade.sh
╠ << unpacked target file: packages.db.restricted
╠ << unpacked target file: packages.db.revision
╠ << unpacked target file: packages.db.system_mask
╠ << unpacked target file: packages.db.webservices
╠ << unpacked target file: parent
╠ << unpacked target file: signature.asc
╠ Receiving GPG signature of meta-file repository packages.db.meta╠ packages.db.meta.asc: not available, fine.
╠ notice.rss: available, IEEI !.
╠ Review repository: 3109
☢ Receiving repository database: ERROR
☢ An error occurred while checking the repository integrity. giving
☛ sabayon-weekly Repository has not been received yet.
☛ sabayon-weekly Repository is not available. Unable to validate
☛ RepositoryError ()
☛ !!! Please update your repositories now to remove this message!
sabayon sysop #
I do not know if I have stated here, but I have a certain hatred for the Linux terminal. Several times I update the repository to remove this message, but it (obviously) was not removed (you may need to add a few lines of code to equo software for it detects that the problem had not been resolved and suggest alternatives).

So what do I do now?

Apparently, all this is a problem in the GPG keys (a problem that, oddly enough, happens every time I reinstall the Sabayon), but I have no idea how to fix it. PS .: My Sabayon is 14:10 GNOME.

Before all this, I've tried:

Code: Select all

equo update --force
The result was exactly the same as a "equo update" common.

Code: Select all

equo repo mirrorsort sabayon-weekly
This command sorts the repositories according to their connection speed. Still, not solved my problem.
I also tried to update the repositories using Rigo. Also did not solve the problem.

What can I do?

PS2.: Perhaps this has something to do with such a file called "chrony.keys".

Fitzcarraldo
Sagely Hen
Posts: 8218
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Problems with repositories (again)

Post by Fitzcarraldo » Wed Nov 26, 2014 15:47

I have no idea why you're having trouble. Why do you think it has something to do with the file chrony.keys? Chrony is an NTP client, so I don't think it would have a bearing on your problem. However, it would do no harm to remove it:

Code: Select all

# equo remove chrony
Disable the Chrony daemon so that it does not start at boot:

Code: Select all

# systemctl disable chronyd
# timedatectl set-ntp false
Stop the Chrony daemon running now:

Code: Select all

# systemctl stop chronyd
If you want, you could install the NTP client to synchronise your clock. See my blog post Synchronising the clock using NTP in Sabayon Linux. But before you do that, I would recommend that you make sure your installation's time zone and clock have been configured correctly -- see the systemd section (the second section) in my blog post Configuring the Linux clock.

User avatar
albfneto
Sagely Hen
Posts: 1938
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil
Contact:

Re: Problems with repositories (again)

Post by albfneto » Sun Nov 30, 2014 19:08

i dont use the Weekly repo,but i use sabayonlinux.org and limbo.

but i changed the repositories for an while, for testing.

I dont observed this issue. In my system, the repos working normally.

please post the output of these comands:

Code: Select all

# cat /etc/entropy/repositories.conf
# cat  /etc/entropy/repositories.conf.d/entropy_sabayon-weekly
and also these commands:

Code: Select all

# equo repo list
# equo st
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE

Post Reply