Upgrade to systemd-215-r3 broke mount of /home [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
jotbe
Baby Hen
Posts: 3
Joined: Wed May 16, 2012 22:54

Upgrade to systemd-215-r3 broke mount of /home [Solved]

Post by jotbe » Sun Nov 09, 2014 23:06

Just a hint for everybody who ran a Sabayon upgrade lately and got systemd-215-r3 installed. I had the issue that after rebooting my machine, it fell back to emergency mode due to some issues while trying to mount /home. journalctl mentioned an unknown mount option defaultrelatime.

I checked /etc/fstab which had that line in it:

Code: Select all

UUID=xxx /home                   ext4    defaults,x-systemd.device-timeout=0,relatime,discard 1 2
After removing the parameter x-systemd.device-timeout=0, Sabayon booted correctly again. I found out that there is a bug in at least the above mentioned version of systemd which was fixed in versions > 215:

http://cgit.freedesktop.org/systemd/sys ... 36a259d22c

I tried to append the removed option:

Code: Select all

UUID=xxx /home                   ext4    defaults,relatime,discard,x-systemd.device-timeout=0 1 2
That worked. :D

Post Reply