libreoffice equo package depends on xen and xen-tools?

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

libreoffice equo package depends on xen and xen-tools?

Postby ava » Wed May 14, 2014 21:01

Hello,

I was compiling xen-unstable from source, and when I tried to install it I found that I already had a version both of Xen and the toolstack on my system, installed via the xen and xen-tools packages with Equo. I tried to remove them, and found them to be dependencies of libreoffice, jdk, jre and icedtea-web. This surprise cuts off a lot of everyday-use applications from my work environment... I however need to uninstall xen-tools (which is from xen-stable, 4.4), as some of the libraries and scripts would conflict with mainline xen-unstable, which is 4.5; any kind of mismatch between the toolstack (or some of its libraries) and Xen would prevent the toolstack from correctly working. So, that's not a major issue, I will re-install everything I need from source and see if I manage to get it to work.

Forgive me for the really offhand question, does anyone know if those dependencies are really necessary? I was wondering, almost just out of curiosity, if anybody knows what causes such a weird dependency. I don't think any of the applications really rely on Xen, as they all work even if the system hasn't been booted on top of Xen, so I think the dependency is due to some libraries which are included in the xen and xen-tools packages.

--- EDIT ---
So, I tried to do some more research, and it seems that the dependency is not direct. The libreoffice package relies on the jdk, which in its turn relies on jre, which seems to want icedtea. For some reason, icedtea seems to be needing systemtap, which relies on libvirt and xen/xen-tools.
So, the question is still there, but sorry for the previous lack of information.
ava
Baby Hen
 
Posts: 2
Joined: Sat Jan 18, 2014 22:54

Re: libreoffice equo package depends on xen and xen-tools?

Postby Fac3kk » Fri Jun 06, 2014 20:45

I`ve been wondering about the same thing... I tried to install libreoffice and found huge dependency tree which seemed to be strange. Had no time to analyze nor download all that so used google docs, but today I wanted to install jdk on almost fresh 13.05 installation and that`s what equo proposed:

Code: Select all
tlisiecki ~ # equo install virtual/jdk-1.7.0 -p
╠  @@ Calculating dependencies...
╠  @@ These are the packages that would be installed:
╠  ## [N] [sabayon-weekly] media-fonts/lklug-0.6|1
╠  ## [N] [sabayon-weekly] media-fonts/arphicfonts-0.2.20080216.1-r2|0
╠  ## [N] [sabayon-weekly] media-fonts/sazanami-20040629|1
╠  ## [N] [sabayon-weekly] sys-apps/baselayout-java-0.1.0|0
╠  ## [N] [sabayon-weekly] dev-java/java-config-wrapper-0.16|0
╠  ## [N] [sabayon-weekly] dev-java/java-config-2.2.0|0
╠  ## [N] [sabayon-weekly] media-fonts/lohit-fonts-2.4.2|1
╠  ## [N] [sabayon-weekly] media-fonts/baekmuk-fonts-2.2-r2|3
╠  ## [N] [sabayon-weekly] net-libs/libnet-1.2_rc3|0
╠  ## [N] [sabayon-weekly] net-misc/radvd-1.9.8|0
╠  ## [N] [sabayon-weekly] net-firewall/ebtables-2.0.10.4-r1|0
╠  ## [N] [sabayon-weekly] app-misc/scrub-2.5.2|0
╠  ## [N] [sabayon-weekly] media-libs/celt-0.5.1.3|0
╠  ## [N] [sabayon-weekly] app-emulation/spice-0.12.4-r1|0
╠  ## [N] [sabayon-weekly] net-misc/vde-2.3.1|1
╠  ## [N] [sabayon-weekly] sys-cluster/glusterfs-3.4.2-r1|0
╠  ## [N] [sabayon-weekly] x11-libs/vte-0.28.2-r206|0
╠  ## [N] [sabayon-weekly] sys-libs/libseccomp-2.1.1|0
╠  ## [N] [sabayon-weekly] net-libs/libssh2-1.4.3|0
╠  ## [N] [sabayon-weekly] net-misc/bridge-utils-1.5|0
╠  ## [N] [sabayon-weekly] dev-python/cython-0.20.1|0
╠  ## [N] [sabayon-weekly] app-accessibility/flite-1.4-r3|0
╠  ## [N] [sabayon-weekly] gnome-base/gconf-3.2.6-r2|0
╠  ## [N] [sabayon-weekly] dev-libs/libIDL-0.8.14|0
╠  ## [N] [sabayon-weekly] gnome-base/orbit-2.14.19-r3|0
╠  ## [N] [sabayon-weekly] gnome-base/libbonobo-2.24.3|2
╠  ## [N] [sabayon-weekly] gnome-extra/at-spi-1.32.0-r2|0
╠  ## [N] [sabayon-weekly] app-accessibility/brltty-5.0-r2|0
╠  ## [N] [sabayon-weekly] sys-apps/dtc-1.4.0|0
╠  ## [N] [sabayon-weekly] app-emulation/xen-4.4.0|0
╠  ## [N] [sabayon-weekly] app-emulation/xen-tools-4.4.0|0
╠  ## [N] [sabayon-weekly] net-analyzer/netcat6-1.0-r2|2
╠  ## [N] [sabayon-weekly] sys-firmware/vgabios-0.7a|0
╠  ## [N] [sabayon-weekly] app-emulation/spice-protocol-0.12.6|0
╠  ## [N] [sabayon-weekly] sys-firmware/sgabios-0.1_pre8|0
╠  ## [N] [sabayon-weekly] sys-firmware/ipxe-1.0.0_p20130624|0
╠  ## [N] [sabayon-weekly] sys-firmware/seabios-1.7.3.2|0
╠  ## [N] [sabayon-weekly] app-emulation/qemu-2.0.0|0
╠  ## [N] [sabayon-weekly] app-emulation/libvirt-1.2.3|0
╠  ## [N] [sabayon-weekly] dev-util/systemtap-2.4-r1|0
╠  ## [N] [sabayon-weekly] app-admin/eselect-java-0.1.0|0
╠  ## [N] [sabayon-weekly] dev-java/icedtea-7.2.4.7|0
╠  ## [N] [sabayon-weekly] virtual/jre-1.7.0|0
╠  ## [N] [sabayon-weekly] dev-java/icedtea-web-1.3.2-r7|0
╠  ## [N] [sabayon-weekly] virtual/jdk-1.7.0|2
╠  @@ Packages needing to be installed/updated/downgraded: 45
╠  @@ Packages needing to be removed: 0
╠  @@ Packages needing to be installed: 45
╠  @@ Packages needing to be reinstalled: 0
╠  @@ Packages needing to be updated: 0
╠  @@ Packages needing to be downgraded: 0
╠  @@ Download size: 207.8MB
╠  @@ Used disk space: 672.1MB
╠  @@ You need at least: 1087.7MB of free space
╠  @@ No configuration files to update.


Is that really necessary?
Fac3kk
Simple Hen
 
Posts: 67
Joined: Fri Oct 16, 2009 16:26


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron